Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Hullo all. I am typing/editing a doc using the memoir class and Bjornstrup fancy chapter headings. Whenever I try to adjust [shrink] the margins using the geometry package, 'odd' things happen: the bottom right corner of the greyed-in header which is 'behind' [for lack of a better word] the chapter number starts to disappear: bit-by-bit. Here is my attempt to reproduce a MWE:

The first is my ruleofprayer.tex file:

\documentclass[a4paper,12pt,twoside]{book}
\input{preamble}
\begin{document}
\include{chapter1}
\end{document}

Then, here is my preamble.tex file:

\usepackage{lmodern}
\usepackage{geometry}
\usepackage[dvipsnames]{xcolor}
\usepackage{amssymb}
\usepackage{framed}
\usepackage{indentfirst}
\usepackage{changes}
\usepackage[Bjornstrup]{fncychap}
\usepackage[pagestyles]{titlesec}
% % % % % % % % % % % % % % % % % % % % % % % % % % % % % %
\ChNumVar{\fontsize{76}{80}\usefont{OT1}{pzc}{m}{n}\selectfont}
\ChTitleVar{\raggedleft\Huge\sffamily\bfseries}

\titleformat{\section}[display]
{\normalfont\Huge\scshape\mdseries\centering}{}{16pt}{\Large}
\titlespacing*{\section}
{0pt}{20pt}{16pt}

\titleformat{\subsection}
{\normalfont\Large\bfseries\centering}{}{1em}{}
\titlespacing*{\subsection}
{0pt}{3.25ex plus 1.0ex minus 0.2ex}{1.5ex plus 0.2ex}

\titleformat{\subsubsection}
{\normalfont\large\scshape\mdseries\centering}{}{1em}{}
\titlespacing*{\subsubsection}
{0pt}{3.25ex plus 1ex minus .2ex}{1.5ex plus .2ex}

\titlespacing{\section}{0pt}{*2}{*2}
\titlespacing{\subsection}{0pt}{*2}{*2}
% % % % % % % % % % % % % % % % % % % % % % % % % % % % % % 
\geometry{
  left=2.85cm,
  right=2.85cm,
  top=1.95cm,
  bottom=2.25cm
}
% % % % % % % % % % % % % % % % % % % % % % % % % % % % % % 
\newpagestyle{main}{
\headrule
\sethead[\scshape\chaptertitle][][]{}{}{\slshape\chaptertitle}
\setfoot[][\thepage][]{}{\thepage}{}
}
\pagestyle{main}

And finally a brief portion of chapter1.tex:

\chapter{Saturday Evening Prayers}
Towards evening, we stand before the holy icons (having lit a candle and   maybe some incense), with reverence and fear of God; we gather our thoughts, make the Sign of the Cross, and say:

In the Name of the Father, and of the Son, and of the Holy Spirit. Amen.

\begin{framed}
From St. Thomas Sunday until Ascension, instead of \textbf{O God, cleanse me, a sinner \ldots we say:}
Christ is risen from the dead, trampling down death by death, and upon those in the tombs bestowing life.
\end{framed}

Afterwards, we collect our thoughts, and make seven prostrations (or metanoias), saying:

\section*{The Seven--Bow Beginning}

If I leave the geometry package alone (i.e. without any values assigned to it) the greyed-in background turns out as a nice rectangle as it should; only when I attempt to 'meddle' with the geometry and mess with the margins do I encounter the problem. Thanks!

I apologize for not properly splitting the files up before. I hope this clarifies the MWE.

share|improve this question
    
Can you please correct the MWE, since it's not compilable as it stands? –  egreg Feb 21 '13 at 16:43
    
Put the settings for geometry just after the package is loaded, so that the other packages are aware of the changes it makes. Don't use fncychap: just the fact that the chapter issues an overfull \hbox message no matter the settings is a clear indication that the package is buggy. –  egreg Feb 21 '13 at 17:03
    
If I add the settings for geometry after the package loads, then delete the fncychap - How do I obtain the desired chapter heading styles? Also, when I do that I get an error at the line that reads: \ChNumVar{\fontsize{76}{80}\usefont{OT1}{pzc}{m}{n}\selectfont} –  Michael Dykes Feb 21 '13 at 17:56
    
There are many chapter heading styles available in the documentation of memoir. The \ChNumVar and \ChTitleVar commands are specific of fncychap. –  egreg Feb 21 '13 at 18:03
    
Please forgive my ignorance here, but I just tried to use the {\jenor} chapterstyle, and I keep getting an undefined control sequence. I am not sure how to proceed, and (again forgive my lack of knowledge or remembering) I cannot remember how to include some of that code here. Thanks so much! –  Michael Dykes Feb 21 '13 at 18:12
show 2 more comments

1 Answer

You have an ordering problem: you are changing the margins after loading fncychap, which messes up its calculations. Reordering to

\usepackage{geometry}
\geometry{
  left=2.85cm,
  right=2.85cm,
  top=1.95cm,
  bottom=2.25cm
}
\usepackage[Bjornstrup]{fncychap}

fixes the issue.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.