Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am having a little problem with the references of my master thesis. I need to have my references in the text as:

[Mareel and Leroy, 2003; Kintzios, S.E. and Barberaki, M.G., 2004].

or

[Reya et al., 2001].

so in my .tex file I have:

\citep{MareelLeroy, Kintzios}

and in my .bib file:

@article{MareelLeroy,
Author = {Mareel, M. and Leroy, A.},
Title = {{Clinical, cellular, and molecular aspects of cancer invasion}},
Journal = {{Physiological Reviews}},
Year = {{2003}},
Volume = {{83}},
Number = {{2}},
Pages = {{337-376}},
Month = {{Apr}}

}

@article{Reya,
Author = {Reya, T. and Morrison, S.J. and Clarke, M.F. and Weissman, I.L.},
Title = {Stem cells, cancer, and cancer stem cells},
Journal = {Nature},
Year = {2001},
Volume = {414},
Number = {6859},
Pages = {105-111},
Month = {Nov}
}

@BOOK{Kintzios,
title = {Plants that fight cancer},
publisher = {U.S. CRC Press},
year = {2004},
author = {{Kintzios, S.E. and Barberaki, M.G.}}, 
booktitle = {Plants that fight cancer},
pages = {296}
}

In my reference list I get:

Kintzios, S.E. and Barberaki, M.G. Plants that fight cancer. U.S. CRC Press, 2004.

M. Mareel and A. Leroy. Clinical, cellular, and molecular aspects of cancer invasion. Physiological Reviews, 83(2):337–376, Apr 2003.

In the text I have what it should be, but in my reference list I always get the initial in front of the last name. All my references are listed alphabetically on last name, but still the initials are at front. That makes everything quit messy and not very clear.

So, I am looking for a solution: how do I get the initials after the last name but still leaving the reference notation in my text the way it was? So: in my text:

[Mareel and Leroy, 2003; Kintzios, S.E. and Barberaki, M.G., 2004]. and [Reya et al., 2001].

and in my reference list:

Mareel M. and Leroy A. Clinical, cellular, and molecular aspects of cancer invasion. Physiological Reviews, 83(2):337–376, Apr 2003.

???

I already tried some things:

  • I know Kintzios is a book and Mareel an article, but I only have the problem with my articles and so I only need a solution for this

  • I tried to leave out the komma (,) between the last name and the initials in the bib file, but then I only get the initials in my text

  • I tried to switch the last name and the initials of place, that doesn't work either

  • I tried to place dubble { around the authors in the bib file, then I get what I want in the reference list, but the "et al." is lost in my text. So then I get the whole list of authors...

So please, if someone can help me... I tried so long and I don't know what to do now...

A part of my preamble:

\documentclass[11pt, a4paper, twoside, openright]{report}

\usepackage[square]{natbib}
share|improve this question
1  
Welcome to TeX.sx! A tip: If you indent lines by 4 spaces or enclose words in backticks `, they'll be marked as code, as can be seen in my edit. You can also highlight the code and click the "code" button (with "{}" on it). Usually, we don't put a greeting or a "thank you" in our posts. While this might seem strange at first, it is not a sign of lack of politeness, but rather part of our trying to keep everything very concise. –  Kurt Feb 21 '13 at 19:14
    
Thank you for the tips, I'll keep them in mind. I apologise that it's not concise but my file is confidential so I can't post a lot. –  Mus Liselot Feb 21 '13 at 19:21
    
You are welcome and no need to apologise. You can build a MWE with dummy datas. For us is important, which document class you use, which packages with which options you use for your bibliography. Have a look to question minimal working example (MWE) to learn how to build a MWE ... –  Kurt Feb 21 '13 at 19:53
    
I added my preamble, hopefully this might help –  Mus Liselot Feb 21 '13 at 20:27
    
Which bibliography style do you use? –  Mico Feb 21 '13 at 20:30

1 Answer 1

up vote 4 down vote accepted

With the following complete and compiling MWE you should get what you want. After compiling you should have only one warning coming from package filecontents (this warning is okay).

The MWE with your given bib file included (with a little bit pretty printing; for example have a look to the page numbers please):

%http://tex.stackexchange.com/questions/99303/bibtex-natbib-references-harvard-style
\listfiles
\RequirePackage{filecontents}
%\jobname gets the filename of your tex file \jobname.tex 
\begin{filecontents*}{\jobname.bib}
@article{MareelLeroy,
  Author  = {Mareel, M. and Leroy, A.},
  Title   = {Clinical, cellular, and molecular aspects of cancer invasion},
  Journal = {Physiological Reviews},
  Year    = {2003},
  Volume  = {83},
  Number  = {2},
  Pages   = {337--376},
  Month   = {Apr},
}

@article{Reya,
  Author  = {Reya, T. and Morrison, S.J. and Clarke, M.F. and Weissman, I.L.},
  Title   = {Stem cells, cancer, and cancer stem cells},
  Journal = {Nature},
  Year    = {2001},
  Volume  = {414},
  Number  = {6859},
  Pages   = {105--111},
  Month   = {Nov},
}

@BOOK{Kintzios,
  author    = {Kintzios, S.E. and Barberaki, M.G.}, 
  title     = {Plants that fight cancer},
  publisher = {U.S. CRC Press},
  year      = {2004},
  booktitle = {Plants that fight cancer},
  pages     = {296},
}
\end{filecontents*}


\documentclass[a5paper]{article}

\usepackage{natbib}


\begin{document}

Cited with macro \texttt{citep}: \citep{MareelLeroy, Kintzios, Reya}.  
Cited with macro \texttt{citet}: \citet{MareelLeroy, Kintzios, Reya}.  
Cited with macro \texttt{cite}: \cite{MareelLeroy, Kintzios, Reya}.  

\bibliographystyle{agsm} % Alternative: agsm, plainnat
\bibliography{\jobname}

\end{document} 

That gives me as result the following pdf file:

Result of MWE

share|improve this answer
    
So I put: \RequirePackage{filecontents} in my preamble and I put \begin{filecontents*}{\jobname.bib} and \end{filecontents*} around all my references? (I work with seperated files and I have 1 file which puts it al together with the code \input{Bibliografie} for exapmle) –  Mus Liselot Feb 21 '13 at 20:37
    
No. Package filecontents is specially for MWEs so that you are able to include different files like bib file and tex file in one tex file. Follow the link to read the documentation ... In your tex document you just call your bib file bronnen.bib as you did. –  Kurt Feb 21 '13 at 20:42
    
Thank you so much! It worked! I just changed "plainnat" in "agsm" and it is like I want. Thank you so much! –  Mus Liselot Feb 23 '13 at 18:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.