Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have a problem. Using WinEdt try to make my bibliography with the bibtex file. But get the following message

This is BibTeX, Version 0.99c (MiKTeX 2.8)
The top-level auxiliary file: report_q_cdc11.aux
The style file: unsrt.bst
I couldn't open database file biblio/1755988.bib
---line 62 of file report_q_cdc11.aux
: \bibdata{biblio/1755988
:                        }
I'm skipping whatever remains of this command
I found no database files---while reading file report_q_cdc11.aux
(There were 2 error messages)

Could you please tell me, what can be wrong? This bibtex file I just downloaded from web.

share|improve this question

3 Answers 3

up vote 1 down vote accepted

use this test file and also controll that your bibfile is readable and in the correct subdirectory. What happens?

\documentclass{article}

\begin{document}

\nocite{*}
\bibliographystyle{plain}
\bibliography{biblio/1755988}

\end{document}
share|improve this answer
    
Command Line: bibtex.exe "test" This is BibTeX, Version 0.99c (MiKTeX 2.8) The top-level auxiliary file: test.aux The style file: plain.bst I couldn't open database file biblio/1755988.bib ---line 4 of file test.aux : \bibdata{biblio/1755988 : } I'm skipping whatever remains of this command I found no database files---while reading file test.aux (There were 2 error messages) –  Ilya Jan 31 '11 at 13:35
    
@Gortaur please copy the bib file into your document directory and use \bibliography{1755988}. Same problem? –  Herbert Jan 31 '11 at 13:42
    
Yes, unfortunately. It even writes "I couldn't open database file biblio/1755988.bib" though I changed the syntax in accordance to your advise. Maybe I need to change some preferences in WinEdt (it's the first time I try to use BiBTeX with WinEdt). –  Ilya Jan 31 '11 at 13:46
    
@Gortaur, sure because you didn't run the document twice. You can also delete the *.aux file to be sure, that not the old bib filename is read. –  Herbert Jan 31 '11 at 13:48
    
Thanks, now it works only with \nocite{*}. What is it? –  Ilya Jan 31 '11 at 14:04

It seems your bibliography file (1755988.bib) is either misspelled, or missing. Check whether it is in the biblio folder in the directory where you are compiling the .tex file.

You need to hunt the

\bibliography{biblio/1755988}

line in your source code, and see whether it corresponds to the .bib file you're trying to use.

share|improve this answer
    
I wrote \bibliography{biblio/1755988} rather then \bibliography{biblio/1755988.bib} - but when I fixed ".bib" the situation has not changed. The file is in the same folder. –  Ilya Jan 31 '11 at 13:27
    
@Gortaur: You mean the 1755988.bib file is in the biblio folder? If yes, then you'll need to write a short minimum example that illustrates the issue. –  Martin Tapankov Jan 31 '11 at 13:35

As a last remedy, you can run DebugView. Set the variable MIKTEX_TRACE, e.g.

Set MIKTEX_TRACE=access,curl,error,process,config,env,filesearch,files,core,tempfile

from a command prompt and run bibtex on your aux file. Investigate the trace log in the DebugView window. This will certainly locate what the problem is caused by. Note that WinEdt 6 makes it possible to set MIKTEX_TRACE through winEdt menu: Options | Execution Modes | Variable.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.