TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Update 2: I've found the same error report here: http://latex-community.org/forum/viewtopic.php?t=11957&f=19 However this individual is using LyX and I'm using TeXWorks. So "So it seems the error has something to do with Pk rendering and by selecting Dvips from the menu -> View -> Render method, Yap no longer complains about the postscript specials. I am not sure yet exactly why this error occurs (maybe because it needs ghostscript installed somewhere specific)." by mainiacfreakus Isn't advice that works for me...

Update 1: I uninstalled and re-installed my MikTeX distribution to no avail.

What to do now?

So I finally figured out how to get the --shell-escape option into the into the -tex-option= line under Edit->Preferences->Typesetting in TeXWorks and load the auto-pst-pdf package. This information saturates the internet and - at the same time - is nowhere to be found. (I figure this process is a sort of hazing ritual for those new to PSTricks.) But now no PS graphics appear in the PDF or DVI after compiling.

I'm attempting to put some simple graphs into a document.

Here is an example of code that doesn't work.


\RequirePackage{amstext}[1995/01/25] \RequirePackage{amsbsy}[1995/01/20]
\RequirePackage{amsopn}[1995/01/20] \RequirePackage{amsgen}


This is a test document.



When I open up the DVI I find the following error report:

MiKTeX Problem Report
Message: Some PostScript specials could not be rendered.
Data: Error: /undefined in tx@Dict
Operand stack:
   --nostringval--   PermitFileReading   --nostringval--   PermitFileWriting   --nostringval--   -39321600   -39321600   39321600   39321600   5594037   0   5594037
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   1914   1   3   %oparray_pop   1913   1   3   %oparray_pop   1897   1   3   %oparray_pop   1787   1   3   %oparray_pop   --nostringval--   %errorexec_pop   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--
Dictionary stack:
   --dict:1166/1684(ro)(G)--   --dict:0/20(G)--   --dict:78/200(L)--   --dict:95/300(L)--   --dict:37/200(L)--
Current allocation mode is local
MiKTeX GPL Ghostscript  9.00: Unrecoverable error, exit code 1

Source: Libraries\MiKTeX\Dvi\Ghostscript.cpp
Line: 372
MiKTeX: 2.9
OS: Microsoft Windows 7 Home Premium Edition, 64-bit Service Pack 1 (build 7601)
Invokers: explorer
SystemAdmin: no
PowerUser: no
Root0: C:\Users\Mike\AppData\Roaming\MiKTeX\2.9
Root1: C:\Users\Mike\AppData\Local\MiKTeX\2.9
Root2: C:\ProgramData\MiKTeX\2.9
Root3: C:\Program Files (x86)\MiKTeX 2.9
UserInstall: C:\Users\Mike\AppData\Roaming\MiKTeX\2.9
UserConfig: C:\Users\Mike\AppData\Roaming\MiKTeX\2.9
UserData: C:\Users\Mike\AppData\Local\MiKTeX\2.9
CommonInstall: C:\Program Files (x86)\MiKTeX 2.9
CommonConfig: C:\ProgramData\MiKTeX\2.9
CommonData: C:\ProgramData\MiKTeX\2.9
share|improve this question
Welcome to TeX.sx! Please add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}. – egreg Feb 23 '13 at 22:55
Thanks for the welcome egreg. – Mike Feb 23 '13 at 23:11
This test code actually produces two PDFs now. One with the text - one with the graphic. The PDF with the text has the title 'test' because I named it that. The one with the graphic has the title 'test-autopp'. – Mike Feb 23 '13 at 23:14
I have no problem with Ghostscript; however, align typesets twice its contents, so it's confusing auto-pst-pdf. Do you really need align? equation seems the best, for a single diagram. – egreg Feb 23 '13 at 23:17
I suppose I don't need align. However the rendering issue persists with or without. – Mike Feb 23 '13 at 23:24

The setting of TeXworks should be like:

enter image description here

Then I have no problem with your example. I used current TeXLive 2012 under Linux. With MikTeX it should be the same.

share|improve this answer

Try this, it is an answer which came up on google.

You need render >> method = dvips. You can change the default in Options.

share|improve this answer
Welcome to TeX.sx! As it stands now, you wrote more a comment than an answer (I know, you do not have enough reputation for writing comment). Please write more elaborate: In what program this option must be changed on which place? Are there perhaps additional steps or caveats? – Speravir Feb 24 '13 at 21:36
See Update 2 above. I've never used LyX and don't really want to. I would rather learn LaTeX. – Mike Feb 24 '13 at 22:11

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.