Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I write in British English and occasionally I get an overfull hbox warning because LaTeX does not know how to break a word correctly in its British form. For example, the word 'analysing' causes an overfull hbox because LaTeX will not break the word, whereas 'analyzing' is broken into 'analyz-ing' and the hbox warning goes away. what is the best solution to this? Is there a way to have LaTeX recognise British English and correctly break words?

share|improve this question
2  
Did you forget to load the babel package? Otherwise, you will be using the default American hyphenation patterns which indeed do not break "analysing". You see which hyphens are allowed by \showhyphens{analysing} etc. and add new hyphenations with the \hyphenation command. –  Andrew Swann Feb 24 '13 at 13:43
add comment

1 Answer 1

up vote 9 down vote accepted

Load babel with the british option (simply using english won't work).

\documentclass{article}

\usepackage[american,british]{babel}

\textwidth 30pt% just for the example

\begin{document}

xxx analysing

\selectlanguage{american}

xxx analysing

\end{document}​

enter image description here

EDIT: Here's a solution in case you're using XeLaTeX/polyglossia:

\documentclass{article}

\usepackage{polyglossia}
\setmainlanguage[variant=british]{english}

\textwidth 30pt% just for the example

\begin{document}

xxx analysing

\end{document}​
share|improve this answer
    
I did this and my biblatex-chicago package stopped working, so I loaded [american,british,english] as options for babel, which fixed it. –  David Rowthorn Feb 25 '13 at 15:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.