TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Does anyone (not to specifically ask Christian) know if the prerequisite PGF/TikZ version listed in the PGFPlots manual is off by a bit? I've been trying to use \tikzset{external/mode=list and make} and then make -f <texfile>.makefile to generate my images externally. The images were not being created and I was getting an undefined control sequence error in the image log files.

The PGFPlots manual for version 1.7 that I have said it needs PGF 2.0. I had version 2.0 from June 2, 2010 installed at the time. I just upgraded to PGF 2.10 and then my process worked. I also did not see the section "Externalization Library" in the PGF 2.0 manual, but it does appear in the 2.1 manual.

EDIT: This is the code I had been testing with:


\tikzset{external/mode=list and make}
            child {node{left}}
            child {node{right}
                child {node{child}}
                child {node{child}}
A simiple image is \tikz \fill (0,0) circle(5pt);.

This code did not work with my 2010 version of PGF 2.0, but worked when I upgraded to PGF 2.1.

share|improve this question
it depends on whether you actually have an error in the code, or if it is related to pgfplots. It is hard to tell without any information. Please first try and compile without the external library, if that works, have you then remembered to enable write18? If yes, we need to see some log-output. – zeroth Feb 25 '13 at 18:21
@zeroth well there isn't an error in the code, like i said, it works with no problem now. the only thing i changed to make it work was the installed version of pgf/tikz. i'll add the code i was testing with for good measure, i didn't think a mwe was needed for code that works. – aeroNotAuto Feb 25 '13 at 18:42
Ok, I had mistaken your comment about upgrading as another thing. A problem that is in maintaining the pgfplots manual is that there are a couple of places where version compatibilities are mentioned. However, one should typically have them updated simultaneously. pgfplots gets updated more frequently, and as Christian is also a developer on pgf it is hard to guard against all cases. (However, in my previous version of the manual 1.6.1, it said that it required 2.10?, also in the CTAN manual, which is 1.7) – zeroth Feb 25 '13 at 18:56
@zeroth oh all right, i just wanted to make sure it was the documentation and not something silly i was doing. i wasn't sure if my solution (upgrading) was robust/supposed to work. now i know it needs 2.10, and hopefully anyone that finds this through a search engine will as well. – aeroNotAuto Feb 25 '13 at 19:03
up vote 3 down vote accepted

Well, pgfplots always works best if you operate against the most recent stable of PGF. At least that is the plan. The manual of the current stable of pgfplots (1.7) claims that it should run against PGF 2.00 - it does not and I am sorry for it.

I will restore compatibility with PGF 2.00 for the next release of pgfplots.

Nevertheless, it is good practice to upgrade the distributions to the latest stable versions.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.