3
votes
1answer
90 views

XeLaTeX hang when using specific math symbols

I am using XeLaTeX in conjunction with amsmath and unicode-math for my reports. After a while, I ran into a weird problem in which compilation would just hang indefinitely. I found out the culprit was ...
2
votes
0answers
15 views

Error using split within an equation [duplicate]

I am getting multiple errors for using split within an equation. I use this command in a number of other places throughout my LaTeX document, but there is one case in which many errors are given ...
5
votes
1answer
479 views

`missing $ inserted` Error when not putting $ before and after array environment

Considering this answer I added $ before and after the array, i. e. before \begin{array} and after \end{array} in the following code. Then the former missing $ inserted Error was gone. ...
4
votes
1answer
652 views

What does “Limit controls must follow a math operator” mean?

When I try to compile this: \documentclass{article} \usepackage{amsmath} \usepackage{nath} \DeclareMathOperator{\argmin}{arg\,min} \begin{document} \begin{equation} \argmin ...
0
votes
0answers
28 views

Undefined control sequence error when using \abs [duplicate]

I have the following line of code that is throwing up an undefined control sequence error: \begin{equation} \vec{N} = \frac{\vec{T'}(t)}{\abs{\vec{T'}(t)}} \end{equation} The problem is with the ...
3
votes
2answers
677 views

! Package amsmath Error: \tag not allowed here

I want to use \tag in my LaTex file at https://www.sharelatex.com/. For example, I want to do: If $x \equiv x' \pmod{N}$ and $y \equiv y' \pmod{N}$, then: $xy \equiv x'y' \pmod{N}\tag{Substitution ...
5
votes
0answers
363 views

Miktex amsfont problem: \scriptfont is undefined [duplicate]

Today, After updating Miktex system, I have trouble with error \scriptfont is undefined. So I tried to reinstall Miktex 2.9.4813 (32 bit version). Everything OK, but again after updating, problem is ...
1
vote
1answer
1k views

Undefined control sequence for equation

I am running into the error message !Undefined control sequence with the below explanation and can't figure out what I'm doing wrong. I am using Mactex and Texmaker. I am new to LaTeX and would really ...
6
votes
1answer
801 views

“Extra \fi” errors in equation environment with savetrees

I get the Extra \fi error for the \end{equation} line in the following code. \documentclass{article} \usepackage[utf8]{inputenc} \usepackage{savetrees} \usepackage{amsmath} \begin{document} ...
4
votes
2answers
1k views

Unhelpful, misleading errors in amsmath environments

With the simple equation environment; \documentclass{article} \usepackage{amsmath} \begin{document} \begin{equation} a \foo b \end{equation} \end{document} you can see a helpful error message, ...
2
votes
1answer
2k views

Missing $ error in math mode

I have the following LaTeX code (beginning from line 80): \begin{definition} $\hat{n}_{v}$ = \begin{cases} $n_{v}$ & \text{ if } $v \in$ \text{connected component of size} $< ...
8
votes
1answer
304 views

Makeindex error when ! used in \index in align environment

See MWE below. The symbol ! in the \index causes an error. This is only the case in align environments (not in equation). So it seems to have to do something with amsmath. If ! is put in an \mbox ...
12
votes
1answer
510 views

Lost labels using intertext with varioref and hyperref

I have a problem using \intertext together with \vref when hyperref is also used. Consider the following minimal example: \documentclass{article} \usepackage{amsmath, varioref} ...
1
vote
1answer
906 views

Error using the package makeidx

My index is working smoothly with the command \makeindex alone. However, when I put \usepackage{makeidx}\makeindex compilation gives two errors as 1. Command \see already defined. ...
2
votes
1answer
10k views

Any reason why \blacksquare and \box are causing errors?

I am using the amsmath package. I just want a black box at the end of a proof, right-justified. \blacksquare and \box both cause errors. Actually, I'd prefer a musical quarter note if that's ...
2
votes
2answers
241 views

Unable to include equation featuring special symbols

I am designing an article, and using the amsmath package. I tried to use the following to include an equation in my document: \begin{equation} |\psi\rangle = \alpha|0\rangle + \beta|1\rangle ...
0
votes
2answers
2k views

The argument of foo has an extra }.

I'm trying to write a command that does, effectively, an \fbox in something like an align environment. The following code works: \usepackage{etextools} \makeatletter ...
6
votes
1answer
23k views

using subequations

I have an equation consisting of two parts and would like to use subequation for that. Here's the code: \usepackage{amsmath} \begin{subequations} \begin{equation} \operatorname{min}_{a,b,c} ...
2
votes
2answers
404 views

Why does \everydisplay conflict with gather and multline

When gather* is used together with \everydisplay an error is produced. Is there a possibility to make these work together? Minimal working example: \documentclass{ctexart} \usepackage{amsmath,color} ...
8
votes
1answer
734 views

Amsmath has problems with $e^{\sum{x}}$

Running the code: \documentclass{article} \usepackage{amsmath} \begin{document} Test: $e^{\sum{x}}$ \end{document} Dies, yet it runs just fine with the \usepackage{amsmath} commented out. The logs ...
3
votes
2answers
4k views

alignat problem

Whenever I try to use the alignat environment, it doesn't seem to work on my computer! I tried the following simple code (my file had \usepackage{amsmath}): \begin{alignat}{3} \min \quad x_1 ...