0
votes
0answers
16 views

How to debug the “Argument of \XC@definec@lor has an extra }” error in Foreach statement? [duplicate]

First, I draw three nodes each of which has three parts. Everything is OK. The code and the image are as follows. \documentclass{article} \usepackage[utf8]{inputenc} \usepackage[]{tikz} ...
3
votes
2answers
350 views

TikZ error for externalized graphics but output is correct

This is not an MWE per se, but it is the code I boiled the problem down to. Note: it does not produce an error. The issue is that once I somehow managed to get an error for any TikZ or pgfplots ...
6
votes
1answer
96 views

Strange result in plotting data using pgfplots

I'm trying to plot this: \begin{tikzpicture} \begin{axis}[ height=5cm, width=\linewidth] \addplot[smooth,blue] plot coordinates { (27,177) (28,223) (29,240) (30,227) ...
2
votes
0answers
109 views

TikZ dash pattern generates an offending PDF [closed]

Consider the following MWE: \documentclass{standalone} \usepackage{tikz} \begin{document} \def\dotsize{1} \def\spacesize{2} \def\linesize{4} \begin{tikzpicture}[% dash pattern=% on \dotsize pt ...
2
votes
0answers
56 views

Error with $ when using math in TikZ figure [duplicate]

I am drawing some figures with TikZ for a beamer presentation. I want one figure to look something like this: Additionally, I want to add labels under the intervals (the sections in between ticks ...
1
vote
1answer
126 views

Usage of final option with package animate

I'm currently animating some inline graphics (TikZ) on a beamer presentation with the animate package, and have come across some weird behavior. Since I still have lots of work to do, I set the ...
7
votes
1answer
776 views

Why does loading pgfplots after tikz break the default layers in a tikzpicture?

Taking the MWE from Jake's answer to the question Background rectangles with equal width but 'fitting' height, I get an error when loading pgfplots after the tikz packages but not before. I'm assuming ...
1
vote
1answer
389 views

Debugging TikZ and PGFPlots compatibility issue

I just tried to compile an old TikZ code (which as far as I recall compiled perfectly in the past and was not changed in the meanwhile) and I faced some serious compilation issues related to TikZ. ...
3
votes
1answer
180 views

Print macro output instead of executing

I am attempting to debug a Tikz/PGF script. I have a STY file that generates Tikz/PGF scripts, but the output graphic isn't quite what I want it to be. In order to debug the problem, I was hoping ...
1
vote
0answers
697 views

tikzpicture fails when externalization is enabled [closed]

In a document of mine I'm trying to use the external library. For the record, I downloaded the CVS version of TikZ, since I want the better update checks. Anyway, I have a figure in my code which ...
6
votes
1answer
950 views

TikZ datavisualization example fails

While trying an example from the datavisualization section of the current TikZ manual I get a strange error message. On my system I have the current MikTeX 2.9 and installed the CVS version of TikZ ...
5
votes
3answers
301 views

\settowidth problem in tikz and in groups

I just came to the following problem - using \settowidth on a length in a tikzpicture resets that length to 0? Here is a (totally command-line) MWE, compiled with pdflatex test.tex: ...
10
votes
1answer
523 views

Visualizing correct page lengths with 'layouts' and 'tikz' packages?

I am currently working on a project with xelatex/fontspec and tikz, and so, this example is basically the same as the one from layouts package reads all length as zero with tikz/fontspec/xelatex?. ...
2
votes
1answer
128 views

layouts package reads all length as zero with tikz/fontspec/xelatex?

After getting the suggestion to use the layouts package for visual debugging of lengths, I came up with the following example, which I compile with xelatex test.tex: ...
17
votes
2answers
4k views

Is plotting exponential graphs a known source of bugs in TikZ?

I want to plot $y = 2^x$ over a small domain. Unfortunately, even though tikz (v 2.1) seems to be able to calculate 2^{negative numbers} it is not plotting them correctly. My minimal example is: ...
9
votes
1answer
512 views

Using pgfplots with a0poster

I want to use tikz/pgf to plot some graphs in a poster done with a0poster. That is the code: \begin{tikzpicture} \begin{axis}[xlabel=lambda, ylabel=int] \addplot[blue] table [mark=none, col ...
17
votes
5answers
636 views

What tips and tricks are there for debugging TikZ/PGF code?

When answering questions here and when drawing my own complicated TikZ/PGF drawings, I've developed a fair number of "tips and tricks" for debugging the code. I'm sure that others have as well. I ...
1
vote
0answers
271 views

tikz bug in the automata package? [duplicate]

Possible Duplicate: Strange arrow mark with TikZ edge and anchors. The following code \begin{tikzpicture} \node (q0) [initial,state] {$q_0$}; \node (q1) [state,right ...
1
vote
0answers
110 views

How do I temporarily change the PGF version used? [duplicate]

Possible Duplicate: Installing several versions of a package This might be a more general question but I'm interested in the PGF implementation so I'll ask specifically. I have TikZ code ...
24
votes
3answers
1k views

How can I work around this TikZ bug: (\x)^2 and \x^2 produce different results in TikZ plot?

I have some files with TikZ graphics that have suddenly changed appearance since I upgraded to PGF-2.10. Here is a minimal example: \documentclass{minimal} \usepackage{tikz} \begin{document} ...
2
votes
2answers
338 views

Meaningful error messages when using latex instead of pdflatex

When I have TikZ images or I include .png graphics, I need to use pdflatex instead of plain vanilla latex. (That is, I need to use pdflatex all the time, rather than just when I want to produce the ...