is about finding the cause of errors or wrong results in (La)TeX code/documents using a methodical approach.

learn more… | top users | synonyms

9
votes
0answers
78 views

Determine File Name and Line Number Where a Macro is Invoked From

Wondering if there is any way to print out (for debugging purposes) the file name and the line number from where a macro is invoked (not where it is defined). My attempt to use the currfile package ...
4
votes
0answers
98 views

Error arising when using \typeout & \meaning with \midrule

In order to facilitate debugging some experimental code, I created a version of \typeout that will break its content into multiple lines: %% dummy macro for simulating newlines in output to terminal ...
3
votes
0answers
40 views

Debug log the text returned via tex.sprint() and friends?

Is there an easy way to see what text was sent from Lua to TeX via tex.sprint(), tex.print(), and tex.write()? (e.g., print it to stdout or log it to the .log file)
3
votes
0answers
184 views

Troubles with TeX Live 2009 and 2013

Well, before Christmas I was updating some software in my Ubuntu 12.04 installation, where I have happily installed TeX Live 2013 since last summer (I did it from an ISO image downloaded from the ...
3
votes
0answers
72 views

How to debug error message from luaotfload-database.lua

I am beginning to think it was a really bad idea to update to TeXLive 2013. Since this update almost none of my old documents compile any longer. Does anyone have any idea what LuaLaTeX is trying to ...
2
votes
0answers
25 views

htlatex adding _ after - in URLs

I'm using htlatex on Fedora 21, texlive-tex4ht-svn33024.0-1.1 I noticed that whenever a URL has a hyphen within it, in the HTML output it's formatted with an underscore symbol following -. For ...
0
votes
0answers
45 views

Label at the end of document is lost, bug?

I'm having a long document in memoir at the end of which I set a label, and so far it has worked. I did some changes to my document, at unrelated places, and suddenly I'm getting the warning that that ...
0
votes
0answers
38 views

! Missing number, treated as zero. <to be read again> error with makeglossaries

I'm getting these two errors after compile with makeglossary. If I compile my .tex file with PDFLatex->makeindex->PDFLatex runs without problem but if I change this command series to ...
0
votes
0answers
41 views

Peculiar bug, what is causing it?

I tried typesetting a couple of times but still got the above result. Wiping line 26 and typing it all over again fixed it though, but my question is: Do you think this a bug in my editor (Texpad) ...
0
votes
0answers
27 views

Line filled with \dotfill doesn't appear

I'm using the \dotfill command inside a special indentation block but I can't see the dots This is the relevant piece of code: {\addtolength{\leftskip}{0.5\textwidth} Nota de aceptación:\newline ...
0
votes
0answers
40 views

Vanishing text?

I have a document, in which one of the lines in the pdf file is missing all but the first word. The obvious thing to do is try to prepare a minimal example that reproduces the problem. This is not ...
0
votes
0answers
72 views

Kile error compiling .bib not appearing in .blg

I keep having trouble while compiling the bibliography with Kile. I get the following error message: File ended while scanning the use of \thebibliography \bibliography{HKR} \begin{thebibliography} ...
0
votes
0answers
56 views

Hyperlinking theorems in smfart

Edit: The class smfart is one of several classes created by the Société Mathématique de France for typesetting mathematics. Here is its CTAN page, where it lies under smflatex, and here is the ...
0
votes
0answers
97 views

I need some help debugging this LaTeX macro - TeX “skips past” a bunch of code?

I'm trying to test and debug a collection of LaTeX macros that I've been working on, and I have run into a problem that has me totally stumped. Essentially, the problem is that at a certain point in a ...