60
votes
1answer
770 views

Automated management of package options and loading order

This question led to a new package: pkgloader(CTAN, Github) LaTeX package conflicts are a common source of frustration: (1) (2) (3) (4) (5) (6). To quote Freek Dijkstra: Package conflicts ...
5
votes
2answers
177 views

Creating a dependency tree (\RequirePackage) for packages used in my document

Is there a way of creating a dependency tree for packages \RequirePackageing each other for those packages used in my document, ideally with the respective required options and version numbers? Are ...
14
votes
1answer
3k views

Option clash for package xcolor

Im doing a report, and having a rather large table in my appendix. And want to emphasize some specific values by coloring some single cells. I'm trying to do it with xcolor. But receiving the error: ...
0
votes
1answer
2k views

How to resolve option clash for package xcolor? [duplicate]

Possible Duplicate: Option clash with xcolor and TikZ The following is my MWE: \documentclass{article} \usepackage{tikz} \usepackage[table]{xcolor} \begin{document} Hi! \end{document} ...
14
votes
2answers
1k views

Package options and \RequirePackage: order of commands and option conflicts?

How do the options of a \RequirePackage command interact with options specified for that same package elsewhere? Here is an example: The pdfx package, if loaded with the a-1b-option, executes the ...
20
votes
2answers
5k views

Option clash with xcolor and TikZ

I want to draw some coloured circles, so I loaded tikz in my preamble. However, now xcolor is telling me that it has an "option clash". How should I fix this? \documentclass{article} ...
3
votes
1answer
992 views

\RequirePackage without option clashes because of the package loading order?

I am writing a package which requires the xcolor package with table option. It is loaded in the package with \PassOptionsToPackage{table}{xcolor} \RequirePackage{xcolor} which works if my package ...
11
votes
3answers
3k views

Conflict between Options of Packages

I have these following packages defined in my preamble and once the file is ran, it creates an error of the following saying there is a clash within the package options. Packages are below: ...