{packages} is about packages in general, e.g. about choosing, installing or using packages. For questions about writing packages, choose {package-writing} instead. If your question concerns a specific package, choose its name as tag. For {document-classes} or {templates} use the respective tag.

learn more… | top users | synonyms (2)

0
votes
0answers
11 views

How to fix LaTeX Error: File `kantlipsum.sty' not found?

How to fix LaTeX Error: File `kantlipsum.sty' not found ?
11
votes
1answer
210 views

Is it ok to load a package twice (as long as no extra options are given)?

In Loading package twice with \RequirePackage causes "option clash" and Loading a package more than once we see that a package can be loaded multiple times, as long as no options or no ...
1
vote
1answer
24 views

tlmgr unknown directive error with upstream Tex Live 2016

I have installed Tex Live 2016 following the instructions from the tex live quick install instruction for linux, running the install-tl installer. I am on Linux Mint 17.3. Trying to use tlmgr, I got ...
2
votes
1answer
45 views

Add \place using your computer location?

Is there a package that gives the \place using your computer location?
6
votes
1answer
522 views

The Bra-Ket Notation in LaTeX

I want to write the following symbol in LaTeX: I'm using the following (minimal) code: \documentclass[12pt,twoside]{article} \usepackage{amsmath} \usepackage{amssymb} \usepackage{...
4
votes
1answer
68 views

Gap between ket and bra by using the braket-package

I'm using the braket-package for using the braket notation. It works fine, but I've got some problems by using the package for writing a tensor product. There is always a big gap between the ket and ...
0
votes
0answers
54 views

Why does latex show that {unrecognized command } when I hover over this environment , \begin{IEEEeqnarray}{rCl}

To use this environment I have to load this package: \usepackage[retainorgcmds]{IEEEtrantools} I have the MiKTeX distribution and I didn't find this package in packages manager so I downloaded the ...
0
votes
1answer
54 views

Cannot find bibliography [on hold]

I am working on my thesis and apparently, when compiling the file, it does not find any bibliography file, whereas this is actually located in the same path as my thesis file. The code I have is: \...
2
votes
1answer
24 views

Figcaps and special characters

I'm trying to use the figcaps package in an article to keep all figures at the end of the document. When I compile the following TeX code using pdflatex I get the following error message: ! Package ...
2
votes
1answer
28 views

How do I update minitoc

I'm desperatly trying to update my minitocs I added in the beginning of every chapter. To do so, I've tried compiling several times, and I've tried to delete my "\minitoc and my \dominitoc in my code. ...
1
vote
1answer
25 views

gnuplottex and ngerman

A while ago, I asked a question about always occurring errors from the gnuplottex package. /usr/share/texlive/texmf-dist/tex/latex/gnuplottex/gnuplottex.sty:79: Argument of " has an extra }. [...te\...
0
votes
1answer
46 views

Lost word in first page

I have a matter with an article, in the first page it appears caption, as word, alone. The rest of the pdf looks as I want. I have searched everywhere but I do not know where does it come from. I ...
407
votes
31answers
214k views

LaTeX template for resume/curriculum vitae

If you have a TeX'ed resume, did you use a template or make your own? Are there any useful packages? What looks the most professional? How about special considerations for different areas of work (e.g....
1
vote
1answer
31 views

Disabling automatic dissimilarity coding in texshade

The package texshade provides an environment to typeset nucleotide and aminoacid alignments. This otherwise great package has a default setting, which I would like to turn off: By default, texshade ...
1
vote
0answers
33 views

Anyone knows any “automatic” package to draw graphs of posets (the Hasse diagrams)?

anyone knows any "automatic" package to draw graphs of posets (the Hasse diagrams)? I know TikZ, but I wanted something faster (automatic). Thank you.
0
votes
1answer
34 views

Cross-reference and tikzpicture conflict?

When I Include this diagram to my memoir document % Requires \usetikzlibrary{shadows,positioning,backgrounds} \centering \begin{tikzpicture}[x=11.8mm,y=8mm] % some colors \colorlet{even}{cyan!60!...
2
votes
1answer
106 views

todonotes error on TeX Live 2016

I just upgraded to Tex Live 2016 on a Mac and doing a pdflatex on any document that includes the todonotes package (whether actually used or not) now throws this error: (/usr/local/texlive/2016/texmf-...
1
vote
1answer
43 views

Packages for string diagrams

What TeX packages exist specifically for drawing string diagrams, e.g. like these: (or with similar styles)?
0
votes
1answer
28 views

expl3 2016 .dtx files to .sty

I have a very similar problem to this old one, closed for being too specific: File expl3.sty not found when trying to compile a *.tex file with XeLaTeX But I have read a few people having it with no ...
1
vote
1answer
24 views

! Package inputenc Error: Unicode char \u8:‐ not set up for use with LaTeX

I am using BibTex for referencing and when I added a new reference I got the following error message: ! Package inputenc Error: Unicode char \u8:‐ not set up for use with LaTeX., which seems to occur ...
8
votes
2answers
139 views

How can I change the build system of python.sty from Python2 to Python3?

I am using the python.sty package, downloaded here. I found the default build path is to use Python2.7: \documentclass{article} \usepackage{python} \begin{document} \begin{python}% import sys print (...
0
votes
1answer
148 views

Windows, TeX Live and directory for personal packages

On Unix like system using TeX Live, the command kpsewhich --var-value=TEXMFLOCAL gives the path of the directory where to install homemade package. For example, on my Mac, I obtain the path /usr/local/...
0
votes
1answer
40 views

Show in draft mode, hide in final mode

I am writing a paper which has some parts which I want to hide in the final pdf output but displayed in draft pdf output (that is when I am working on the paper). So I need an environment which is ...
5
votes
2answers
692 views

pgfopts error when installing ytableau

I am trying to install ytableau.sty, following the directions here and here, and in the ytableau README. I am running TexShop 2.47 on OS X 10.6. Here's a walkthrough of what I've done, although I ...
1
vote
0answers
57 views

Where is \noident defined? [closed]

As always, I have the following: \documentclass{article} \usepackage[utf8x]{inputenc} %∑ \usepackage{hyperref} %clickable x-ref-s \usepackage{url} %\usepackage{fixltx2e} \usepackage[margin=...
3
votes
1answer
30 views

Update preinstalled packages at ShareLaTeX

I am using ShareLaTeX who have already preinstalled many packages. Is it possible to manually update these packages to newer versions?
1
vote
0answers
77 views

Package for typesetting the Bible

Are there any LaTeX packages or styles that have been designed specifically for typesetting the Bible, with its text divided into books, chapters, and verses? This post contains a couple of nice ...
3
votes
1answer
66 views

TeXlive 2016 error with literat (Literaturnaya) font

It is so strange that no questions on the whole website are dedicated to the Literaturnaya font (despite its frequent use in Russian documents 10 years ago or so), and only two questions reference it! ...
0
votes
1answer
30 views

Add footer info to a .sty or the .tex itself?

I can add footer information with the fancyhdr package: \documentclass{article} \usepackage{lipsum} \usepackage{fancyhdr} \pagestyle{fancy} \lfoot{\copyright\hspace*{.1em}\the\year\hspace*{.1em}This ...
0
votes
0answers
17 views

I do have a c.sty file required for copernicus.cls where can I find it?

This is the output I got in TeXstudio: File `c.sty' not found. \usepackage co
4
votes
2answers
262 views

Partial compilation commands/environment?

In the interest of speeding up compilation times of large documents, I got interested in partial compilation. (I'm already aware of "pre-compiling" preamble format fmt files and intend to use that as ...
1
vote
0answers
21 views

Package babel Error: Unknown language `french' still exists after installing texlive-lang-french

I use a latex template on sharelatex and it works fine. However, I encounter the following issue when building it on my laptop (Ubuntu + Texmarker), ! Package babel Error: Unknown language `french'. ...
2
votes
1answer
30 views

TexStudio in Mac OSX El Capitan Error: package not found

Why if I want to use eskd or eskdx packages does TeXStudio show me an error message: "not found eskd.sty"? I installed MacTeX and TeXStudio with default settings, and moved project from PC. But when ...
143
votes
5answers
289k views

How can I manually install a package on MiKTeX (Windows)

I'm new to LaTeX, investigating using it for some work projects. I'm using MiKTeX on Windows. My employer's locked-down network blocks the application's automatic installation function. I can take ...
1
vote
0answers
41 views

Biblatex causing undefined control sequence error at \begin{document}

I've been having this problem for quite some time now but can't figure it out and it's driving me crazy. I'm new to latex and can't find any already answered question that can help me sort it out, so ...
1
vote
1answer
34 views

What should i include for enabling \smallfigscale [closed]

I am having a issue with width = \smallfigscale which used for \includegraphics. I think I have the package included, but not installed. What package do I need to install to make it run? example of ...
2
votes
1answer
136 views

Updating from an old enumitem package - Lubuntu

I've installed Texmaker on my netbook running LXLE (built on Lubuntu 12.04) and when I tried to compile a file I'd been working on with Texmaker on Windows, I get an error saying: Unknown option ...
47
votes
4answers
77k views

How do I add a .sty file to my MacTeX/TeXShop installation?

I've searched online, but I have not found any clear instructions how to permanently add .sty files to my TeXShop installation. I'm using a Mac with OSX (TeXShop is a mac only program). What is the ...
1
vote
0answers
69 views

Configuring Texmaker for Tex Live

On my Ubuntu machine, I have just downloaded Texmaker and Tex Live. I now want to compile a Latex file which uses the tcolorbox package. From what I have read, this package should come with Tex Live (...
2
votes
1answer
140 views

LaTex cannot find user installed packages

I just switched to a new laptop and am having trouble getting a few packages to work on the new machine. I installed Miktex 2.9 basic package and the style files I need to access are contained in the ...
0
votes
0answers
49 views

Using TeX Live with Texmaker

On Ubuntu, I downloaded Texmaker (sudo apt-get install texmaker), but this did not come with the packages which I needed. So, I also downloaded TeX Live (sudo apt-get install texlive-full), which ...
0
votes
0answers
27 views

Installing TexMaker with all packages

I have installed TexMaker on Ubuntu (via Software Center), only to find that some of the packages, is to run sudo apt-get install texlive-full, which apparently comes with all the packages. However, I ...
0
votes
0answers
14 views

Issue with miktex installation - loading package database

I am trying to install miktex 2.9 with the Net installer. But the setup is stuck on "loading package database" The packages are in 'Miktex 2.9 local package repository' to be installed in the folder '...
8
votes
1answer
50 views

Prevent Lyx from automatically including packages

Lyx question here, I think it applies to no particular version. When I include external graphics, Lyx automatically adds \usepackage{graphicx} to the beginning of the generated TEX file. However, ...
0
votes
1answer
82 views

How to include any .sty file in circuit_macros?

My circuit_macros M4 code .PS #\usepackage{steinmetz} #include(steinmetz) #s_init(steinmetz) scale=25.4 source(up_,AC);llabel(,120\angle 50{^{\circ}},) .PE output And that I want image, That ...
2
votes
2answers
47 views

A lot of files are installed but not found by TexnicCenter

I have a classic install of MikTex, with all basic packages, but a lot are not found. Some managed to be found via the "package installation" window at compilation, but xcolor.sty just doesn't want to ...
7
votes
2answers
257 views

Arbitrary \left \right delimiters

Is there a package that would allow me to use other symbols/any symbol apart from the (among others) usual delimiters () [] {} | with \left and \right? For example, \(\left\int f(x) dx \right.\) ...
1
vote
0answers
37 views

Problem with the installation of libertinust1math package

I would like to use the Linux Libertine Font for my document; as suggested here I have inserted this 3 code lines in the preamble of the input file \usepackage{libertine} \usepackage{libertinust1math}...
0
votes
1answer
38 views

Colorful undirected graphs in Tikz to demonstrate equivalence classes?

I would like to learn to create this kind of pictures as below with colored vertices in Tikz. The vertex sizes can be the same. This is a graph demonstration (CC BY-SA 3.0) for equivalence classes ...
2
votes
0answers
31 views

Encoding problem with accents and inputenc package

I have this problem, it seems i'm doing something wrong while writing letters with accents like "è", on that line the compiler says: package inputenc Error: unicode char \u8:èun not set up for use. ...