{packages} is about packages in general, e.g. about choosing, installing or using packages. For questions about writing packages, choose {package-writing} instead. If your question concerns a specific package, choose its name as tag. For {document-classes} or {templates} use the respective tag.

learn more… | top users | synonyms (2)

1
vote
0answers
16 views

Avoiding widows while keeping text height even across two-page spread

In The Elements of Typographical Style, the author notes (§2.4.8) that widows—single lines occurring at the top of a page—should be avoided. Yet the text height of two facing pages should be the same, ...
0
votes
0answers
9 views

Shortening text height across chapter to fill last page

We all know the problem of having a chapter that is just too large to fill the last page conveniently, leaving one or two (or three) lines at the top of the last page. Besides attempting feats of ...
1
vote
0answers
14 views

Include siunitx package in subdirectory

I am creating a TeX project that uses the siunitx package. I would like to be able to place the siunitx package in a subdirectory, to simplify folder structure and to allow me to easily transfer this ...
51
votes
8answers
18k views

What graphics packages are there for creating graphics in LaTeX documents?

What packages do you use and recommend for creating graphics in your LaTeX documents? As this is a community wiki post, please add your package to the accepted answer (or add a comment, and ...
0
votes
0answers
48 views

Problems with tikz-dependency / MiKTeX package manager

I'm getting an error when using the tikz-dependency package. The option to suppress a label does not work propertly (MWE below). \documentclass[a4paper]{article} \usepackage{linguex} ...
0
votes
0answers
130 views

Windows Miktex can't find mathtools.sty

When I try to compile my paper I get the error: ! LaTeX Error: File `mathtools.sty' not found. Other packages are successfully found and automatically installed, but mathtools.sty is not. I just ...
0
votes
0answers
14 views

Alignment of text is not proper in APA style 6 package

I just started using LaTex for my research work. I am using APA6 style package, but when i am producing output is not properly aligned. I am mentioning below LaTex command i am using. ...
3
votes
0answers
54 views

What is the use case for the ucs package?

The ucs package (formerly aliased to unicode), provides support for Unicode as a input format, as I understand it. Under what circumstances should I be using that package, and unicode symbols? to my ...
2
votes
2answers
125 views

How to Use BOONDOX Latex Calligraphic Font

New LaTeX user here. While reading this nice question and its answer, I discovered the "BOONDOX Calligraphic" font and tried to implement it in my document. I've been having some troubles, and after a ...
1
vote
2answers
77 views

Is there an EASY step by step guide to installing packages?

Im trying to install a package, the one called "mathtools". I am using MikTeX and Texmaker, and the Package Manager does not work, so i need to do it manually. I have downloaded a folder from CTAN ...
2
votes
1answer
414 views

Rendering VHDL in latex

I have a VHDL code which I want to insert into my latex document. I need a package that takes care of syntax highlighting, indentation etc. Is there a package which serves this purpose?
1
vote
2answers
230 views

MiKTeX package update: Select All grayed out

I installed MiKTeK 2.9.4321 in a locked down environment. I don't believe that we can directly download the entire thing from outside, and the aforementioned version is the one that we have on a CD, ...
3
votes
3answers
405 views

problems installing mathtools

There have been a few questions regarding installing this package in the past, but they now seem to be out of date. I'm using MiKTeX 2.9 and TexMaker. When I try \usepackage{mathtools} in TexMaker it ...
0
votes
1answer
69 views

Missing mathtools.sty

I'm really new to LaTeX and am having a problem with mathtools.sty. I am using MikTeX and Texmaker. When I try to create the pdf (compile?) it gives me the error: ! LaTeX Error: File ...
51
votes
2answers
13k views

How do I install an individual package on a Linux system?

I need to install a new TeX/LaTeX/ConTeXt package on my computer. I'm running Ubuntu/Fedora/Slackware/Some-Version-Of Linux. What are the possible ways to do this? Note:   We get a ...
1
vote
1answer
50 views

How to create a table with long text and which packages use

Please, Help me inserting a table like this. I could not prepare this table easily because the long text i have to insert into the columns. I have been trying from some examples of stackechange but ...
6
votes
3answers
118 views

Problem with the zhnumber package

I am trying to write about numerals and the use of symbols. As an example I would like to use chinese/japanese symbols to show a multiplicative system. I have come up with the package zhnumber which ...
4
votes
2answers
2k views

Vertical addition and multiplication and long division

Is there in existence packages that recreate the following environments: Some of the above have been discussed like in the How to present a vertical multiplication but what I am interested in is if ...
0
votes
0answers
36 views

Modifying the appearance of appendix titles

I want to modify the appearance of appendix titles. For that I use the package appendix with the following options: \documentclass[ numbers=noenddot ]{scrreprt} \usepackage[ automark, ...
2
votes
1answer
22 views

Package installed but not working

I installed the MacTEX package, and want to use the listings package for pretty printing code. According to the TeX Live Utility, the package is installed (I tried re-installing it as well). However, ...
2
votes
0answers
31 views

What online tool is suggested for the picture package in LaTeX? [duplicate]

As you know there are online tools for drawing tables for LaTeX. Is there any online tool which can be used to generate the pictures (any geometrical graphics and shapes) easily? That means we ...
5
votes
1answer
1k views

Latex cannot find `.sty` files

I am on a mac and I believe I am using MacTeX. I am getting errors of the sort: File `fullpage.sty' not found. When I run locate fullpage.sty I get ...
0
votes
0answers
48 views

when i was running my thesis following problem raised please help me

I was doing my article in latex it is showing the following error. Can any one help me? Package keyval Error: compat2 undefined. \ProcessOptionsKV[p]{Gm}
2
votes
1answer
77 views

Can I write $\log^2{x}$ in skmath?

Standard LaTeX has the opportunity to write things like $\log^2{x}$. This is however no longer possible when loading the skmath package, because skmath expects the logarithm to be entered ...
10
votes
4answers
159 views

Is it safe to use the TeX Live Update utility while compiling documents?

I just started the TeX Live Update utility and saw that quite some packages were updated on the server. I proceeded to update all outdated packages, but this takes a while. Is it safe (in terms of ...
113
votes
10answers
8k views

Which packages should be loaded after hyperref instead of before?

The hyperref documentation says: "Make sure it comes last of your loaded packages". The reason is that it redefines many LaTeX commands. It's a rule of thumb that helps to avoid errors. However, ...
0
votes
1answer
68 views

Font Issue — Times and Computer Modern work but nothing else

This code seems to work: \documentclass{article} \usepackage{times} \begin{document} This is a test. \end{document} %End of document. But, I have had no luck with any fonts other than Times ...
0
votes
0answers
54 views

Why does hyperref return errors when options are included to this package?

When I include these options to the package hyperref I get error messages and the file doesn't compile! Please here is a minimal working environment: \documentclass[a4paper,10pt]{article} ...
4
votes
1answer
26 views

smartref package conflicts with babel option frenchb

I've unsuccessfuly searched for an answer to this problem. I'd like to use the smartref package together with babel with option frenchb, but there seems to be a conflict : command \chapterref in the ...
4
votes
1answer
67 views

How can the last updated packages get propagated earlier than the first updated packages

I often experience the following phenomenon. For example, from texnik.dante.de/tex/generic I noticed that pst-plot gets updated on August 24, 2014 pst-poly gets updated on August 28, 2014 and ...
94
votes
12answers
6k views

LaTeX packages for use with revision control

I use revision control (Subversion, to be exact) to keep track of the edits to my LaTeX documents. Is there a LaTeX package that interfaces with revision control? Specifically, it would be nice to see ...
30
votes
4answers
4k views

Is there a good LaTeX package for generating barcodes?

I'm looking for a good LaTeX package to generate one dimensional barcodes, that has the following properties. It doesn't require any external scripts or internet connection to work. It easily ...
1
vote
1answer
119 views

design a style using tikz package

How can I use latex tikz package to design the style that is seen in the picture?
1
vote
1answer
452 views

File `balance.sty' not found

i recently installed texworks 2012 full version in ubuntu 12.04. i am working in latexila. when i am running a .tex file the following error occured- File `balance.sty' not found. can any one help me ...
0
votes
1answer
56 views

Where should I put LaTeX macro package files?

I'm preparing to submit an article to one of Springer's journals. It requires to use Springer's LaTeX macro package. (http://www.springer.com/statistics/journal/10985 --> Instruction for authors --> ...
1
vote
1answer
46 views

How can I hyperlink figures and tables in LaTeX? [closed]

I can hyperlink references by hyperref package. But I can not hyperlink figures and tables? should I use any certain package for labeling ?
4
votes
1answer
70 views

Should one always use exscale when using lmodern?

At the moment I only use summation signs with symbols which have a normal high and also no summation signs in subscripts. Due to this post is it correct that I should always use the exscale package ...
1
vote
3answers
227 views

How to make a fancy exam at LaTeX?

I'm very interested make a fancy exam at LaTeX? , You can see this example like this : But, i don't know How to start it ? Can you explain How to make it ? or What is the package at LaTeX ?
4
votes
1answer
66 views

Package to run multiple iterations of a variable, with compilation?

I guess this is somewhat similar to Animations in LaTeX, except what I would want is something like this: Say you have a .tex document, which uses some macro \tester as parameter. I'd like to load a ...
3
votes
4answers
10k views

Installing a class

I created a new class file to use. I have put the .cls file in the same directory as the original cls files (report, book etc) and im 100% sure the names match. The directory for me is: C:\Program ...
0
votes
1answer
36 views

Package won't get loaded [duplicate]

I have written a package and placed it in the same directory as e.g. latex.ltx. However, TeXShop just won't load it, or rather, XeLaTeX and pdfTeX called through TeXShop won't. If I, however, on the ...
0
votes
0answers
24 views

How to remove extra white space from figures

How can I please remove extra white space from a figure because it's taking me so much space. Thank you,
0
votes
0answers
64 views

How to insert hebrew In backround (with Tikz) in Lyx

I try to do a background with a text on the top right corner of the page (with borders and page number) I succeeded in creating it but I want to insert a hebrew text (it renders english the way I ...
5
votes
1answer
465 views

What .sty files do I need to successfully run pdflatex on .tex produced from nbconvert?

Allegedly, one can produce pdf files from ipython notebooks by first producing a .tex file from nbconvert (http://ipython.org/ipython-doc/stable/interactive/nbconvert.html#nbconvert) However, I run ...
0
votes
0answers
38 views

Rd.sty throws ! LaTeX Error: Command \bold already defined.

I have to use Rd.sty package can be obtained from here in my .Rnw documents. Without using \usepackage{Rd} everything works fine. But the inclusion of \usepackage{Rd} throws the following error: ! ...
1
vote
1answer
1k views

Miktex Package Installation

I recently installed MiKTeX with the texmaker editor and cannot figure out how to update the packages. When I attempt to use the subfigure package with the following preamble ...
0
votes
1answer
74 views

Packages to install once for all

I just upgraded my Ubuntu from 12.04 to 14.04. Then, I have manually installed tex-common, texlive-base and texlive-latex-recommended. And I realize that some packages do not exist anymore. For ...
1
vote
1answer
22 views

Sideways subfigure over several pages

I am trying to include "sideways" subfigures according to this question How to rotate a group of figures (subfigure) from Torbjørn T. I would like to put three graphics next to each other (for ...
0
votes
1answer
64 views

Which packages come standard with Ubuntu's `texlive` package? [duplicate]

Is a list published somewhere of which macro packages come standard with texlive? Specifically, I am considering installing the texlive package (not texlive-full) in Ubuntu. I'd like to know if ...
13
votes
3answers
508 views

I'm a cargo cult programmer …

... because I don't know why this works \def\my@addextraoption#1{% \xdef\my@extraoptions{% \@ifundefined{my@extraoptions}\@empty\my@extraoptions,% \zap@space#1 \@empty}} ...