TeX Live is a widely used TeX distribution available for Windows, Mac OSX, Linux, and other Unix-like operating systems.

learn more… | top users | synonyms (1)

3
votes
0answers
138 views

Compiling with TL2015 doesnt work

I wanted to install TeXLive shortly. But when I start my TeXStudio Editor and I try to compile a minimal example, the following failure occurs: Prozess gestartet: pdflatex.exe -synctex=1 ...
28
votes
2answers
14k views

Auto Package download for TeXLive

I use MiKTeX on Windows and quite satisfied with it. Recently I started switching all my tasks toward open-source alternatives, and in the course I would love to use Linux. But the problem is in Linux ...
1
vote
1answer
53 views

Under what conditions can I redistribute files from my local TeXLive installation [closed]

I created a Github repository called luatexminimal, to provide a minimal, barebones LuaTeX setup to compile PDF documents. I had to copy a few files from my local TeXLive installation to do that: ...
0
votes
0answers
40 views

yfont.sty not found - What to do?

I have been using LaTeX now for some time without encountering any problems. But then, since yesterday, I have been unable to use it due to an error that reads ! LaTeX Error: File `yfonts.sty´not ...
1
vote
1answer
120 views

Installing TeX Live and Texmaker or Kile under openSUSE Leap 42.1

I'm under openSUSE Leap 42.1 I installed TeX Live : sudo zypper in texlive Then I try to install texlive-latex but it seems that texlive package is a full package because that say me ...
2
votes
0answers
41 views

Text moves down when i added logo in header slide

I have a problem with that, when added to the header slide logo, text (learn, describe, implement, compare as you can see on the pictures) moves little bit down and I do not know why. Have you a ...
3
votes
1answer
99 views

pageslts error: very old endfloat in texlive 2013 [closed]

The package pageslts in TeX Live 2013 complains about "very old endfloat package detected", but the recent endfloat version 2.5d is loaded. A minimum working example showing this error is: ...
3
votes
1answer
162 views

Makeindex-style for list of acronyms (glossaries)

I'm a LaTeX newbie using this example provieded by Tom Brien to combine some of my acronyms with their glossaries-entries. I would like to change the style of the acronyms-list to make it looks like ...
7
votes
3answers
10k views

How to install texlive-fonts-recommended (from Debian/Ubuntu) into texlive2012 (CTAN)?

while compiling my tex file, I am getting lots of this error -- kpathsea: Running mktexpk --mfmode ljfour --bdpi 600 --mag 0+540/600 --dpi 540 zplmr7v mktexpk: don't know how to create bitmap font ...
1
vote
0answers
36 views

Classicthesis + texlive fresh install

I have been using TeX Live on Ubuntu 14.04 and the package classicthesis with no problems until now. I have recently reinstalled Ubuntu 14.04 and TeX Live with it. I followed the guide on how to ...
12
votes
1answer
207 views

Set DVI version output in xelatex?

After upgrade to TeXLive 2015 I can no longer convert xdv output of xelatex to svg with dvisvgm. MWE: \documentclass{article} \usepackage{fontspec} \usepackage{polyglossia} \begin{document} $x^2$ ...
8
votes
1answer
173 views

LuaTeX 0.85 \pdf* primitive changes and format file generation

TeX Live 2015 ships with LuaTeX 0.80. As LuaTeX 0.85 became available last month and I am supposed to do be doing other things I found this to be a wonderful opportunity to procrastinate by giving the ...
2
votes
1answer
231 views

Tex Live Package Security

To what extent is the code of the packages included in tex distributions reviewed with respect to malicious code. This is with respect to what is posted in documentation as well as what is actually ...
0
votes
1answer
44 views

lualatex not using latest latex version

I am using TexLive 2015 on OS X. tlmgr info latex reports that I have the latest latex version 2015-08-03 $> tlmgr info latex package: latex category: Package shortdesc: ...
1
vote
1answer
178 views

How to configure TexLive 2015 to use latexindent.pl script with Kile

I would like to autoindent my code under Kile using latexindent. I have TeXLive 2015 installed and I run arara on my tex file. I tried to follow the manual instructions (p.5) for latexindent where ...
1
vote
0answers
59 views

Using TexStudio and TexLive — Error: Could not start command

I'm fairly new to LaTex, and I'm having some trouble getting it up and running on my computer. I just installed TeX Live and TeXstudio 2.10.4 on my computer (which is running Windows 8). In TeXstudio, ...
2
votes
1answer
31 views

Fails to compile with XeLaTeX in TL2015 when including `newtxmath`

All my LaTeX documents stopped compiling with XeLaTeX from TeX Live 2015 sometime in the last two months. It was working before. Here is a minimum working example: \documentclass[11pt]{scrartcl} ...
2
votes
1answer
34 views

Strategies for providing packages as version control repositories

I'm working on experimental packages (say my-package-1 and my-package-2). Their changes are tracked thanks to a version control system (git in fact), the corresponding repositories being as follows: ...
0
votes
0answers
36 views

What is the purpose of installing the TeX Live “font/macro source tree” for ordinary users?

The TeX Live installer gives the option, checked by default, to "install font/macro source tree". The documentation states simply that omitting these files is "not recommended", with no further ...
5
votes
1answer
73 views

How can I use xindy on a system with libncurses.so.6?

My GNU/Linux system (Arch) now has libncurses.so.6 rather than libncurses.so.5. But I have upstream's vanilla TeX Live (fully updated) and xindy wants libncurses.so.5: xindy --version produces ...
0
votes
0answers
22 views

Installing TeXLive2015 on an ibook G4

does anyone know a way or an instruction to install a version of TeXLive2015 or MacTeX2015 on an ibook G4? Or is there a useable binary somewhere? I am not able to built one myself but would like to ...
2
votes
0answers
66 views

MacTex Vs TexLive Installation

I have downloaded TexLive 2015 DVD, and it appears that Linux Commands can be used to install TexLive. I went to the TexLive website, and they suggest using the MacTex Distribution which agains is a ...
2
votes
0answers
49 views

Updating .sty files in ~/texmf

I am using TeX Live on Linux Mint 17.2, and I have previously set up the ~/texmf directory, so that I can manually install my own .sty files. However, after editing the .sty files in ~/texmf, LaTeX ...
5
votes
2answers
5k views

Latex cannot find `.sty` files

I am on a mac and I believe I am using MacTeX. I am getting errors of the sort: File `fullpage.sty' not found. When I run locate fullpage.sty I get ...
2
votes
0answers
66 views

How to install cyrtimes.sty for Texmaker with installed texlive-full at Linux Mint (Ubuntu)

I had some troubles with TeX packages installation for my minimal configuration, so I decided to install texlive-full. After that I can't build my document anymore because of missed very basic package ...
38
votes
3answers
24k views

How to remove everything related to TeX Live for fresh install on Ubuntu?

How can I remove everything that is related to TeX Live from my Ubuntu 12.04? I first used the backport packages from ppa:texlive-backports/ppa and later the manual install via install-tl-unx.tar.gz. ...
3
votes
0answers
90 views

Getting TexLive Recommended Fonts after installing MacTex-2015 on El Capitan

I downloaded and installed MacTeX-2015 on a brand new Mac OS/X El Capitan system, then ran pdfTeX (i.e. Plain TeX) on an old .tex file and got the following error that I'm hoping you can help me ...
17
votes
5answers
24k views

How to install a latex package in MacOS TeXLive?

I just downloaded cyrillic package into a temp directory and executed: sudo latex cyrlatex.ins It works, but it produces a few dozen files in the same directory. How to place them into my TeXLive ...
0
votes
0answers
23 views

Should I uninstall old version of TeXLive before I install new one?

I have Tex Live 2013 on my computer (Windows 7). Should I uninstall this before I install TeX Live 2015?
0
votes
0answers
43 views

Converting EPS to PDF fails on MacOs with Texlipse

On a mac 10.10.5 with texlipse plugin for the IDE Eclipse (newest version MARS) together with TeXLive/TeXShop I am trying to convert a tex-file with an eps image to pdf and I use epstopdf-package for ...
1
vote
0answers
28 views

(TexLive) after upgrade tex cannot see my fonts [closed]

I upgraded from TexLive 2013 to 2015, now tex cannot see the fonts installed in /usr/share/fonts/. How can I fix this?
2
votes
0answers
39 views

How can I list all the Chinese fonts I have installed? (Ubuntu, TexLive)

I am using package xeCJK and I need to do a \setCJKmainfont{} command but I don't even know which fonts I have available on my system. I have quickly installed a bunch of Chinese fonts but I can't ...
2
votes
1answer
81 views

Biblatex and Polyglossia error after TeX Live update [duplicate]

I've just updated TeX Live distribution (from 2015.37233 to 2015.38831), and now I encounter error whenever biblatex package is loaded provided that default language is Russian. Here's the minimal ...
175
votes
9answers
69k views

How to install “vanilla” TeXLive on Debian or Ubuntu?

Debian and Ubuntu have very good texlive packaging. But I'd like to use tlmgr to have a more fine-grained control about upgrades and which packages I want to be installed. So how do I install ...
0
votes
1answer
45 views

Error on MacTeX 2015 that does not happen on Linux TeX Live

How come (pdf)latex from MacTeX 2015 fails to compile a file that (pdf)latex from Ubuntu’s TeX Live 2015 manages to compile? I thought TeX Live 2015 is included in MacTeX 2015 and it should behave the ...
3
votes
1answer
54 views

\xdef and \fnsymbol problem under TeX Live 2015/MacPorts 2015_6

I'm writing a paper using a cls file provided by the journal (which I cannot modify). They are using some tricky code for creating table notes under tables. Problem is that this code crashes under my ...
7
votes
1answer
133 views

\fmtversion not the same with xelatex and pdflatex

Consider the following MWE \documentclass{article} \begin{document} \fmtversion \end{document} Texlive 2015 was updated today (tmlgr update --all) The command: xelatex file.tex creates a .pdf ...
1
vote
1answer
61 views

How to install a package on texlive? [windows 7]

How to install a package on windows 7? I want to install the following packages for texlive: graphicx graphics subcaption float also, is there a way to see a list of the packages I have installed on ...
0
votes
0answers
19 views

how to update texlive ubuntu14.04 to 2015 [duplicate]

I have texlive 2013 in ubuntu 14.04 I want promoted to texlive 2015 ?
142
votes
8answers
61k views

What are the advantages of TeX Live over MiKTeX?

I have been using MiKTeX for a couple of years. I don't know whether it is "wise" to insist on using it. Could you give me a list of advantages of TeX Live over MiKTeX?
0
votes
0answers
77 views

TeXstudio Error:Could not start build view XelaTex?

enter image description here I can use PDFlaTex, but when I use XelaTex ,error happened
2
votes
2answers
115 views

TeX Live 2015, moderncv and \footersymbol

With TeX Live 2014 I could use the command \renewcommand*{\footersymbol}{{{\rmfamily\textcolor{color2}{~--~}}}} to change the footer symbol in moderncv (\moderncvstyle{casual}). After the ...
14
votes
3answers
381 views

etex package still seems to be necessary in LaTeX2e 2015/10/01?

I've experienced this problem after upgrading to TeX Live 2015 and getting newer versions of all my packages. (Presumably some of those package updates are to blame.) MVE: \documentclass{scrartcl} ...
2
votes
0answers
43 views

marginpar have changed,is it a bug?

In my latex installation, this MWE always gives the warning: marginpars have changed, after multiple runs. But clearly, there is nothing changing. Is it a bug? \documentclass{scrbook} ...
1
vote
1answer
30 views

Can I specify TeXLive version to install in the install-tl profile?

In a TeXLive installation profile, can I specify a specific version or do I just get what I get? I'm having versioning conflicts inside a Docker container which is supposed to be able to reliably ...
1
vote
0answers
159 views

Installing the emerald font on TeX Live 2015

I got a new machine and put TeX Live on it, the version you get from tug.org. Now I need to compile a document that uses the emerald font. I feel like I have tried everything. The font seems to be ...
0
votes
0answers
47 views

unicode-math v.0.8c and LuaLatex error

I try to select math fonts using unicode-math and LuaLaTeX. After a lot of troubleshooting i used the following MWE (similar to the one given in the unicode-math manual): \documentclass{article} ...
0
votes
1answer
66 views

Find the right package for missing files in TeXlive

Is there any way in TeXlive to find the correct package which contains the missing file? I have installed a minimal scheme (without recommended/additional fonts) and now I get this error: The command ...
5
votes
1answer
73 views

Problems with bigfoot and lualatex in TL15

Consider the following MWE (for lualatex): \documentclass{article} \usepackage{etoolbox} \usepackage{fontspec} \usepackage{biblatex} \usepackage{bigfoot} \begin{document} Test \end{document} Up ...
1
vote
1answer
73 views

texlive on Mac: how do I “switch repository” as message says

I run OS 10.10.5 on Macs. I have teX Live Utility version 1.21. When I run it I get a window that says :Repository has a different TeX Live version, The repository at ...