Ubuntu is a Linux distribution based on Debian. It includes TeX and Friends in the form of the TeX Live distribution. Note that http://askubuntu.com is specifically dedicated to Ubuntu questions.

learn more… | top users | synonyms

0
votes
0answers
16 views

How to use TeX in the atom editor?

I would like to try atom. On Ubuntu 16.04, I have the full TeXlive installed. I also have atom. But I have no idea how to compile the file I opened. So far atom seems not to recognise at all the TeX-...
3
votes
5answers
1k views

codecogs like software/ IDE/ LaTeX environment ?

I have been using the website, codecogs for mathematical equations - and it is wonderful for a noob like me. However, I wish to avail of such support when I am offline, is there similar facility for ...
1
vote
1answer
206 views

Texmaker generated pdf file of multi-file latex not showing the position of cursor

I am compiling LaTeX files with Texmaker on Ubuntu 14.04 system. When I run pdflatex and then view the .pdf file (internal), it does not show me the exact place where I am editing on Texmaker i.e. ...
3
votes
2answers
335 views

Using minted package on Ubuntu: .w18 file not found error

I am trying to run the following code through XeLaTeX, using the -shell-escape option: \documentclass{article} \usepackage{minted} \begin{document} \end{document} The file is named guess.tex and ...
6
votes
4answers
7k views

LyX: change PDF viewer

In LyX, how can I set Ubuntu's document viewer (Evince) as the preferred PDF reader for the generated PDF files? All of a sudden it started using Okular, which I don't like all that much.
1
vote
1answer
11 views

on linux: lyx looses changes in preferences after restarting (screen font, color etc)

I am on linux/ ubuntu 14.04 and my user directory can be found in /.lyx. I was able to paste a color theme into /.lyx/preferences but when I try to make changes to the preferences within lyx, the ...
1
vote
1answer
43 views

Bibliography does not work with beamer. Ubuntu 14.04

I've been trying to use bibliography in a beamer document. I have tried in many ways and does not work at all. Here is an example of the document \documentclass{beamer} \usepackage[backend=...
0
votes
0answers
44 views

Texstudio installation error in Ubuntu 14.04

I tried installing texstudio 2.11.0, QT 5 on my ubuntu 14.04 and it gave me the following error: dpkg: error processing package texstudio (--install): dependency problems - leaving unconfigured ...
1
vote
0answers
69 views

Configuring Texmaker for Tex Live

On my Ubuntu machine, I have just downloaded Texmaker and Tex Live. I now want to compile a Latex file which uses the tcolorbox package. From what I have read, this package should come with Tex Live (...
0
votes
1answer
4k views

Why do viewPDF failed to start?

I have just started to work with Latex in Ubuntu environment using Kile. I can produce a pdf file in the working directory hwoever I get an error message when I built the program: [ViewPDF] failed ...
0
votes
0answers
27 views

Installing TexMaker with all packages

I have installed TexMaker on Ubuntu (via Software Center), only to find that some of the packages, is to run sudo apt-get install texlive-full, which apparently comes with all the packages. However, I ...
1
vote
0answers
23 views

Error : could not start the command : pdflatex -synctex=1 -interaction=nonstopmode

I have Ubuntu 14.04 , and a Texmaker. Trying to to compile: \documentclass[11pt]{article} \begin{document} s \end{document} if i compile this file, the following error appears: Error : could ...
0
votes
1answer
343 views

“Log file not found” error for new files

I use Texmaker 4.1 under Ubuntu 14.04. Recently I have to reinstall all LaTeX distributions (LaTeX itself, TeXmaker, additional packages). There are no problems to compile a file that was previously ...
4
votes
3answers
1k views

TexStudio Autosave Recovery Question

So I was using Texstudio to write an article and the computer just froze. I had to restart the computer, my 2 hour work was gone. I was stupid enough to not save it at all... Does anyone know if ...
2
votes
1answer
29 views

pdflatex/lualatex called from shutdown script can not find installed packages

At work I have set up a little backup script on my Ubuntu 14.04.1 machine. The script backs up my machine to an external hard drive. After this is done it copies a LaTeX project to my Dropbox and ...
2
votes
1answer
81 views

Problem in PS2PDF file size

I am using gnuplot to plot an input file. I pass this file to gnuplot from a bash script and the output is .ps. Then I convert it to pdf in my bash script, but the pdf cuts the rest of the plot off. I ...
1
vote
1answer
235 views

Problem with overwriting diagram files using feynmf.sty

I've just installed feynmf.sty from the software center and tried working with a standard example, \begin{fmffile}{simple} % simple.mf will be created for this feynman diagram \begin{fmfgraph}(40,25)...
1
vote
1answer
74 views

Can't run texlive 2015 on ubuntu 14.04

I downloaded texlive 2015 from the Tex Users Group web and successfully installed. After installation I added these lines in my .bashrc: PATH=/usr/local/texlive/2015/bin/x68_64-linux:$PATH; export ...
2
votes
1answer
183 views

Add babel to plain tex [Texlive - Ubuntu 16.04]

To add babel to plain tex in my previous Ubuntu installation I used to do the following: edit the file /etc/texmf/fmt.d/10texlive-base.cnf change the line tex tex - tex.ini into tex tex language.dat ...
2
votes
0answers
66 views

.bbl file not created by BibLaTeX; no preexisting BibTeX conflict [closed]

I run the following code: % !BIB TS-program = biber \documentclass{article} \usepackage[backend=biber,style=ieee-alphabetic]{biblatex} \addbibresource{bibshort.bib} \usepackage[utf8]{inputenc} \...
5
votes
2answers
835 views

Error 32512 (driver return code)

I'm using XeTeX, Version 3.1415926-2.4-0.9998 I'm creating tex file using PHP and storing it on linux server. [ex: abc.tex] Then creating .sh file with command to execute *.tex file using xelatex [ex:...
5
votes
2answers
40k views

How to install a language package in Texmaker on Ubuntu 12.04?

I'm having problems with the babel language package with TeXmaker could someone propose a fix I've typed in \usepackage[french]{babel} and I get the following error: Package babel Warning: No ...
1
vote
0answers
23 views

Set environmental variable to the right texlive version [closed]

I followed this instructions to install a vanilla version of texlive. Everything worked out fine except the part where I have finalize the installation. I used grep -n texbin /etc/environment || sudo ...
11
votes
1answer
11k views

Font problem - errors returned

I am using Ubuntu as OS. When I try to run a tex code, I receive this error from Textmaker : ! Font T1/ppl/m/n/12=pplr8t at 12.0pt not loadable: Metric (TFM) file not found ! Font T1/ppl/m/n/24.88=...
1
vote
1answer
34 views

Add a summary to the pdf writer

In some of the books that I have read, in any pdf viewer, there is some kind of tab where i can see the summary of the document, and I can jump to any part (chapter/section) of the document by just ...
0
votes
0answers
49 views

latex/biblatex: “Missing \endcsname inserted”

all posts on this problem are talking about babel issues. Not my case. Can u tell why i get the error? Thanks in advance! \documentclass{article} \usepackage[bibstyle=publist]{biblatex} \...
2
votes
1answer
262 views

Running TexWorks on Ubuntu

I'm very confused about how I should be using TexWorks on Ubuntu, and what the difference is between TexWorks, TexLive, and MikTex. So, I installed the TexLive package with sudo apt-get install ...
2
votes
1answer
26 views

How to use \watt in lyx

I am trying to use \watt in LyX, but I find that although it is a very simple case, I have spent 1 week to solve it but in vein. First, I found out that if I want to use watt then I must use the ...
0
votes
1answer
99 views

sublime text latex autocompletion for all available packages

I installed the plugin latex-cw on sublime text 3, and this plugin is cool, because it shows me completion for a lot of latex commands. The problem is, if I install or use a new package, latex-cw won'...
2
votes
1answer
57 views

Code that compiled in ubuntu but not working in win 7

I was typing my thesis in ubuntu in gedit and compiling in the terminal and it worked fine but now due to some reasons I installed windows 7 in my PC but the same code is not working in texmaker. When ...
2
votes
0answers
52 views

Texmaker error “File not found” when using a “build” subdirectory for output files

I am using Texmaker in Ubuntu and have a file that worked when compiling using Quickbuild: LaTeX + Bib(la)tex + LaTeX (x2) + dvips + ps2pdf + View PDF. In order to tidy up my directory I picked the ...
4
votes
1answer
72 views

Wrong hyphenation of simple German words using babel with option [ngerman]

I recently had to switch from OS X to Ubuntu and am having trouble with babel's German hyphenation since. I am running texlive 2015 on Ubuntu 15.10. I installed both TeX and the German language ...
5
votes
2answers
2k views

How to use biber with Ubuntu 12.04? [duplicate]

I am using Ubuntu 12.04, TexLive 2012 from backports, TexLive full installation. However, when I try to compile via latexmk, I get an error message that biber is missing. How to get biber working on ...
2
votes
2answers
2k views

Xubuntu 12.04 + Tex Live 2012 no biblatex binary and no biber

I am getting really confused now. I installed Tex Live 2012 on my Xubuntu 12.04 with a backport and I installed TexMaker. I could user PdfLatex right away and it generated everything I needed except ...
1
vote
0answers
102 views

Texmaker 4.4.1 xelatex invokes pdflatex

I encountered an error while trying to compile a xelatex document from texmaker. This is information about my system Ubuntu Gnome 15.10 Texmaker 4.4.1 (installed form synaptic) texlive-2015 full ...
3
votes
0answers
73 views

exported PDFs are different in windows and ubuntu

I am using Texmaker with PDFLaTeX build option in both Windows 7 and Ubuntu 14.04. The .tex uses my institute's template which is said "using scrreprt class of KOMA-Script". The problem is: I can ...
1
vote
0answers
93 views

How to install language packages and .sty for lyx in ubuntu

I'm working in ubuntu 15.10 some files which I made in windows and lyx doesn't compile them. The error results are: Package babel Error. You haven't specified a language option Undefined control ...
5
votes
2answers
4k views

fontspec cannot find fonts on Ubuntu

I recently migrated to Ubuntu from Mac OS. I installed TexLive and it works. However, fontspec doesn't work, no matter what fonts I use. This goes for fonts native to Ubuntu and fonts that I have ...
2
votes
0answers
116 views

No color profile found for RGB screen colors

I am using Texmaker and when building tex file I get the following error: No color profile found for RGB screen colors The files is compiled correctly, it seems that the Texmaker has issue with ...
8
votes
1answer
4k views

Package fontenc Error: Encoding file `eu2enc.def' not found

I got this error while running my tex file in XeLaTeX. For recovering this i install fonts by running following code : sudo apt-get install texlive-full sudo apt-get install texlive-fonts-...
1
vote
0answers
31 views

AuCTeX doens't compile inline equations

I installed on my Ubuntu emacs and AuCTeX (by sudo apt-get install emacs; apt-get install auctex) and when I want to get the preview I get it only for display-style. Here is a screen shot of MWE, Is ...
0
votes
0answers
147 views

epstopdf not working even with pdflatex -shell-escape command

following on from suggestions in this thread: epspdfconversion isn't working I have tried to convert an eps image to pdf using the suggestions below: In the configuring for pdflatex: pdflatex -...
0
votes
1answer
1k views

Download and installation of LaTex for Linux Ubuntu [duplicate]

I'm using Ubuntu and I want to download and install LaTeX, what should I choose and where can I find it? Thanks.
1
vote
1answer
71 views

Kile project setup bug

I tried to make a project setup in Kile, making the XeLaTeX command output directory ../output as an experiment. It 1) didn't work and 2) can't be changed back. Now whenever I try to run the command, ...
2
votes
0answers
167 views

mhchem wants expl3

I am on Ubuntu using TexLive and I cannot compile this .tex file: \documentclass[ letter, 12pt %% set default font size to 12 point ]{scrartcl} %% article, see KOMA documentation (scrguide....
1
vote
0answers
172 views

How to update a package?

I am loading in my file .tex \usepackage{pgfplots} \usepgfplotslibrary{fillbetween} but I get this error: This is pdfTeX, Version 3.1415926-2.5-1.40.14 (TeX Live 2013/Debian) restricted \write18 ...
1
vote
1answer
48 views

Following .Rnw works fine in RStudio but throws error in LyX

This .Rnw compiles fine in RStudio Version 0.99.862 \documentclass{book} \usepackage{Rd} % Rstudio will be able to find this .sty file \begin{document} <<label=Test, echo=FALSE, results='...
19
votes
3answers
8k views

TeXLive won't find files in $HOME/texmf

I just upgraded to Ubuntu 11.10 and was trying to get my custom styles/fonts and the like to work. As on all distributions before, I store them in $HOME/texmf, with a tree structure according to the ...
1
vote
0answers
14 views

How to install texlive on ubuntu and how can I locate texlive after installation? [duplicate]

Months ago, I successfully installed TeXLive on ubuntu 12.04. Weeks ago, I updated my system from 12.04 to 14.04 but my TeXLive stopped work. So, I tried to uninstall my TeXLive and install it again. ...
2
votes
0answers
58 views

Linux Libertine does not show Cyrillic small caps (XeLaTeX)

I'm trying to output any non-latin (in this particular case Cyrillic) small caps with XeLaTex using the following source code: \documentclass{article} \usepackage{fontspec} \setmainfont[ ...