4
votes
3answers
79 views

attachfile does not work inside captions

In the caption of some figures I want to link to files using the attachfile2 package. But when I try to compile the following example with XeTeX, MiKTeX and TeXstudio I get the warning ** WARNING ** ...
0
votes
1answer
28 views

No hyperref link in stackrel with xelatex

Consider the following example document: \documentclass{article} \usepackage{amsmath} \usepackage{hyperref} \begin{document} \begin{equation} \label{eq:eq1} a = b\quad \wedge \quad b = c ...
3
votes
1answer
48 views

\textsuperscript inside \section (XeLaTeX)

How can I get work \textsuperscript inside \section? \documentclass[unicode, fontsize=9pt, twoside=false, russian, a5paper]{scrbook} \usepackage{polyglossia} \setmainfont{PT Serif} \setsansfont{PT ...
4
votes
1answer
37 views

Problem with \% in PDF bookmark under XeLaTeX

A MWE is: % !TeX program = XeLaTeX \documentclass{article} \usepackage{hyperref} \begin{document} \section{\^e\%} \section{20\%} \end{document} It can work fine under pdfLaTeX and LuaLaTeX. But ...
2
votes
0answers
99 views

A rather peculiar problem: XeLaTeX, hyperref and lots of warnings [closed]

When I compile my document using XeLaTeX I get the following error: ** WARNING ** Can't begin an annotation when one is pending. ** WARNING ** Interpreting special command bann (pdf:) failed. ** ...
5
votes
1answer
129 views

Tweaking Biblatex-chicago citation format

I'm hoping this hasn't been asked elsewhere already; if so, I apologize. My issue is that I am trying to format my dissertation using Chicago style (biblatex-chicago). I am using XeLaTeX + ...
3
votes
1answer
935 views

Package hyperref Warning: Token not allowed in a PDF string [duplicate]

My document contains section titles that are formatted by the listings package. (The section names are names of configure script switches.) ...
11
votes
1answer
206 views

/ActualText in small cap hyperlinks

I'm using the frenchlinks option for hyperref, which due to solicitous care of XeLaTeX + Linux Libertine, gives bona fide small-caps links on the page. The problem is, when I cut and paste out of the ...
3
votes
0answers
65 views

How to make hyperref link boxes in XeLaTeX as big as they are in pdfLaTeX

When typesetting the following sample using xelatex, the various clickable link-boxes produced using \ref, \cite, \footnote, \href, etc. are small and ugly, and sometimes make it hard to read the ...
4
votes
0answers
183 views

Beamer: problem with \framezoom and XeLaTeX

I have a problem getting the \framezoom command to work when compiling with XeLaTeX, using fully updated MikTeX 2.9. Here is an example: \documentclass{beamer} \usepackage{mwe} \begin{document} ...
1
vote
0answers
30 views

\href and \includegraphics not making hyperlinks in XeLaTeX [duplicate]

I need to make hyperlink on a image. For that, I setup as follows. \href{http://stackexchange.com/users/1170155/thekojueffect?tab=accounts}{\includegraphics[height=11pt]{stackexchange.png}} The ...
3
votes
0answers
87 views

Hyperref TextFields dont't work when in tabular environment with xetex?

I created a pdf fillable form in LaTex using hyperref text fields, then decided that I wanted to change the font of the whole form, so I tried to use XeTeX with fontspec. Unfortunately, when I do ...
4
votes
1answer
171 views

How to get polyglossia with babelshorthands to work with hyperref and csquotes?

I just switched from babel to polyglossia and got several errors which are related to the usage of \enquote in \section. The problems only occur if babelshorthands=true is set for polyglossia and ...
5
votes
0answers
124 views

Clickable box malformed in TOC when using math in heading and the Latin Modern Math font

The clickable box (the actual hyperlink) in the TOC is too heigh when using the Latin Modern Math font. Using Cambria Math everything looks normal. Using the \texorpdfstring{}{} command does not ...
5
votes
1answer
191 views

Strange bug with hyperref, percent symbol and cyrillic character

I minimized it to the following snippet: \documentclass{article} \usepackage{hyperref} \begin{document} \section{\%н} \end{document} When I compile it: xelatex test.tex the first run compiles ...
6
votes
1answer
307 views

Clickable hyperlink with \overset and XeLaTeX

I would like my document to have clickable hyperlinks inside \overset environments. I'm using XeLaTeX because of the fonts… This is a (rather) minimal example: \documentclass[a4paper, 12pt]{article} ...
4
votes
1answer
113 views

List of theorems: no links when problem title is non-english

I'm trying to make use of this solution to get list of problems. I'm using XeTeX, and if I use non-english as a problem name -- hyperref's links to problem in "List of problems" doesn't work. Here's ...
7
votes
1answer
200 views

href not working with image (but OK with text)

When I use a text in \href fine, but if I use an image it does not generate a link at all. \documentclass{article} \usepackage{hyperref} \usepackage{graphicx} \begin{document} ...
1
vote
1answer
369 views

Hyperrefs in advanced ToC in XeTeX

I'm trying to apply this awesome template. I'm using XeTeX and russian -- and it gives: ! Missing \endcsname inserted. <to be read again> \csname\endcsname l.5 ...
2
votes
1answer
565 views

“improper alphabetic constant” with hyperref and bidi packages

I'm getting an "improper alphabetic constant" error in xelatex which appears to be due to an interaction between the bidi and hyperref packages, when I redefine the \section cmd. Here's an MWE: ...
5
votes
3answers
680 views

hyperref bad references

After cleaning up my project and compiling a tex file 10 times in a row: rm temp.toc temp.pdf temp.out temp.html temp.aux xelatex temp.tex # executed 10 times! I still get bad references with ...
5
votes
2answers
143 views

How to disable 'totpages' anchor link created by 'hyperref'?

I've been searching like hell for this, trying to hack the totpages and/or the hyperref packages but to no avail... The totpages package automatically creates link on every reference to the total ...
7
votes
2answers
483 views

Strange error when unicode-math and hyperref are combined in xelatex

The following is an MWE for a problem that I'm facing: \documentclass{article} \usepackage{hyperref} \usepackage{unicode-math} \setmathfont{Asana Math} \begin{document} \section{$2\times 2$} $2 ...
5
votes
2answers
2k views

TeX Live 2012, XeLaTeX, moderncv, error “Failed to convert input string to UTF16”

I'm getting this error from moderncv version 1.1.1. With earlier version everything was ok and I did not make any changes to my tex document. I don't use any special font. File encoding is set to ...
0
votes
1answer
131 views

URLs set with lining figures regardless font settings

I’ve noticed during my XeLaTeX typesetting with hyperref package that since not so long ago, URLs (using \url) have been typed in lining figures (as opposed to the oldstyle figures) whatever my ...
0
votes
1answer
211 views

Cannot add metadata to pdf [closed]

i noticed that i am not able to add metadata to my pdf.. any clues? Here is a minimal working example. The produced pdf has no author or title metadata. I am using miktex and texworks. % !TeX program ...
4
votes
1answer
416 views

Problem when bidi & hyperref packages are used with custom document class (XeLaTeX)

There is a problem when bidi & hyperref packages are used together and custom document style is used. For example: \documentclass[unicode]{myreport} \usepackage{xltxtra} \author{Author} ...
10
votes
2answers
666 views

Substitute italic ampersand with alternative ampersand in Linux Libertine O

Based in this answer I want to create a command \amper that uses the alternative ampersand of Linux Libertine O and leaves the regular \& alone. The problem with the MWE below is that hyperref ...
7
votes
1answer
189 views

hyperxmp + xelatex bug: duplication of pdfkeywords

I found an annoying bug(?) relating to the pdfkeywords metadata field which hyperref allows to set. When hyperref is used in combination with hyperxmp and the document is compiled with xelatex the ...
0
votes
0answers
47 views

Xelatex hyperref problem [duplicate]

Possible Duplicate: Hyperlinking a drawing I need a drawn line hyperlinked a specific page in the document. In the following MWE when I comment out polyglossia package and use PDFLatex, it ...
7
votes
2answers
478 views

Hyperlinking a drawing

Is it possible to hyperlink a drawn line to a specific page in the document? I use following command to draw a line: \line(1,0){20} Many thanks! Here is MWE: \documentclass[a4paper]{article} ...
1
vote
2answers
2k views

\hyperref to a \label doesn't work (“empty destination key”)

In one of my documents, I used the combination of \label with \hyperref. Now, I fail for some reason. I included the package: \usepackage[colorlinks=true,urlcolor=blue,linkcolor=blue]{hyperref} ...
6
votes
2answers
288 views

XMP with XeLaTeX

I got the hyperxmp package to include XMP copyright information with regular LaTeX but with XeLaTeX there seems to be a problem. I need XeLaTeX for its better font support and typographic features. Is ...
15
votes
1answer
690 views

Is there a poisonous interaction between memoir, hyperref, and hyperxmp?

In another, now rather confused, question, I'm struggling to get copyright information into a PDF produced by memoir. The investigations so far have led to this problematical MWE: % !TEX TS-program ...
2
votes
1answer
2k views

hyperref error when using XeLaTeX and fontspec with LaTeXmk

I have defined a compilation tool for TeXWorks as follows: Program: latexmk Arguments: -e $xelatex=q/xelatex $synctexoption %0 %S/ -pdf $fullname It works fine in ...
6
votes
2answers
12k views

How to fix “Package hyperref Error: Wrong DVI mode driver option `dvips'”?

I'm having this Error when I try to compile my .tex file with xelatex: ! Package hyperref Error: Wrong DVI mode driver option `dvips', (hyperref) because XeTeX is running. See the ...
3
votes
1answer
1k views

Undefined color error for URL, when compiling with XeLaTeX

I've defined a different color for hyperlink using \hypersetup command with urlcolor. When I am compiling it with XeLaTeX I am getting undefined color error for the URL link, but it works fine when I ...
2
votes
0answers
622 views

XeLaTeX, hyperref and page breaking [closed]

Using XeLaTeX, loading the hyperref package apparently changes the way in which (reconfigured) widow and orphan penalties work — so they reappear, just as if I had not altered the values for the ...
2
votes
1answer
2k views

XeLaTeX, \includegraphics and \hyperlink

I have question regarding XeLaTeX. I have switched from LaTeX to XeLaTeX because I wanted to use ttf fonts and now I have a problem with \hyperlink. It works with text, but it doesn't with images. So ...
6
votes
1answer
752 views

Hyperref ignores \setdefaultlanguage from polyglossia

I use polyglossia to set my default language with \setdefaultlanguage to German. This works for the captions of tables, figures etc. I want to reference to these figures with the \autoref command of ...
2
votes
1answer
829 views

Xelatex and hyperref to file

I would like to add link to video in the same folder where pdf document is stored. There is code: \documentclass[a4paper,10pt]{article} \usepackage{hyperref} \begin{document} ...
12
votes
3answers
2k views

How to change the PDF producer metadata with XeLaTeX on MikTeX

I tried to change the PDF Producer of the generated PDF file with XeLaTeX, but it always be "MikTeX-xdvipdfmx (0.7.8)", if the PDF is generated with pdflatex, it will change as I wish, does anybody ...