Tag Info

New answers tagged

12

Here I provide \dhat{} and take the effort to account for the slant by adding an \hspace equal to 0.2\ht0 where the argument has been stuffed in the 0 box (I am assuming a slant value [tan(slantangle)] of 0.2). EDITED to work in the smaller mathstyles. REEDITED to refine inter-hat kern for more uniformity across mathstyles. \documentclass{article} ...


6

For the “double acute accent”, see https://en.wikipedia.org/wiki/Double_acute_accent The accent is used in Hungarian to denote the long variant of ö and ü and realized in TeX with \H{o} and \H{u}. For example, the correct spelling of a great mathematician is Erd\H{o}s that gives Erdős German doesn't use this accent, so M\"{o}ller is the correct ...


1

I have no problem compiling, if I declare Lucida Sans Unicode as main font. I suspect Lucida Sans is a type 1 font, requiring font encoding declaration, &c., which might be the source of the problem. Incidentally, to have nice quotes in your bibliography, load csquotes. Without it, I had hideous fake opening quotes. Also, you may type accented letters ...


4

You shouldn't use \def to define your accent command – this will break the definitions of other encodings. Also you shouldn't load fontenc after fontspec as this changes the default encoding. I would redefine \' like this (I don't have your accentbx package, so I'm using \fbox as example): \documentclass{article} \usepackage{fontspec} ...


4

Due to it being overloaded by the tabbing environment latex has a saved version of \' known as \@acci that is restored in parboxes and similar places. So after redefining the accent redefine the saved copy \makeatletter \let\@acci\' \makeatother


0

Not really. I found out I need different encoding for my iMac and MacBook to prevent the errors. Probably some different makeup of the environments. I decided to be pragmatic and uncomment one of these LaTeX commands depending on the machine I'm working on: \usepackage[latin1]{inputenc} % works on iMac \usepackage[utf8]{inputenc} % ...


3

For an “underdot” accent in math mode, use the accents package: \documentclass[12pt]{article} \usepackage[utf8]{inputenc} \usepackage{amsmath,accents} \DeclareUnicodeCharacter{1EA1}{% \ifmmode \underaccent{\dot}{a}% \else \d{a}% \fi } \begin{document} ạ $ạ$ \end{document} However, I'd avoid using ạ in math mode for this, as “a with an ...


4

You need the package inputenc (and the option for the encoding of your editor) for this and you should type ' instead of ` for the apostrophes (this last point could be some issue of copy/pasting on my system...). % arara: pdflatex \documentclass[12pt]{amsart} \usepackage[utf8]{inputenc} % my editor is set to use utf8 and this would be my recommendation ...


2

If you really(!) need to do it with math-characters you can use \DeclareUnicodeCharacter{0109}{\ensuremath{\mathrm{\hat{c}}}} \ensuremath makes sure you use math-mode (whether you are in a math-environment or not). \mathrm switches to upright math-font and should make it consistent with normal text.


7

You can declare characters for use in text or math or both \DeclareUnicodeCharacter{0109}{\^c} \DeclareUnicodeCharacter{0109}{\hat{c}} \DeclareUnicodeCharacter{0109}{\ifmmode\hat{c}\else\^{c}\fi} \DeclareUnicodeCharacter{0109}{\TextOrMath{\^{c}}{\hat{c}}} But the definition that you suggest \DeclareUnicodeCharacter{0109}{$\hat{c}$} is the worst of both ...



Top 50 recent answers are included