Tag Info

New answers tagged

3

Just place the first \multido cycle into an animateinline environment, replace \multido{\i = \nImages+-1}{\nImages}{% by \multiframe{\nImages}{i=\nImages+-1}{% and remove \newpage from the loop body. Then latex, dvips, ps2pdf: \documentclass{article} \usepackage[ a4paper, margin = 2cm ]{geometry} \usepackage[utf8]{inputenc} ...


1

This issue occurs in newer animate versions. To be fixed in the next version. As a workaround, try: \documentclass{article} \usepackage{animate} \begin{document} \begin{tabular}{l} {\animategraphics{12}{Anim/debut}{1}{22}} \end{tabular} \end{document}


0

A best practice approach (IMHO): Step 1 Put each diagram in a separate compilable input file with standalone document class as follows. % frames.tex \documentclass[pstricks,border=12pt]{standalone} \begin{document} \foreach \r in {0.1,0.2,...,1.0}{% \begin{pspicture}(4,4) \pscircle(2,2){\r} \end{pspicture}} \end{document} Because the diagram is ...


1

You don't need to use controls to pause/run an animation: Animations pause when the mouse button is pressed while the pointer is over the animation area. Keep the button pressed while moving it out and the animation remains paused. After the next click the animation continues. BTW, the players [AV]Player.swf of the media9 package behave in the same way.


2

using controls and loop option together. \animategraphics[controls,loop, trim=12.5cm 3.5cm 12.5cm 4.2cm, width=0.45\textwidth, height=0.35\textheight]{1}{pics/animation/prog_with_step/step_}{2}{20}}


2

Put each frame content into a minipage of desired width and height, such as \documentclass{article} \usepackage{animate} \usepackage{listings} \usepackage{xcolor} \begin{document} \begingroup\parindent=0pt \begin{animateinline}{1} \begin{minipage}[\baselineskip]{6cm} \begin{lstlisting}[backgroundcolor=\color{black!50},linewidth=\linewidth] i = 1 ...


2

You cannot not put hyperlinks inside animate frames. The problem is not the reference itself but the fact that hyperref tries to put an hyperlink at the \ref location. The solution is to enclose the animateinline with \begin{NoHyper}...\end{...} to prevent hyperref from adding a link. More info here: Strange interaction between hyperref, listings and ...


2

This issue was fixed in version 2014/03/06. Please update the animate package.


3

You have plenty of unprotected end-of-lines in the definition of \qnorm; spaces are ignored in the argument of \pgfmathparse, but not in other places of \pgfmathdeclarefunction. \documentclass{article} \usepackage{pgfplots} \usepackage{tikz} \usepackage{animate} \usepackage{geometry} \usepackage{hyperref} \usepackage{hypcap} \pgfplotsset{compat=newest} ...


4

The problem is that package animate has to use XForm objects for the appearance streams of the annotation. There pdfTeX does not allow destinations, which are automatically added by hyperref for the listings. A workaround is environment NoHyper of package hyperref, which disables the hyperref stuff temporarily: \documentclass{article} \usepackage{hyperref} ...



Top 50 recent answers are included