Tag Info

Hot answers tagged

14

This is a bug in biblatex 1.7 and the \RequireBiber[3] setting it appears. This was changed in biblatex-apa style 4.5. You can change the apa.bbx file to \RequireBiber[2] to fix it. I have released version 4.6 of the style with this setting and it should be in TL today.


13

Greetings, I'm the author of biblatex-apa. I know what the problem is with this and I should have a fix and new release of biblatex-apa tomorrow on CTAN.


12

A minimal example would have been appreciated. ;-) (I'm working with the standard biblatex styles and didn't know about biblatex-apa's \DeclareLanguageMapping.) I regard the following solution as rather "hackish" because a) I don't know the functioning of this particular \textcite command b) other commands besides \textcite might be in need of change as ...


12

This is also quite easy to do. I'm assuming that the doi and url fields trump the publisher and location field, so the way to implement this is to only print these fields if the doi and url fields are undefined. So we add the following: \renewbibmacro*{location+publisher}{% \iffieldundef{doi}{ \iffieldundef{url}{ \printlist{location}% ...


12

if you can use the package biblatex, it is easy: \documentclass{article} \usepackage{filecontents} \begin{filecontents*}{demo.bib} @book{test, author = {Herbert Voss}, title = {Me, I and myself}, year = 2010, location = {Berlin}, url = {http://www.myirl.org}, urldate= {2010-03-04}, } \end{filecontents*} ...


12

Documentation: You can find the documentation for bibliographies here: bibmod-doc A new implementation is currently in beta. You can find the documentation for it here: mkiv-publications From BibTeX to ConTeXt MKVI Some examples: These citation styles seem to work out of the box: (Author, YYYY) \cite[alternative=authoryears][author2001] Author ...


11

I've been able to answer my own question using various hacks I found on tex.sx. As @PLK pointed out, there appears to be a compatibility issue with polyglossia and Biblatex, but among all the styles I tried this issue is only visible with the APA style. So I am using authoryear-comp instead that suits the requirements I stated. This might be useful for ...


11

I could replicate the error on my TeXLive 2011 Mac installation after updating to current packages via TeX Live Utility (biblatex 1.7, biblatex-apa 4.4, biber 0.9.8). A quick fix for me was a change to the apa.bbx file in line 29: \RequireBiber[3] % Biber is strictly required now due to custom sorting to \RequireBiber[1] % Biber is strictly required now ...


11

The problem is not directly related to polyglossia. The problem is that that there is no english-apa.lbx. The existing british-apa.lbx defines extras for british. And as mentioned in the biblatex documentation "\DeclareLanguageMapping is not intended to handle language variants (e. g., American English vs. British English) or babel language aliases (e. g., ...


11

The problem with your sample document is that you are missing the line \DeclareLanguageMapping{american}{american-apa} This should appear after you have loaded biblatex. If you are still having problems with your sample document, the following sample document works correctly with a standard MacTeX/TeXShop setup. (Although I was able to get your example ...


10

The conjunction particle that's inserted between authors' names is determined by the bibliography style you've selected. It would appear that you're using the apalike bibliography style. Here's what you could do to change "and" to "i": Find the file apalike.bst in your TeX distribution, make a copy, and name the copy, say, apalike-catalan.bst. (Do not edit ...


10

I think \renewcommand*{\bibfont}{\scriptsize} will help! ;)


10

To force a comma in all cases, you are right to target \finalnamedelim. The correct version is \renewcommand*{\finalnamedelim}{% \finalandcomma \addspace \bibstring{and}% \space }


10

Short: If you define backend=biber then you should actually use biber as your backend and not bibtex. Or you can define backend=bibtex and use bibtex. Longer: biber is a program specifically meant to replace bibtex (the program) for biblatex. It does everything bibtex does and much more. Among other things it can handle UTF8 encoded files flawlessly, ...


10

This is, in fact, the correct disambiguation behaviour. When you cite the 2004 paper, the biblatex "uniquelist" feature (which APA requires) expands the name lists to the point of minimum ambiguity which is: Stroebe & Nijstad et al. Strobe & Nijstad However, since "et al" is plural and should not replace only one name, the hidden name is printed ...


9

As I mentioned in the comments, this will only be possible if you add meta-data to the .bib file to indicate whether a particular journal has "per issue" or "per volume" page numbering. However, this isn't very difficult to do, and you can probably add fields conditionally with your bibliography manager. Here's an example of how this would work in ...


9

You should not load a package. To use the apa style, just specify it in the options for biblatex. Hence, remove \usepackage{biblatex-apa}, and it should work. From the manual, section 2: Specify the style in the usual way when loading biblatex. \usepackage[american]{babel} \usepackage{csquotes} \usepackage[style=apa]{biblatex} ...


9

Make a copy of apa.bst. (In a current TeX Live distribution it is located in /usr/local/texlive/2011/texmf-dist/bibtex/bst/beebe/apa.bst ). Call it myapa.bst or something appropriate, and save it in your local texmf folder: <path to local texmf>/bibtex/bst. Edit the function {format.names} Change line 250 { " and " * t * } to { " \& " * t ...


9

This is a result of the disambiguation performed by biblatex for authoryear type styles - to avoid mistaking people with the same surname (but different initals or names), it dynamically adds initials or full names (as set by options). The apa style adapts that to add square brackets around those. For details see section 4.11.4.1 of the biblatex manual. To ...


8

I have used @unpublished{key, title= {talk title}, author = {author names}, year = {year}, note= {conference name}, URL= {url link to talk abstract if any}, } to cite conference talks in my thesis


8

Now the correct one ;-) The option sortcites should work: \documentclass{article} \usepackage[american]{babel} \usepackage{csquotes} \usepackage[style=authoryear,backend=biber,useprefix=false,sortcites=true]{biblatex} \usepackage{ifpdf} \makeatletter \AtBeginDocument{\toggletrue{blx@useprefix}} \AtBeginBibliography{\togglefalse{blx@useprefix}} ...


8

The difference here is caused by slightly different bibliography drivers for the book entry type and the incollection entry type. In the driver for the book type, there is the following code fragment: ... \usebibmacro{location+publisher}% \newunit\newblock \usebibmacro{doi+eprint+url}% \setunit*{\addspace}\newblock \usebibmacro{origyear}% ... ...


7

The problem here is one that I suspected could occur: adding beamer colours to bibliographies is something of a hack, and is more risky with biblatex than with traditional BibTeX styles. When adding to biblatex styles, we have to target the drivers 'during' the formatting: with traditional BibTeX, it's essentially done 'after' the formatting. That's an ...


7

This is correct APA 6th edition style, see section 7.01, example 2.


7

If you are writing in German - or are not too fond of sentence case (in its English meaning, that is capitalisation of the first letter of the sentence, and only that) anyway - you might want to "turn off" the conversion by \DeclareFieldFormat{apacase}{#1} in the preamble. If you just have the occasional German entry, or prefer English sentence case, save ...


7

There is no need to alter the bib file. It is possible to add the information about the original publication using \DeclareSourcemap \DeclareSourcemap{ \maps[datatype=bibtex]{ \map{ \step[fieldsource=entrykey, match=\regexp{test1}, fieldset=related, fieldvalue={test2}] \step[fieldsource=entrykey, match=\regexp{test1}, ...


7

You can patch the command that formats the endnote to add \RaggedRight to it. The easiest way to do this is with the etoolbox package, using the \appto macro, which appends code to an existing macro. \usepackage{etoolbox} \appto{\enoteformat}{\RaggedRight} Here's your sample document: \documentclass[endnotes]{apa6e} \usepackage{etoolbox} \title{} ...


7

You can use \defbibheading to change the bibliography heading; in the preamble of your document you can say something like \defbibheading{bibliography}{% \section*{\normalfont\refname}} or using \bibname instead of \refname.


7

biblatex-apa already has this feature - you just need to use the shortauthor field in your bib file. Note that corporate names need to be wrapped in braces so that they don't get parsed into elements of a person's name. \documentclass{article} \usepackage[ngerman]{babel} \usepackage{csquotes} \usepackage[style=apa,sortcites,backend=biber]{biblatex} ...


7

Actually, if you look at APA 6th 4.03 and also here: http://blog.apastyle.org/apastyle/2011/04/using-serial-commas.html You'll see that APA 6th edition style says serial commas are only for lists of three items or more. I changed the biblatex-apa style accordingly in version 5.5 and that's why you noticed the change. It's in the changelog for the style: ...



Only top voted, non community-wiki answers of a minimum length are eligible