Tag Info

Hot answers tagged

4

Here is a solution the does not disable the guillemets in French documents. Thanks to Giordano and David Carlisle for providing all the pieces necessary to assemble the information. AUCTeX thinks any document that loads the class you're using (call it foo.cls) is in French. It thinks that because it has compiled foo.cls into a file (foo.el or foo.elc) that ...


4

From the AUCTeX manual 2.5 Entering Mathematics TeX is written by a mathematician, and has always contained good support for formatting mathematical text. AUCTeX supports this tradition, by offering a special minor mode for entering text with many mathematical symbols. You can enter this mode by typing C-c ~. Command: LaTeX-math-mode (C-c ~) ...


3

From the *Messages* log I deduce the "offending" class is msp.cls. Unfortunately I can't find it on the Internet to test it, but anyway in the /var/lib/auctex/emacs24/msp.elc file there should be a "french" string somewhere. Just remove it (you'll need to edit it with root privileges, from within Emacs issue C-x C-f /sudo::/var/lib/auctex/emacs24/msp.elc ...


3

I found a reasonable workaround here on SuperUser (by giordano). The code that fixed it was: (add-hook 'TeX-language-fr-hook (lambda () (setq TeX-quote-language `("francais" "``" "''" ,TeX-quote-after-quote)))) Obviously, this doesn't solve the underlying problem of why AUCTeX is entering French mode when it doesn't need to, but it does put ...


2

Thanks to Giordano and David Carlisle who provided the key information, here is a complete answer. In the package file, replace \RequirePackage[english,francais]{babel} by \@nameuse{RequirePackage}[english,francais]{babel}. Now when your user's auctex compiles the file (which you can also do within emacs, for testing, with M-x TeX-auto-generate), the ...


2

I installed the AUCTeX according to its manual. I wrote a small tex file, but I did not figure out how to get a side-by-side preview like that of TeXStudio for example. I found one here called latex-preview-pane. It works but still do not get a PDF only bohemic script instead (see image below). Author of latex-preview-pane here. It looks like (as ...


2

Note that it is very easy to introduce spurious spaces if making macros such as the one shown which can make a spurious "white" line above the equation consisting of just an indentation box and \rightskip glue. It adds less than \baselineskip of vertical space as it cause \bovedisplayshortskip to be used instead of \abovedisplayskip as the line abovethe ...


2

In line with what @Johannes_B says and @DavidCarlisle 's response, you would be better of creating a abbreviation within emacs. By typing something such as /eqn emacs will see this as an abbreviation and expand it to what you want. There are various ways of setting up abbreviations. Here's an approach that I use: Create an new abbreviation table ...


1

In your .emacs file, append the following code: inoremap <buffer> `a \alpha inoremap <buffer> `b \beta inoremap <buffer> `c \chi inoremap <buffer> `d \delta inoremap <buffer> `e \varepsilon inoremap <buffer> `f \varphi inoremap <buffer> `g \gamma inoremap <buffer> `h \eta Restart emacs. These should help you ...



Only top voted, non community-wiki answers of a minimum length are eligible