Tag Info

Hot answers tagged

18

The following macro \midruleV sets a \midrule every five rows. Counter midruleV is used to count the rows inside a block of five rows. Therefore the counter is reset before the table and after the header, because the header does not count. The larger problem is finding a place to put \midruleV. The example puts it after the last cell by escaping the current ...


8

Here's an option using the pgfplotstable package. The idea is to read the data into a macro (called edytable below) and then typeset it using the command \pgfplotstabletypeset[ columns/Student Id/.style={string type}, columns/Name/.style={string type}, every head row/.style={ before row={% \toprule ...


7

Yes, this is a bug and will be fixed in WinEdt 8.2. In the meantime, you can get things working properly in this way. Open Tree.ini from the "Options Interface". Do the following global replacement with Regular Expressions on: Search for: <\(0@{ }\)MACRO="GlobalReturn;\(1*\)GlobalMark;" Replace with: <\0MACRO="GlobalMark(1);GlobalReturn;\1" ...


7

This is a misunderstanding: LaTeX doesn't help you to write your text, which is the job of the editor. I'm quite confident that such a thing (capitalize each first letter after a dot) can be achieved with emacs or vim. Word is all and everything in one: editor, typesetting machine, spreadsheet and so on and does nothing really well (OK, millions of people ...


6

You can use physics package and exploit its expval (or the short ev) command: \documentclass{article} \usepackage{physics} \begin{document} $\langle x \rangle $ $\langle x^{A} \rangle$ $\expval{x}$ $\ev*{x^{A}}$ $\expval{x^{A}}$ $\ev{x^{A}}$ \end{document} Or use mathtools package and define a macro \DeclarePairedDelimiter\ev{\langle}{\rangle}% ...


5

You asked texstudio! Open Macros → Edit Macros: In this window, Click +Add. This should add the third macro. Enter a name Enter the text you want to be inserted by macro Click OK Now, in Macros menu you have this: Now in your tex file, press Shift + F3 the string To whom so ever it may concern will be inserted. On the other hand, if you want it ...


4

When you type \begin{itemize} the completion options are shown under the environments completion scheme, not under itemize completion. Hence you will get \begin{itemize} content ... \end{itemize} Here itemize is treated as an environment. If you want itemize completion with \item use the menu \begin{itemize} available under, LaTeX → List Environments. ...


4

Make sure that you use TeXStudio in master mode. To cite the manual of TeXStudio section 4.1: TeXstudio allows you to work onto documents separated in several files. To include a TeX file into your document, just use the "\include{file}" command in the "LaTeX" menu. The file will appear in the "Structure View". With a click on his name, TeXstudio will ...


4

In the menu, select User > Customize Completion. Then add \begin{flalign} to the list of commands. You can also specify arguments using @, e.g \foobar{@}.


3

I think another solution would consist in using this macro (which I name d-math.edt in the explanations that follow): BeginGroup; InsLine; GoToBeginningOfLine; Indent; Ins("\[ \]%"); PreviousBullet; EndGroup; The macro shortcut is defined through this addition to the Shortcuts menu in `MainMenu.ini: ITEM="\[ \]" ...


3

I don't think this is a good idea: the file names should not have a hardwired numbering. I suggest a “labeling system”: \makeatletter \newcommand{\definefile}[2]{% #1 is a label, #2 is the file name \global\@namedef{fn@#1}{#2}% } \newcommand{\loadfile}[1]{% #1 is a label \input{\@nameuse{#1}}% } \makeatother \definefile{01_01}{ch01_01-motivation} ...


3

Made comment into answer which satisfied the OP Options-->Configure Texmaker-->Editor--> Is completion checked on and add .bib extension \addbibresource{biblatex-examples.bib}. Check if you can see .bib file in Structure on left side pane or open the .bib file with Texmaker from File menu.


2

Using CTRL + Right will suffice under TeXstudio 2.6.6 (hg 4105+:b24377c712d7+) using Qt Version 4.8.5, compiled with Qt 4.8.5 R. The manual says under section 1.5 Configuring the autocompletion: Use Placeholders: if the completed commands have options which need to be filled out, "place holder" are put at this positions and they can be jumped to by ...


2

Please uncheck "close parentheses automatically". It can be found "Options / configure TeXStudio" (see screenshot). It does work for me under TeXStudio 2.8.6 (Kubuntu 14.04). Edit: as for the shortcut CTRL+I. I don't think there is an easy way to achieve that. You will have to either alter an existing cwl file (where the definitions are stored) or create ...


2

If you type enum and press Tab you will get this: Similarly type item and press Tab to get To put a new \item press Shift + Enter at the end of line For a quick view of these short cuts Press Tools and then Snippets (Cntrl+L, Cntrl+S) to get


2

Not a solution, but a longer comment: For some people, automatic capitalization of some word processors is a "bug", not a "feature". As pointed Gonzalo Medina. The reason is that in practice there are many exceptions, and supervise/correct every automatic decision is very distracting. In my case, overall I hate write correctly abbreviated name species ...


1

This feature (autocompletion) should be the default feature. To ensure it, go to Edit → Preferences. In the editor tab of the window that opens autocompletion (under global editor options) should have been checked like this: Then read this: This is available under the help menu - A short manual for TeXworks. All you have to do is type bfig and press ...


1

For customized commands in TeXMaker add them to your customized completion list. In TeXMaker menu go to User > Customize Completion Here you can add a new command, which should be available in auto-completion then. See also Customize auto-completion in Texmaker for more detailed example.


1

Actually you can capitalize the beginning of a new sentence by making . active and redfine it to first test if a space is following the period and then executing \ucmacro (a macro version of the \uppercase primitive) when a space was found and to print whatever was found when it wasn't a space: \documentclass{article} \begin{document} \let\period=. ...


1

I posted the issue on the website recommended and got a very helpful reply: Updates: Status: Done Comment #1 on issue 1306 by ... : Auto-completion for \citet http://code.google.com/p/texmaker/issues/detail?id=1306 You can add what you want for the auto-completion : "User" menu -> "Customize completion" : \citet{#bib#} I wasn't aware that you could do ...


1

you can create a user.cwl file with the following content \langle%|\rangle %|marks the place of the cursor. Place the file in your settings directory and activate it in Options -> Completion. You can find more information on the cwl format in the manual. For more complex things you can use skripting with triggers.


1

You are looking at the "Completion" Configuration panel, which refers to auto-completion of Latex commands. The option to (un)check "Auto Complete Parentheses" is in the "Adv Editor" pane.


1

TeXstudio only has a command completion (based on the cwl files). There is no word completion (also not for words that already appear in the document). You can however achieve something similar for fixed word lists by scripting.


1

Thanks to user cfr for suggesting this work-around (see discussion here)! To solve the double quote effect of ' mark, go to Settings menu > Configure Kile > Editor > Editing > Auto-Brace plugin. Select it and click on its configuration button, on the right. Un-check the option "Automatically add closing quotation marks". A msg box will pop-up telling you ...


1

yasnippet and auto-complete mode are similar but distinct packages. You can use them simultaneously, and both will complete your input after pressing TAB. What you describe happens when you expand a (ya)snippet that waits for further input. If you change your mind midway, first abort the current action (Ctrl-G), then use undo repeatedly to roll-back the ...


1

I assume, the fixme.cwl was autogenerated. It seems that in this case the autogeneration mechanism was not able to extract the information from the fixme package that \fxnote is a valid command. Check if \fxnote is in your fixme.cwl. If not, simply add it (Note: You need to restart TXS afterwards). If this did not help, see the FAQ on unrecognized commands ...



Only top voted, non community-wiki answers of a minimum length are eligible