New answers tagged

0

If you want to use csquotes you should make the quotes active, and input them (also the colon) without spaces as spaces can insert unwanted break points: \documentclass[12pt]{article} \usepackage[paperwidth=14cm,paperheight=20.5cm]{geometry} \usepackage{libertine}% use this font and geometry width to reproduce bad break \usepackage{ifxetex} \ifxetex ...


3

For babel, you have to use \frenchbsetup{og=«, fg=»}. For polyglossia, you have nothing to do, except the package inserts a breakable space (bug?), so in case the space does break, you have to insert an unbreakable thin space by hand (\,`). % !TeX TXS-program:compile = txs:///xelatex/[--shell-escape] \documentclass[12pt]{article} ...


1

There's no way xesearch can work with babel-french. Both want to put - in a particular character class for exploiting the \XeTeXinterchartoks feature. However, you can directly input the en-dash and em-dash and the result is as expected, at least in your example. But malfunctions of xesearch might arise, because the character class of - will be 0 with ...


1

It is better to ask template question by using the ask a question button, where you can be sure that someone familiar with the templates handles your question. The language definition file for hungarian does not define a hungarian string for abstract. You gotta define one yourself. \def\magyarOptions{defaults=safest} ...


1

Apparently the issue has nothing to do with magyar. Neither \checktoopen nor \tttypeout{} seem to be defined in any of the packages included or in the article class. Environment (re)definitions take the form \renewenvironment{name}{before}{after}, where the after part specifies the code to be included whenever \end{name} is called. Your definition is ...


3

It seems that \makeatletter \def\@@magyar@setup@psheadings{} \makeatother after loading babel solves the problem. \documentclass{article} \usepackage[utf8]{inputenc} \usepackage[T1]{fontenc} \usepackage[markcase=noupper,automark]{scrlayer-scrpage} \usepackage[magyar]{babel} \makeatletter \def\@@magyar@setup@psheadings{} \makeatother \begin{document} ...


0

Since you can use the highlight command in *.bib source file. However I was able to highlight specific parts of the citation by adding \hl{} command to every single line of the citation information: @article{StephenPark, title={\hl{Integration of biological kinetics and computational fluid dynamics to model the growth of Nannochloropsis salina in an open ...


3

Rather use \enquote{Kostendeckungsprinzip} from the csquotes package than those ('old-fashioned') \glq and \grq commands. The main cause of the problem is that \glq etc. can't be used in math mode. \documentclass[graybox,envcountchap,sectrefs]{svmono} \usepackage[ngerman]{babel} \usepackage[style=german,babel]{csquotes} \makeindex % used ...


2

I don't think that it could ever have worked. The package adds the definitions to the language "frenchb" instead of "french". (There are also a number of spurious spaces in some of the language definitions). You should make a bug report, in the meantime you can add the definitions yourself: \documentclass[a4paper]{article} \usepackage[utf8]{inputenc} ...


0

Dealing with this problem myself, I decided to simply disable shorthands globally. My texts are generally UTF-8 encoded so that Umlauts et al are printed just fine. \usepackage[utf8]{inputenc} \usepackage[T1]{fontenc} \usepackage[shorthands=off, % Don't translate quotation marks followed by vocals to umlauts ngerman % Neue deutsche ...


4

You can take advantage of array to create a new column type, first you need to define a Box which save the contents of the cell \newsavebox{\RTLbox} \newcolumntype{R}{>{\begin{lrbox}{\RTLbox}}c<{\end{lrbox}\AR{\unhbox\RTLbox}}} Code \documentclass[a4paper,12pt]{article} \usepackage[ utf8 ]{inputenc} \usepackage[LAE]{fontenc} ...


5

Here's a minimal example reproducing the problem. \documentclass{article} \usepackage[T1]{fontenc} \begin{document} Umeå \textsc{Umeå} \end{document} The file was saved as UTF-8 and the output is Change it to \documentclass{article} \usepackage[T1]{fontenc} \usepackage[utf8]{inputenc} \begin{document} Umeå \textsc{Umeå} \end{document} and you'll get ...


1

How about: \r{a} I don't think any package needed. See: https://en.wikibooks.org/wiki/LaTeX/Special_Characters#Escaped_codes


3

I follow the instructions by Zarko and put the \tikzset instruction in the preamble: \documentclass[justified]{tufte-handout} \usepackage[utf8]{inputenc} \usepackage[T1]{fontenc} \usepackage[main=spanish,english]{babel} \usepackage{tikz} \usetikzlibrary{babel} % here \tikzset{>=latex} \begin{document} \begin{figure} \centering \begin{tikzpicture} ...


0

To solve this issue for Spanish: Package babel Warning: No hyphenation patterns were loaded for (babel) the language "Spanish" install the texlive-hyphen-spanish package: sudo dnf install texlive-hyphen-spanish.noarch


0

The solution for the error prompted for \usepackage[spanish]{babel} : ! Package babel Error: Unknown option `spanish'. Either you misspelled it Install the texlive-babel-spanish package via yum/dnf: sudo dnf install texlive-babel-spanish


2

If I write the document properly, the caption has “Tabla”. \documentclass[a4paper, 10pt]{IEEEconf} \usepackage[T1]{fontenc} \usepackage[utf8]{inputenc} \usepackage[spanish, es-tabla]{babel} \begin{document} \begin{table}[htbp] \centering \begin{tabular}{|l|l|l|} x & y & z \end{tabular} \caption{Se representa el voltaje y el inverso de su raíz ...


1

I'm not sure you really want to rename \varprojlim to \lim. Anyway, you should do \addto\extrasspanish{\renewcommand{\lim}{\varprojlim}} Full example: \documentclass[a4paper]{article} \usepackage[T1]{fontenc} \usepackage[utf8]{inputenc} \usepackage[spanish]{babel} \usepackage{amsmath} \addto\extrasspanish{\renewcommand{\lim}{\varprojlim}} ...


2

As moewe kindly pointed out, the installations of my packages (and just MiKTeX in general) was older than the observable universe. As such, I have just completely reinstalled MiKTeX -- which I am sure is overkill, but I digress -- and now my package versions are 3.9n for babel (2016/01/08) and v3.3 for biblatex (2016/03/03). That has (almost unsurprisingly) ...


3

You are calling your command to early: babel sets the main language at begin document and so overwrites your \selectlanguage. If you move your commands behind \begin{document} or use \AtBeginDocument it works fine: \documentclass[]{article} \usepackage[UKenglish,german,french]{babel} \usepackage[autostyle]{csquotes} % define the commands to switch and the ...


2

Since egreg already stated (he was just quicker than me) that babel-french does redefinitions to the lists provided by LaTeX it's necessary to do the own redefinitions after babel came into action, i.e. add it either in the document body or use the \AtBeginDocument{...} hook, which is processed consecutively, i.e. the babel redefinitions are done already, ...


2

babel gets in the way because the French module redefines lists after your redefinition. In my opinion it's better to use a different method based on enumitem: \documentclass{article} \usepackage[T1]{fontenc} \usepackage[frenchb]{babel} \usepackage{enumitem} \newlist{contenum}{enumerate}{1} \setlist[contenum]{label=\arabic*.,resume} \begin{document} ...


5

Apologies for reviving this thread, but I didn't see this answer in here. I believe al-ter-nate and al-tern-ate to be two different words. al-ter-nate: a verb meaning to take turns performing two different activities, e.g. I alternate between running and walking. al-tern-ate: an adjective meaning every other, e.g. I go running on alternate Sundays. They ...


3

Expanding on Ulrike's idea, here's a reimplementation of \babelhyphenation that accepts a *-variant which, instead of a list of words, inputs a file. \begin{filecontents*}{english.yp} hom-ony-mous gene-ral-ly \end{filecontents*} \documentclass{article} \usepackage[british]{babel} \usepackage{catchfile,letltxmacro} \makeatletter ...


4

I wouldn't try to use \input inside such command arguments. Better first read the file and then use it. Eg. \documentclass{article} \usepackage[british]{babel} \usepackage{filecontents,xparse} \ExplSyntaxOn \NewDocumentCommand{\hyphenationfromfile}{m} { \tl_set_from_file:Nnn \l_tmpa_tl { } { #1 } \exp_args:NV \hyphenation \l_tmpa_tl } ...


4

You can protect the definition from premature expansion: \documentclass{article} \usepackage[british]{babel} \usepackage{filecontents} \begin{filecontents*}{english.yp} hom-ony-mous gene-ral-ly \end{filecontents*} \showhyphens{homonymous} \makeatletter {\everyeof{\noexpand}\xdef\tmp{\@@input english.yp }} \babelhyphenation[british]{\tmp} ...


4

According to the documentation: Starting with version 2.2a, frenchb alters the layout of lists, footnotes, and the indentation of first paragraphs of sections) only if French is the “main language” [...] otherwise frenchb doesn’t change anything regarding lists, footnotes, and indentation of paragraphs. And it also says that if French is the ...



Top 50 recent answers are included