New answers tagged

0

To make things only appear not immediately on a frame you can use \onslide<2-> What you want to appear\onslide<1->. Everything you write in between the two \onslide commands will only be visible on the second part of the frame. So in your example you want something like that: \begin{frame} \begin{tikzpicture} %Draw your graph(always ...


1

You probably mean the frame title. The command \setbeamerfont{frametitle}{shape=\scshape} sets the shape of the frame titles to SmallCaps. So you probably just want to remove this line.


5

The following example patches the \frametitle command to update the length \titlelen that gives the length of the title under the current theme's font: \documentclass{beamer} \let\Tiny\tiny% http://tex.stackexchange.com/a/94159/5764 \usepackage{etoolbox} \makeatletter \newlength{\titlelen} \tracingpatches \patchcmd{\beamer@@frametitle}% <cmd> ...


5

First, why not just use \insertframetitle? Second, I don't think \beamer@frametitle is defined outside of a frame. That's why you probably get the error message. Third, you should also consider the font (shape, size, ...) in your calculations. Have a look at this example. \documentclass{beamer} \newlength\myframetitlelength \begin{document} ...


0

I think the immediate cause of this error message were the empty brackets in \includegraphics{}, as this will look for an image with an empty file name which will most likely not be found. But to avoid further errors, much of the superfluous code should be removed. beamer itself provides many packages, so there is no need use graphicx, hyperref, color or ...


2

Until a proper answer comes along, you might consider using this quick and dirty trick: \hyperlink{some label}{\textcolor{normal text.fg}{link text}} If you use it very often, then create a command for it: \newcommand\myhlink[2]{\hyperlink{#1}{\textcolor{normal text.fg}{#2}} MWE \documentclass{beamer} \hypersetup{colorlinks=true} ...


1

Here is an alternative solution using minipages. \documentclass[demo]{beamer} \usepackage{biblatex} \begin{document} \begin{frame}{Workload Categorization} \begin{minipage}[t]{0.5\linewidth} Benchmark suites: \begin{itemize} \item 22 SPECcpu2006 \item 11 SPLASH2x \item 9 PARSEC 3.0 \item 6 NAS \end{itemize} \end{minipage}% ...


1

This is a bit hacked, but does work. We use two columns with a List in each one, so that the items are next to each other. Then we remove the bullets and indentation from the second list. Perhaps you want to fiddle with the width to get the distance between the two lists to your liking: \documentclass[demo]{beamer} \usepackage{enumitem} ...


0

You probably want something like that using columns: \documentclass[demo]{beamer} \begin{document} \begin{frame} \frametitle{explanation} \begin{columns} \begin{column}{0.5\textwidth} Benchmark suites:\hspace{4cm}64bit architectures: \begin{itemize} \item 22 SPECcpu2006\hspace{3.5cm} Intel SandyBridge \item 11 ...


2

You can do calculations of page positions: \documentclass{beamer} \usepackage{tikz} \usetheme{default} \usepackage{zref-savepos} \begin{document} \begin{frame} \tikz[overlay,remember picture]\draw[red] (current page.north)--(current page.south); \centering \hspace*{\dimexpr\zposx{end}sp-\zposx{midright}sp-\zposx{midleft}sp+\zposx{start}sp}% ...


1

This solution uses \settowidth. I added a \rule at the center for comparison. \documentclass{beamer} \usetheme{default} \newlength{\tempdima} \newlength{\tempdimb} \begin{document} \begin{frame} \begin{center} \settowidth{\tempdima}{\fbox{one}}% \settowidth{\tempdimb}{\fbox{three four five}}% \rule{1pt}{\baselineskip}\\ \hspace{\dimexpr ...


1

Try putting stuff in columns. (Beamer manual -- 12.7 Splitting a Frame into Multiple Columns). This way you can later add content to the left side later if you wish so. Example from the manual \begin{columns}[t] \begin{column}{5cm} Two\\lines. \end{column} \begin{column}{5cm} One line (but aligned). \end{column} \end{columns} The below example does not ...


1

By replacing \insertsubtitle with \visible<2>{\insertsubtitle} in the default definition of the titlepage, the subtitle gets only visible on the second slide, but its space is already reserved on the first slide. For more information, I recommend the the section about overlays in the beameruserguide. \documentclass{beamer} \usetheme{default} ...


0

If you do not like how the frametitle is defined in the shadow outer theme, you can tweak it according to your needs. See the example below, there are two places where you can increase the spacing above and below the font. \documentclass[t]{beamer} \useoutertheme{shadow} \mode<presentation> { \usetheme{Madrid} } ...


3

I am not sure, if I guessed all your packages right, I still get a font warning. However, you scaled most of your elements to the font size by chosing the unit em. Therefore to reduce size, you have to change the font size, which I did by saying \tiny in line 9: \documentclass[]{beamer} \usepackage{tikz} \usetikzlibrary{matrix, positioning, arrows} ...


1

The columns has an option for that, \begin{columns}[onlytextwidth,T] \documentclass{beamer} \usetheme{default} \usecolortheme{default} \usefonttheme{professionalfonts} \let\familydefault\rmdefault \setbeamertemplate{navigation symbols}{} \setbeamertemplate{caption}[numbered] \setbeamertemplate{frametitle}[default][center] \usepackage{tikz} ...


1

Use minipage instead of columns and column environment. use hspace{0.5cm} in between two minipage. After minipage environment command use vspace{-0.1cm} in first minipage and use vspace{0.5cm} in the second minipage and compile your code you will be getting the following.


0

The \def\pgfsysdriver{pgfsys-dvipdfm.def} trick kinda worked for me, but it totally messed up the position of my images in my presentation. So I decided to dig a little further and here is what I've found : This is indeed a bug, and depending on the beamer theme you are using, the package pgfpages will override the behavior of the theme which is using : ...


1

Here, I use a \raisebox wrapped inside a macro named \Includegraphics (capital "I"). The key is knowing the proper downward vertical shift of the image, which is otherwise aligned to the baseline. That shift, in this case, is -.5\dimexpr\height-\ht\strutbox+\dp\strutbox, which will work regardless of image height and font size. \documentclass{beamer} ...


0

A simple, but not so nice version would be \begin{document} \newcount\anzahlSeiten \anzahlSeiten=10 %if it throws an error, decrease the number and include the last one manually. Number must be even, because it includes always a pair \newcount\ipp \ipp=0 \loop %\begin{frame} %with frames it doesn't loop somehow \global\advance\ipp by1 ...


0

I packaged the text next to the pictures into parboxes. In general, I recommend not to use fixed space. \begin{column}{.32\textwidth} \hspace*{2mm} \includegraphics[height=0.2\textheight]{test1} \parbox[c][0.2\textheight][t]{\linewidth}{ \hspace*{2mm} John}\\ \hspace*{2mm} \includegraphics[height=0.2\textheight]{test1} ...


2

Could be the Singapore theme \documentclass{beamer} \usetheme{Singapore} \begin{document} \section{Test} \begin{frame} abc \end{frame} \section{Test2} \begin{frame} abc \end{frame} \end{document}


1

\setbeamertemplate{frametitle}[default] is defined in beamerouterthemedefault.sty. If you take the definition from there, you can redefine it according to your needs. For example add a shift with \hspace*{1cm}: \documentclass{beamer} \makeatletter \setbeamertemplate{frametitle}{ \ifbeamercolorempty[bg]{frametitle}{}{\nointerlineskip}% ...


0

Changing a theme for presentation in LyX is easy. Just go to Document > Settings Select LaTeX preamble and write \usetheme{ThemeName}, where ThemeName can be changed to the name of the theme like Warsaw etc. Check out this video. It will show you how to change the Theme in LyX: Changing Theme for Presentation in LyX


0

A slide or Frame in LyX consists of a Frame heading followed by contents and then a separator. So first select the Frame tag from the drop down list and give it a title Then fill in the Contents of the Frame and in the end select a separator from the drop down list at the top right corner. You can repeat this process to create as many slides/Frames as you ...


0

\invisible is your new friend \documentclass{beamer} \setbeamercovered{transparent} \begin{document} \begin{frame}{Programming Basics} \texttt{Comments are followed by \underline{\hspace{2cm}}} \begin{enumerate} \item<1> ! \item<1> @ \item<1> :: \item<1-2> ; \invisible<1>{\item ...


0

I think the problem might be, that latex has problems to hyphenate the title of the article. An easy workaround is to let latex do the work and use bibtex or biblatex. \documentclass{beamer} \setbeamertemplate{navigation symbols}{} % only for this example, otherwise in .bib file \usepackage{filecontents} \begin{filecontents}{\jobname.bib} ...


2

If you use the overlay as an argument of the block, the vertical alignment of the blocks will not be the same. your example: \documentclass{beamer} \usetheme{Warsaw} \begin{document} \begin{frame} \begin{block}<1>{Example of Cloze style question} \underline{\ \ \ \ \ \ \ \ } is the man, who invented dynamite. \\ \end{block} ...


1

The code bellow works fine for me. Note the beamer method. \documentclass[12pt]{beamer} \geometry{verbose,letterpaper} \usepackage{multimedia} \usepackage{hyperref} \begin{document} \begin{frame}{Movie test} Whispering-gallery mode in a quarter circle: \movie[height=6cm, width=6cm, showcontrols, poster] {}{Circle-m-increase3.mp4} \end{frame} ...


1

I figure out a trick: to use \onslide* feature of powerdot. To simulate the feature, put the following in the preamble \newcount\slidenum \slidenum=2 \newcommand{\framebreak}[1]{\onslide*{\slidenum}{#1} \advance\slidenum by 1} Then to write a long slide \begin{slide}[]{A fairly long slide} \onslide*{1}{ First slide } \framebreak{ Second slide } ...


0

Overlays are the easiest way to replace an image. But you will have to find the right luminosity values yourself, when producing the gray scale version of your image. \documentclass{beamer} \usetheme{Warsaw} \setbeamercovered{transparent} \setbeamertemplate{navigation symbols}{} \usepackage{beamerthemeshadow} \usepackage{tikz} \begin{document} ...


3

Putting vertical space before the frame title does not solve the problem for the frames without a title. You could instead try increasing the \headsep: \addtolength{\headsep}{0.6cm}


3

Full credit to Gonzolo's Code. This is just a cleaner (in my opinion) way of obtaining the same effect. MWE: \documentclass[10pt,english,compress]{beamer} \usepackage{tikz} \usetikzlibrary{shapes,calc} %My predefined color \definecolor{myblue}{rgb}{0.1,0.15,0.7} %Set color for Annotations \colorlet{annotcol}{myblue!80!black} %Store coordinates of ...


2

You can use \defverbatim{\foo}{\begin{verbatim}...\end{verbatim}} \documentclass{beamer} \begin{document} \begin{frame}[fragile] \defverbatim{\testslide}{\begin{verbatim}test slide 1 $E=mc^2$\end{verbatim}} \only<1>{% \testslide } \only<2>{ test slide 2 } \end{frame} \end{document}


2

The file basename (file name AP_inc_????.pdf without frame number and extension) has to be specified without quotes: \animategraphics[controls,buttonsize=0.3cm,width=7.5cm]{5}{AP_inc_}{1997}{2013}


2

Just use <x|handout:0> in the spec: \documentclass[handout]{beamer} \begin{document} \begin{frame} \includegraphics<1|handout:0>{stage1.png} \includegraphics<2|handout:0>{stage12.png} \includegraphics<3>{stage123.png} \end{frame} \end{document} See section 9.6.3 of beameruserguide.pdf, "Action Specifications".


0

You can change Beamer's fonts with the \setbeamerfont macro. The available options are described in Section 18.3.3 of the Beamer User's Guide. For your particular case: \setbeamerfont{section title}{size=\Large,series=\bfseries}


0

I think the best thing is to get rid of the sty file and put the important commands in the tex file. \documentclass{beamer} \setbeamertemplate{navigation symbols}{} % don't use navigation tools \usepackage[absolute,overlay]{textpos} %needed for textblock \usepackage{hyperref} \begin{document} { \setbeamercolor{background canvas}{bg=black} ...


0

The section in head/foot shaded inherits its appearance from section in head/foot, but when redefining it, one could sneak in extra command, like the \tiny in the following example. \documentclass{beamer} \usetheme{Rochester} \usefonttheme[onlysmall]{structurebold} \beamertemplatenavigationsymbolsempty \setbeamertemplate{headline}{ ...


0

In the github site of pdfpc (https://github.com/pdfpc/pdfpc) someone claims that compiling pdfpc with cygwin on a windows machine is possible. Look at the issue 106. In case the link does not work anymore I'll just copy and paste what he did. Ps I do not have a Windows machine, so maybe somebody else could confirm this? Copy and Paste below. I just ...


1

It is definitely possible to use only one itemize environment in this case. You could simply replace Foo and Bar using the \alt command. In my opinion the resulting code is also easier to read. Here is an example: \documentclass{beamer} \setbeamertemplate{navigation symbols}{} \begin{document} \frame{ \begin{itemize} \item\alt<1>{Foo}{I replace Foo} ...


7

There is no problem, generally, when \href{http://www.example.com/A%20B%20C.pdf}{some text} appears by itself, that is, not in the argument to a macro, because \href suspends the usual TeX's reading rules when absorbing the URL. However, something like \mbox{\href{http://www.example.com/A%20B%20C.pdf}{some text}} would give troubles (\mbox is used to ...


1

It turns out that this works: \documentclass{beamer} \let\Tiny\tiny \setbeamertemplate{navigation symbols}{} \begin{document} \frame{ \begin{overprint} \onslide<1> \begin{itemize} \item Foo \item Bar \end{itemize} \onslide<2> \begin{itemize} \item I replace Foo \item I replace Bar \item I am new! \end{itemize} \end{overprint} } \end{document} ...


4

It's possible to do this by modifying the underlying Pygments style macros. This will work with recent versions of minted, but since it is modifying the internals, it may not always work in the future. You would need to replace the default in \PYGdefault with a different style name if you want to use a different highlighting style. Also, if you want to use a ...


3

You can also use \texorpdfstring from hyperref as the problem is (generally speaking) based on the use of formatting commands while harvesting the meta data. That way you prevent that \alert gets ever in touch with pdf-specific procedures. The compiler usually don't likes to see anything but plain text there -- especially with TikZ commands it becomes really ...


3

If \title is defined after \begin{document} but before \maketitle, the problem is solved. \documentclass{beamer} \usepackage[utf8]{inputenc} \usetheme{m}%\usetheme{m}%-->problem \usepackage{tikz} \usetikzlibrary{arrows,shapes} \begin{document} \author{} \title{Hello \protect\alert{World}!} \begin{frame} \titlepage \end{frame} \end{document} ...


0

Per default beamer seems to use the colour part title for the boxes in the section and subsection pages. The following code redefines these pages with two independent colours, which can than be altered during the document to distinguish the individual sections. \documentclass{beamer} \usepackage{beamerthemesplit} \usetheme{PaloAlto} ...


0

Based on the comment by @samcarter and the answer in Trying to understand the renewbibmacro and DeclareFieldFormat construct I got the effect I desired by adding the following lines after \newrobustcmd: \setbeamercolor{bibliography entry author}{fg=black} \setbeamercolor{bibliography entry title}{fg=black} \setbeamercolor{bibliography entry note}{fg=black} ...


1

You can easily add text before or after the tile page elements via \addtobeamertemplate{title page}{before material}{after material} Thus you can put your supervisor's name at towards the bottom of the title page via \addtobeamertemplate{title page}{}{\begin{center}Supervisor\end{center}} \documentclass{beamer} \begin{document} \title{Talk title} ...


1

As a workaround: \documentclass{beamer} \makeatletter \let\orig@@footnotetext\@footnotetext \usepackage{luatexja} \let\@footnotetext\orig@@footnotetext \makeatother \begin{document} \begin{frame} \frametitle{Sample} Test\footnote{Footnote test.}. \end{frame} \end{document} This time footnote does not disappear. It seems that \@footnotetext is ...



Top 50 recent answers are included