Hot answers tagged

14

As far as I could see from bibentry's package documentation, the \bibentry command is just outputting the whole reference as it stands in the bibliography. This is exactly what the \fullcite command of biblatex is doing, too. Compare the following code example that I adapted from your MWE and its output: \begin{filecontents}{ref.bib} @BOOK{abramowitz+...


9

Wrap the \bibentry in NoHypers i.e. \begin{NoHyper}\bibentry{elvis}\end{NoHyper} The hyperlink now points to the correct entry in the references.


6

You have at least two options to achieve this. \citefield and friends We can use \citefield and friends to access any field of any bibliography entry using the \citefield[<prenote>][<postnote>]{<key>}[<format>]{<field>} syntax (so \citefield does indeed work like your normal cite command). One needs to be aware, however, ...


6

There are two errors in your MWE. \bibliography{mybib.bib} should be \bibliography{mybib} otherwise BibTeX looks for the file mybib.bib.bib instead of mybib.bib. \bibliographystyle{apa} should be \bibliographystyle{apalike}. The bibliography style apa.bst is not compatible with bibentry. So, delete your .aux and .bbl file, and retry with the following ...


6

The command \nobibliography* can be used only if you are going to use \bibliography{mybib} later in the document (supposing mybib.bib is your bibliography file). In your case you have to use \nobibliography{mybib} Also remember that it is needed to declare a bibliography style, e.g. \bibliographystyle{plain} Thus, modifying your MWE to \documentclass[...


6

As stated in the answer to the other question bibentry is not suitable for the task at hand (without modifications). If you want to give biblatex a try, it is easy to set it up for what you want to achieve. \documentclass{article} \usepackage[utf8]{inputenc} \usepackage{filecontents} \usepackage{csquotes} \usepackage[natbib,style=authoryear]{biblatex} ...


6

This seems simpler: \begin{filecontents}{\jobname.bib} @Book{elvis, author = "Elvis Presley", title = "Turn Me One More Time", publisher = "Jail House Books", year = 1963, } \end{filecontents} \documentclass{article} \bibliographystyle{plain} \usepackage{bibentry} \makeatletter\let\saved@bibitem\@bibitem\makeatother \usepackage{hyperref} \...


5

I'm not sure to understand correctly your needs, but try the example below: \documentclass{article} \begin{filecontents}{examplebib.bib} @article{art1, author="First Last", title="A fictitious journal article", year=1900, journal="Journal of nothingness", volume=2, pages="1-2" } @book{boo1, author="Respectable Writer", title="A silly book", year=2000, ...


5

You can load natbib (of which bibentry is a subpackage) and change abbrv to abbrvnat: \begin{filecontents*}{\jobname.bib} @book{Goossens1994LaTeX, author = {Michel Goossens and Frank Mittelbach and Alexander Samarin}, title = {The \LaTeX{} Companion, $2^{nd}$ Edition}, publisher = {Addison-Wesley}, year = {1994{.}} } \end{filecontents*} \...


4

tufte-book uses the package bibentry which always deletes the final period. You have two options: Protect the final dot in the note field: @book{testcite, title={The}, author={Book}, year={1998}, publisher={Pub}, edition={second}, note={Part 2{.}} } Make bibentry to always keep the final period by redefining \BR@nodot (the command that strips the ...


4

See comments on switching to biblatex and biber - if you want to keep using bibtex, read on. You're missing a \nobibliography* command - see the documentation and here for details. But even with the \nobibliography* command there is no output of \bibentry - this seems to be a problem with the agsm style since switching to plain style does fix the problem: ...


3

biblatex Use \parencite instead of \citep. % arara: pdflatex % arara: biber % arara: pdflatex % arara: pdflatex \documentclass{article} \pagestyle{empty}% for cropping \begin{filecontents*}{\jobname.bib} @inproceedings{eps267587, booktitle = {WWW2009 Workshop: Linked Data on the Web (LDOW2009)}, month = {April}, title = {...


3

You can use biblatex categories. By manually adding a category like follows you can suppress some entries in the bibliography: \DeclareBibliographyCategory{nobibiograpphy} \addtocategory{nobibiograpphy}{test1} Try this (note I used biber instead of bibtex as the engine): \begin{filecontents}{mytestbib.bib} @book{test2, author = "T. Testing", ...


3

This seems to work: the \BR@c@bibitem macro is patched to change the category code of % before grabbing its argument. \begin{filecontents}{mytestbib.bib} @book{goossens93, author = {Frank Mittelbach and Michel Goossens and Johannes Braams and David Carlisle and Chris Rowley}, title = {The {LaTeX} Companion}, year = {1993}, publisher = {...


3

The subfiles need to have a \nobibliography* command included so that \bibentry works. In addition, you should really put the \bibliographystyle of the main file before any file inclusions. In your case it is not too important, but if you had different styles in the subfiles it would give a problem - each of the aux files for of the included files is read ...


3

You can use tcolorboxand a redefinition of \bibenty. A little example (adjust the settings according to your needs): \documentclass{article} \usepackage[many]{tcolorbox} \usepackage{natbib} \usepackage{bibentry} \definecolor{bibentrybg}{RGB}{249,245,233} \makeatletter \renewcommand\bibentry[1]{ \begin{tcolorbox}[ breakable, enhanced jigsaw, boxsep=...


2

The problem is beamers definition of \newblock which is used between units of the citation. Its definition, in beamerbaselocalstructure.sty, ends with some code that is unnecessary for your inline use. The strange spacing occurs whenever the text before the first new block (the author part) spans more than one line. Therefore you need to make a version of ...


2

You can redefine the \bibentry command so it does not create a hyperref target by adding \makeatletter \renewcommand\bibentry[1]{\nocite{#1}{\frenchspacing \@nameuse{BR@r@#1\@extra@b@citeb}}} \makeatother to your preamble. E.g. your example (with natbib options added from your commet so it does not throw an error); the in text ordinary citation ...


2

If it is ok for you to sort the references in your bib-file, you could do the following. Sort references in bib-file. Use \nocite{*} at the beginning of your document. Generate your bibliography with \bibliographystyle{unsrtnat} and \bibliography{mybib}. Here the full code: \documentclass{article} \usepackage{bibentry} \usepackage[square,comma,numbers]{...


2

The \bibentry provides only the citation, as you noted. However, a \cite produces the label you desire. Placing the two together gets the complete list, as in \cite{goossens93} \bibentry{goossens93} Here is my MWE. \documentclass{article} \usepackage{bibentry} \usepackage{filecontents} \begin{filecontents}{mytestbib.bib} @book{goossens93, author = "...


2

Based on your comments, I solved the problem. \DeclareSourcemap{ \maps[datatype=bibtex]{ \map{ \step[fieldsource=numpages,fieldtarget=pagetotal] } } }


2

Here's a solution to my question. Using the 'endnotes' package, we can define a function % define a new citation function \newcommand{\mycite}[3][]{\let\theendnote\relax\endnotetext{``#2": \citet[#1]{#3}}} % arguments: 1: page (optional); 2: sentence fragment; 3: citation Then it can be used as follows within the text: \mycite[p. 32]{he wished to know ...


2

The command \bibentry is fragile, so it can't be used as is in moving arguments (captions and section titles). You can use \protect\bibentry for the occasional appearance in a caption; if it appears in several of them you can do \usepackage{etoolbox} and then \robustify{\bibentry} after \usepackage{bibentry}. \documentclass{article} \usepackage{...


2

It's almost as easy as changing \nobibliography* into \nobibliography{<file>}: \begin{filecontents*}{\jobname.bib} @article{bla, title={blabla}, author={me} } @book{blabook, title={blablabook}, author={me} } \end{filecontents*} \documentclass{article} \usepackage{natbib} \usepackage{bibentry} \bibliographystyle{plainnat} \begin{document} \...


2

I think that for bibentry to works, the reference must be written in one way or another within the global bibliography, which is not something that is done by default within a bibunit environment since it uses its own .bbl file. It is said in the documentation of bibentry: There is only one .bbl file, and hence one list of references. Since \...


2

You are missing \protect: \begin{filecontents*}{\jobname.bib} @article{uthor, author={A. Uthor}, title={Title}, journal={Journal}, year=2015, pages={1-10}, } \end{filecontents*} \documentclass[10pt,a4paper]{article} \usepackage[utf8]{inputenc} \usepackage{amsmath} \usepackage{amsfonts} \usepackage{amssymb} \usepackage{natbib,bibentry} \usepackage{...


2

First we need to recreate the bst file you created with makebst. The file above is only a stripped version (I removed everything commented with latexpand) of the dbj file created running tex makebst.tex with all the default options except for the ay (for author-year), nmdash and nmd-3: %% Stripped version of driver file produced from merlin.mbs \input ...


2

Not a general solution, because it depends on how the bst writes out the .bbl file. In this particular case, adding \makeatletter \def\bibinfo@X@title#1,{\ignorespaces} \makeatother to the preamble makes \bibentry (and so also \nobibentry) into ignoring the title field. \begin{filecontents*}{\jobname.bib} @BOOK{simo2006computational, title={...


1

I think what you are searching is the powerful biblatex, coming with all the utilities you need. I made some minor edits to the example, to keep it up to date. You need to decide, if it is applicable to your own project. I used article in the example to keep everything on one page. Which documentclass you are using doesn't really matter. \begin{...


1

The bibliography style dinat.bst is not fully compatible with bibentry. If you push through the error it raises --- ! Undefined control sequence. <argument> \dinatlabel {Rice u.\,a. 1999} \textsc {Rice}, S.V.~; \textsc {Na... l.51 \bibentry{rice1999optical} You get some kind of output from bibentry. I leave it to you to ...



Only top voted, non community-wiki answers of a minimum length are eligible