New answers tagged

2

You must add a \phantomsection as anchor. But better is it to use the tools of biblatex: \documentclass{book} \usepackage{blindtext} \usepackage{hyperref} \usepackage{biblatex} \addbibresource{biblatex-examples.bib} \begin{document} \tableofcontents \chapter{Test} \cite{doody}. \blindtext %\cleardoublepage %\phantomsection ...


4

The default is not to print the bookauthor if it coincides with the author (see biblatex.def) \newbibmacro*{bybookauthor}{% \ifnamesequal{author}{bookauthor} {} {\printnames{bookauthor}}} Just add \renewbibmacro*{bybookauthor}{\printnames{bookauthor}} to your preamble and the bookauthor will always be shown.


2

Maïeul's biblatex-bookinarticle package adds support of the two new entry types @bookinarticle and @bookinincollection to biblatex. @bookinarticle is a very good fit for what you have @bookinarticle{yahya:wisnovsky:menn:2012, Author = {{Yaḥyā ibn ʿAdī}}, Title = {Maqāla fī l-buḥūṯ al-ʿilmiyya al-arbaʿa ʿan aṣnāf al-wuǧūd al-ṯalāṯa al-ilāhī ...


2

The term "Vancouver style" or "Vancouver system" seems to be slightly more variable than say, APA style or Chicago style. Often institutions have their own modifications to the general idea of the style. (Much like "Harvard style" often just means an author year style.) According to Wikipedia the home of the "official Vancouver style" is the NLM's Citing ...


1

This can be done with a bit of modification of the cite macro (we assume authoyear-ibid here) \renewbibmacro*{cite}{% \global\boolfalse{cbx:loccit}% \iffieldundef{shorthand} {\ifthenelse{\ifciteibid\AND\NOT\iffirstonpage} {\usebibmacro{cite:ibid}} {\ifthenelse{\ifnameundef{labelname}\OR\iffieldundef{labelyear}} ...


0

A more robust result, courtesy of @moewe is to use: \iffieldequalstr{pubstate}{under review} and not declare any macros. For more justification, see here: Biblatex: iffieldequals appears to return true for false conditions


7

This is an alternative solution to the problem. Biblatex provides the field pubstate to record the publication status of journal articles. Thus I suggest to keep the standard journaltitle (or the bibtex journal field) and to add the pubstate= {under review} information to the entry. Thus the bibtex entry looks like @article{key123, author = {Name AA ...


2

I suggest you use the special type @inreference that is specifically for dictionaries and encyclopaedias. @inreference{BAR60, Author={Foo Bar}, Title={Baz}, Year={1960}, Booktitle={Encyclopaedia of Everything} } Then you can just do \DeclareFieldFormat[inreference]{title}{\printtext{s.v.}\addspace\mkbibquote{#1\isdot}} to automatically add the ...


1

When using the following settings, the DOI should be printed \usepackage[ backend=biber, %citestyle = alphabetic, %bibstyle = ieee-alphabetic, sortlocale=en_US, sorting=nyt, backref=true, hyperref=true, firstinits=true, style=numeric,%style=alphabetic, defernumbers=true, ...


1

OK, I figured it out as soon as i posted the question, but other people may benefit from it (delete it otherwise). In Texstudio, the bibliography wasn't set to UTF-8 (in Adv. Editor tab), probably causing the strange effect to occur. by changing it to UTF-8 and saving the preset, the problem disappeared.


1

The problem is that a I was using Mendeley a reference manager, that was updating the global bib file in the background without me noticing it. Hence, the bib file was changing. The default behavior of latexmk is to remake all the bbl files if there is any change to the any citation related stuff, for example, a change to the underlying bib file, or adding a ...


0

As @Evpoc wrote in the comments, Sharelatex supports biber for quite some time now. However, I several times still received that error message. I found that changing \addbibresource{ref.bib} to \addbibresource{ref}, compiling, changing it back and compiling again resolves the problem. I suspect it is caused by some temporary files of biber that Sharelatex ...


0

Since I wasn't allowed to comment on Carlisle's post: I had the same problem, only with two computers running different OSes, Windows and MacOS. Using the code above in Windows at least: \IfFileExists{D:/Dropbox/library.bib}{ \addbibresource{D:/Dropbox/library.bib}} \IfFileExists{/Users/.../Dropbox/library.bib}{ ...


1

If I understand what you want correctly, you only need \toggletrue{bbx:gostbibliography} The behaviour you seek has already been implemented in biblatex-gost, but is only enabled with \printbibliography[env=gostbibliography] With \toggletrue{bbx:gostbibliography} we can keep the standard bibliography environment. Unfortunately, I don't speak Russian, ...


5

As far as I can see you will have to resort to \DeclareLabelalphaTemplate, but that is not too bad. We can just copy the default from biblatex.def and change \field[strwidth=2,strside=right]{year} to \field{year} \DeclareLabelalphaTemplate{ \labelelement{ \field[final]{shorthand} \field{label} ...


2

I think I found an answer, using an author index. I've tried to include a MWE below, but I might have added a few lines which are unnecessary. \documentclass{article} \usepackage[indexing=true,maxnames=99,style=authoryear,datamodel=\jobname]{biblatex} \usepackage{filecontents} \usepackage{imakeidx} \makeindex[program=makeindex,options=-s ...


1

biber needs to "unpack" itself. In restricted environments the standard location (in the user temp-folder) is perhaps not accessible. In such cases you can set the PAR_GLOBAL_TEMP to some other folder. See https://github.com/plk/biber/issues/70


3

Try the following \makeatletter \renewbibmacro*{begentry}{% \ifkeyword{Key}{\sffamily}{}% \iffieldundef{shorthand} {} {\global\undef\bbx@lasthash \printfield{shorthand}% \addcolon\space}% \ifboolexpr{test {\usebibmacro{bbx:dashcheck}} or test {\ifnameundef{shortauthor}}}% {}% {\printnames{shortauthor}% ...


9

Using the latest biblatex 3.3 and biber 2.4 development versions from Sourceforge. New mapping functionality allows loops and creating new entries and so it is possible to split up name fields into dedicated entrytypes for correct printing: \documentclass{article} \usepackage{filecontents} % Declare the coauthor name field \begin{filecontents}{\jobname.dbx} ...


2

The biblatex documentation has the following to say about the issue field (p. 19): The issue of a journal. This field is intended for journals whose individual issues are identified by a designation such as ‘Spring’ or ‘Summer’ rather than the month or a number. Since the placement of issue is similar to month and number, this field may also be ...


4

Since Biber and biblatex are integrated so closely it is not always entirely clear if the problem you are facing is a Biber problem, or a biblatex problem. There are at least five primary sources of trouble when using Biber Installation issues Usage issues Version mismatches The infamous cache bug (should be irrelevant for Biber versions >= 2.2) Malformed ...


1

As @Johannes_B pointed out, the issue is with the hyphenation. Possible workarounds involve \raggedright (see No hyphens in biblatex) or \sloppy (see Hyphenation in bibliography with Biblatex). With \appto{\bibsetup}{\raggedright}: With \appto{\bibsetup}{\sloppy}:



Top 50 recent answers are included