Hot answers tagged

7

This is an alternative solution to the problem. Biblatex provides the field pubstate to record the publication status of journal articles. Thus I suggest to keep the standard journaltitle (or the bibtex journal field) and to add the pubstate= {under review} information to the entry. Thus the bibtex entry looks like @article{key123, author = {Name AA ...


7

Using some of biblatex's on-board technologies we can make the code a bit shorter. (And I'm really not a fan of constructs such as \citeauthor{#2}, \citetitle{#2}, \citeyear{#2}, they go horribly wrong when several works are cited and they don't deal with pre- and postnotes that well. Granted, that might not be a problem here, but still ...) Note first that ...


6

biber can be used to on the fly modification of the data in the bibtex entries. Thus a possible solution is to use a map that uses regular expression to remove ., namely: \DeclareSourcemap{ \maps[datatype=bibtex]{ \map{ \step[fieldsource=journal, match=\regexp{\.}, replace={ }] } } } With the provided MWE we ...


4

OK. I came up with something which seems to work - that is, it survives absolutely minimal testing, but will no doubt break as soon as I try to use it in a real document. I am sure, however, that this cannot possibly be the simplest solution. There must be a more straightforward way of extracting the URL for use as a hyperlink target, mustn't there? I ...


3

The following MWE reproduces the problem \documentclass{article} \usepackage[backend=bibtex,style=authoryear]{biblatex} \addbibresource{biblatex-examples.bib} \nocite{vangennep} \begin{document} \printbibliography \end{document} one gets ! Undefined control sequence. <argument> ...nameprefix {van}\isdot }\ifprefchar ...


2

This is lecturenote.tex file \documentclass{article} \usepackage[backend=bibtex]{biblatex} \addbibresource{mybib} \begin{document} bla bla \cite{mt} foo bar \cite{xyz} \printbibliography \end{document} This is presentation.tex file \documentclass{beamer} \usetheme{Warsaw} \usepackage[backend=bibtex]{biblatex} \begin{document} \begin{frame} bla bla ...


2

The term "Vancouver style" or "Vancouver system" seems to be slightly more variable than say, APA style or Chicago style. Often institutions have their own modifications to the general idea of the style. (Much like "Harvard style" often just means an author year style.) According to Wikipedia the home of the "official Vancouver style" is the NLM's Citing ...


2

biblatex-apa requires Biber from version 4.5. Page 2 of the manual states: 4.5 biber is now required. This is because APA style needs a custom sorting scheme and only biber supports this. bibtex support is going away in biblatex eventually anyway so it’s best to switch.


2

I suggest you use the special type @inreference that is specifically for dictionaries and encyclopaedias. @inreference{BAR60, Author={Foo Bar}, Title={Baz}, Year={1960}, Booktitle={Encyclopaedia of Everything} } Then you can just do \DeclareFieldFormat[inreference]{title}{\printtext{s.v.}\addspace\mkbibquote{#1\isdot}} to automatically add the ...


2

Short answer: Use \iffieldequalstr{pubstate}{under review} or \newcommand*\ur{under review} \iffieldequals{pubstate}{\ur} or \newcommand*\ur{under review} \iffieldequalcs{pubstate}{ur} Where the first option is the preferred here I think. Accoring to the documentation (p. 182) ...


2

Maïeul's biblatex-bookinarticle package adds support of the two new entry types @bookinarticle and @bookinincollection to biblatex. @bookinarticle is a very good fit for what you have @bookinarticle{yahya:wisnovsky:menn:2012, Author = {{Yaḥyā ibn ʿAdī}}, Title = {Maqāla fī l-buḥūṯ al-ʿilmiyya al-arbaʿa ʿan aṣnāf al-wuǧūd al-ṯalāṯa al-ilāhī ...


2

It must be \usepackage[utf8]{inputenc} And the warning that paper1.bib already exists comes from filecontents, which is no problem. However, your example with the given bibliography worked fine with pdflatex and xelatex, too.


2

The .bib key must not contain spaces, and the opening brace of the year in your .bib file was not followed by a closing brace. With this file @book{Fluid_Mechanics_Seventh_Edition, author = {Frank M. White}, title = {Fluid Mechanics, Seventh Edition}, year = {2011}, publisher = {McGraw-Hill} } and a ...


2

With \setbeamertemplate{bibliography item}[triangle] you are replacing the complete label by a triangle. You need some new template: \documentclass[xcolor=dvipsnames]{beamer} \usepackage[ngerman]{babel} \usepackage[utf8]{inputenc} %\usetheme{Antibes} \usepackage[style=alphabetic,maxalphanames=1,backend=biber]{biblatex} ...


1

Solution based on Ulrike's comment: \begin{table}[h!] \begin{tabular}{ p{2.5cm} p{12cm} } \textsc{My Table} & \\ \hline 1st row & {\fullcite{test}} \\ 2nd row & something else \\ \end{tabular} \end{table}


1

This can be done with a bit of modification of the cite macro (we assume authoyear-ibid here) \renewbibmacro*{cite}{% \global\boolfalse{cbx:loccit}% \iffieldundef{shorthand} {\ifthenelse{\ifciteibid\AND\NOT\iffirstonpage} {\usebibmacro{cite:ibid}} {\ifthenelse{\ifnameundef{labelname}\OR\iffieldundef{labelyear}} ...


1

OK, I figured it out as soon as i posted the question, but other people may benefit from it (delete it otherwise). In Texstudio, the bibliography wasn't set to UTF-8 (in Adv. Editor tab), probably causing the strange effect to occur. by changing it to UTF-8 and saving the preset, the problem disappeared.


1

Your MWE is of no use since we do not have the contents of your *.bib file. My guess would be that you need to switch your bibliography parser to 'biber'. Does your MWE work with the following adjustments? \usepackage[bibstyle=authoryear,citestyle=authoryearbrak,backend=bibtex]{biblatex} If yes, you should change the bibliography tool of your editor to ...


1

When using the following settings, the DOI should be printed \usepackage[ backend=biber, %citestyle = alphabetic, %bibstyle = ieee-alphabetic, sortlocale=en_US, sorting=nyt, backref=true, hyperref=true, firstinits=true, style=numeric,%style=alphabetic, defernumbers=true, ...


1

Reusing my answer from LaTeX-community.org: You just need to define what the short author and short title are supposed to be, biblatex prints them by default. %\RequirePackage{filecontents} \begin{filecontents*}{demo.bib} @book{is4562000, title={Indian Standard Plain and reinforced concrete--code of practice (IS ...


1

You could disable - being recognised as a range separator (you will want to treat it as a NumChar then) with \DeclareRangeChars{~,;+/} \DeclareNumChars*{-} This however creates more problems than it solves, I believe, since now \cite[12-34]{sigfridsson} is not recognised as a range any more; you would have to write \cite[12\bibrangedash 34]{sigfridsson} ...



Only top voted, non community-wiki answers of a minimum length are eligible