Tag Info

New answers tagged

1

\setlength\bibhang{2.4em}%% two dashes and space \renewcommand*\bibnamedash{\textemdash\textemdash\space}


2

Here's a version which uses a rule set to a fraction of the length of \bibhang \documentclass{article} \begin{filecontents}{\jobname.bib} @book{Chomsky1986, Address = {Cambridge Mass.}, Author = {Noam Chomsky}, Publisher = {{MIT} Press}, Title = {Barriers}, Year = {1986}} @book{Chomsky1981, Address = {Dordrecht}, Author = {Noam ...


2

The relevant macro for short subsequent citations in verbose-trad2 is cite:title. We just modify it to include the volume if maintitle and title coincide. \renewbibmacro*{cite:title}{% \printtext[bibhyperlink]{% \printfield[citetitle]{labeltitle}% \iffieldsequal{maintitle}{title} {\setunit{\addcomma\space}% \printfield{volume}} ...


2

The definitions for the abbreviations of the months are in language.lbx files, in your case in the english.lbx file. To modify the behaviour, you can use the local customisation command (see Section 3.8 of the biblatex manual, textbook biblatex) \DefineBibliographyString{english}{ march = {Mar}, april = {Apr} }


2

Since your strings are not the standard strings we need to change the standard via \NewBibliographyString{onlinesource} \DefineBibliographyStrings{english}{% urlseen = {accessed on}, urlfrom = {available at}, onlinesource = {online}, } where we also add the new "Online" string. Then what you want can be done via some reformatting of the url and ...


4

I can't find any tool which can split a ODT file to standalone pages, so I think easiest way is to make a script which will create a TeX file for each card and call oolatex on these files. We can create one big .bbl file which include all records from a bib file and use this file for each file. The Lua script makecards.lua: local bibfile = arg[1] local ...


2

One (at least I find) elegant and quite usable way would be a new command, say \sidecite. It will use the same syntax as all the \cite command, but features an optional offset argument enclosed in <> at the beginning. We will use xparse to implement it. First we copy the definition of \footcite from the relevant .cbx style file (in your case ...


1

biblatex's standard styles have no trouble (and no scruple) at all to display a url and urldate for @books or any other entry type. This feature can be turned off via url=off, in which case only @online entries retain their URLs (see §3.1.2.2 Style-specific [Preamble Options], p. 55 of the biblatex documentation). Most custom styles available from CTAN ...


6

It looks like it was a bug in luatex. This seems to have been fixed in the latest version of luatex, version 0.80.0, as provided in texlive 2015-pretest. Using these versions, the output is as expected:


3

Starting from version 2.9 of biblatex (with this commit) data model macros (like \DeclareDatamodelEntrytypes, DeclareDatamodelFields, \DeclareDatamodelEntryfields, ... a full list can be found in §4.5.3 Data Model Specification, pp. 156-161 of the biblatex documentation) are disabled in the preamble and yield only a warning along the lines of Data model ...


2

You state that this entry has no author. However, functionally speaking, "Charleston Mercury" is the author of the piece. Since it's a "corporate author", the field should be author = {{Charleston Mercury}}, (note the double curly braces) to assure that the entry will not be (mis)interpreted as having been written by a person whose first name was ...


0

Ok I've found a pretty rough and ready solution for this Thanks to everyone for the assistance I've basically switched around the title and author fields of the .bib file and added formatting changes where necessary, here is the .bib @incollection{mercury, title = {Charleston Mercury}, author = {{\enquote{Prospects of Slavery Expansion}\nopunct }}, ...


3

\documentclass[a4paper,12pt]{article} \usepackage[T1]{fontenc} \usepackage[utf8]{inputenc} \usepackage[sorting=none,backend=biber,defernumbers]{biblatex} \addbibresource{biblatex-examples.bib} \begin{document} \cite{aristotle:physics,aristotle:poetics,nussbaum,pines,vangennep,wassenberg} \makeatletter \begingroup \def\blx@prefixnumbers{A} ...


0

I found it out now after several tests. I have the following file for all bibliography stuff: \renewcommand{\bibname} {C Literaturverzeichnis} \bibliographystyle{alphadin} \bibliography{bibtex/entries} \addcontentsline{toc}{section}{\bibname} And I had the same issue like you. Everything is working and the bibliography and literature is correctly ...


3

This code should do what you want (with a suggestion of @Moewe): \documentclass{article} \usepackage[american]{babel} \usepackage{csquotes} \usepackage[backend=biber,style=authoryear,maxcitenames=2,maxbibnames=50,firstinits=true,uniquelist=false,uniquename=init,isbn=false,doi=false,useprefix=true]{biblatex} \DeclareNameAlias{sortname}{last-first} ...


3

I wholeheartedly agree with jon that a bibliography file is something a lot of thoughts and manual labour should go into to make sure the information is as accurate as possible; there are so many subtleties and corner cases that a script or other automation cannot catch. I also agree fully with his advice Invest the time (even if not for this task) to ...


1

After some time of debug, I finally found what was wrong or actually the package responsible for that malfunction. I was using BibLaTeX, and as the following minimal working examples prove it, we have to declare the line \PassOptionsToPackage{hyphens}{url} before BibLaTeX is declared. Working example, links packages are declared before : ...


4

Each not too bad PDF viewer should have a "back" feature for jumping to the previous location. Thus there is no need to have such a go back link. Nevertheless there are some options: backref Package biblatex provides a backref feature, which prints a list of pages, where the bibliography entry is cited. Of course the user would have to remember the page. ...


2

Fortunately, biblatex already provides all the facilities to deal with this effectively (it still takes quite some code, though). The authortitle bibliography style has an option to replace repeated authors in the list by a dash, we copy all the macros needed to do that and slightly modify one macro (namely bbx:dashcheck) \renewcommand{\bibnamedash}{} ...


1

Seemingly, using bibtex as a backend causes this problem. If you use exactly your code with biber as a backend, it works as you want. \usepackage[ style=authoryear-icomp, mincitenames=1, maxbibnames=99, maxcitenames=3, dashed=false, url=false, ibidtracker=false, sorting=nyt, natbib=true, sortcites=false, firstinits=false, uniquelist=false, backend=biber ...


2

You are looking for a multi-cite version of \citep. That does not really exist, but since biblatex's natbib commands are just wrappers around their standard counterparts, \citep is really \parencite (exceptions apply for the starred versions: \citep* is not \parencite*, it is \AtNextCite{\defcounter{maxnames}{999}\parencite). The multi-cite version for ...


0

As you observe, chem-acs doesn't (currently) have \footcite set up to provide what you want. You are on the right track thinking you can mix bibliography and citation styles, but you'll need to set maxnames manually \documentclass{article} \begin{filecontents}{\jobname.bib} @article{Buchwald , title = {A new palladium precatalyst allows for the fast ...


2

You want the option dashed=false and the style authoryear-comp. Your MWE then becomes \documentclass[11pt,a4paper,headsepline]{scrartcl} \usepackage[utf8]{inputenx} \usepackage[T1]{fontenc} \usepackage[ngerman,english]{babel} \usepackage{kpfonts} \usepackage{libertine} \usepackage{filecontents} \usepackage{siunitx} \usepackage[natbib=true, ...


2

Handling of laws, regulations etc. that are supposed to be cited in a very particular way isn't all that easy. If you have several of such documents you might want to consider creating dedicated entrytypes for easy customisation (see How can I create entirely new data types with BibLaTeX/Biber? on how to do that, and How to implement a jurisdiction biblatex ...


2

Before we commence, I would like to quote what the biblatex documentation says about the edition field edition field (integer or literal) The edition of a printed publication. This must be an integer, not an ordinal. Don’t say edition={First} or edition={1st} but edition={1}. The bibliography style converts this to a language dependent ordinal. It ...


2

Use \supercite{mykeyword} or \autocite{mykeyword} (thanks, Joseph Wright!) instead of \cite{mykeyword}. Example: \documentclass{article} \usepackage[utf8]{inputenc} \usepackage[T1]{fontenc} \usepackage{garamondx} \usepackage[english]{babel} \usepackage[backend=bibtex,style=phys]{biblatex} \addbibresource{bib.bib} \usepackage{filecontents} ...


1

Actually you are simply lucky that the \setbeamercolor does anything useful. beamer hooks in the \newblock command and this will in most cases not work with biblatex but only with manual bibliographies. Use the biblatex tools like e.g. \DeclareFieldFormat{title}{{\scshape\tiny #1}}


0

It is probably best to redefine labelname as follows \DeclareNameFormat{labelname}{% \ifnum\value{uniquename}=2% \usebibmacro{name:last-first}{#1}{#3}{#5}{#7}% \else \ifuseprefix {\usebibmacro{name:last-first}{#1}{#4}{#5}{#8}} {\usebibmacro{name:last-first}{#1}{#4}{#6}{#8}}% \fi \usebibmacro{name:andothers}} This will always ...


0

The easiest way is to input the text as you want to see it into the edition field, for example edition = {edisi ketiga} This, of course, is not that automatic, as we would like it to be. For some languages (where the word for edition does not vary with the number of the edition) \DeclareFieldFormat{edition}{% \ifinteger{#1} ...


1

Since biblatex-apa aims to comply exactly with the slightly complicated APA guidelines, the "standard" options maxnames and friends do not work (as expected, if at all) with biblatex-apa. To include an arbitrary number of authors (and editors) in the bibliography is possible though with the option apamaxprtauth, which defaults to 7, see §3.1 Package ...


2

Since captions (and floats in general) are rarely considered part of the text flow (after all a float is quite volatile in its placement and it is even more difficult to predict when exactly a reader might look at a float), the trackers are disabled within those environments. The biblatex documentation states in §4.11.5 Trackers in Floats and TOC/LOT/LOF, ...


2

I found two solutions to the question With the development version of biblatex (and biber 2.0) There one can "clone" entries: (see also https://github.com/plk/biblatex/issues/297) \documentclass{article} \usepackage[utf8]{inputenc} \usepackage[T1]{fontenc} \usepackage[style=numeric,defernumbers,sortcites]{biblatex} \DeclareBibliographyCategory{related} ...


2

This is actually surprisingly easy. You will just have to have a way to distinguish those entries with a modified label. There are at least two ways to do that, the two ways are fundamentally different though. Use keywords, you can just add keywords = {modlabel} to the .bib entry and filter the bibliography with keyword=modlabel and notkeyword=modlabel. In ...


2

There is no technical reason not to mix utf8 text and LaTeX in one .bib file. Biblatex, with biber, handles both fine. Ease of input, readability, and portability may count in favour of various approaches. For some fonts, especially fixed width ones, hyphens, en-dashes, and em-dashes are hard to distinguish. Some characters are hard to input, especially ...


1

It is unnecessary to hard code the number of bib entries per page (which could lead to isolated entries on a page if five don't fit). If you are willing to set the bibliography as in moewes example outside of a frame it is quite enough to adjust the page geometry a bit: \documentclass{beamer} \usepackage[T1]{fontenc} \usepackage[utf8]{inputenc} ...


0

I present to you: the sledgehammer method. Fortunately, biblatex allows us to hook into the very end of a bibliography entry with the bibmacro finentry, by default defined as \newbibmacro*{finentry}{\finentry}. We define is \renewbibmacro*{finentry}{\finentry\brf} Where we define \brf as follows \newcounter{bibitmctr} \newcommand{\brf}{% ...


1

Your definitions of lastname and last-init seem somewhat fishy, try the definitions \DeclareNameFormat{lastname}{% \usebibmacro{name:last}{#1}{#3}{#5}{#7}% \usebibmacro{name:andothers}} \DeclareNameFormat{last-init}{% \usebibmacro{name:last-first}{#1}{#4}{#5}{#7}% \usebibmacro{name:andothers}} instead.


0

When I try this as a minimal example I already get an Package keyval error: fieldname undefined: \documentclass{article} \usepackage[backend=biber]{biblatex} \renewcommand*{\multinamedelim}{\addcomma\space} \renewcommand*{\multilistdelim}{\addcomma\space} \renewcommand*{\newunitpunct}{\addcomma\space} \DeclareNameFormat{lastname}{#1\addspace} ...


3

You can enclose code where you don't want the "ibid" mechanism to work in \citetrackerfalse\pagetrackerfalse\backtrackerfalse blah \citetrackertrue\pagetrackertrue\backtrackertrue Depending on whether you find it logical to directly pick up the state from before this block you might or might not add \citereset. See p. 91 and p. 195 of the biblatex ...


7

You simplly have to add the following line in the preamble \DeclareFieldFormat{postnote}{#1} MWE: \documentclass{article} \usepackage[utf8]{inputenc} \usepackage[doi=false,url=false,isbn=false,sorting=none,style=numeric-comp,backref=true]{biblatex} \DeclareFieldFormat{postnote}{#1} \addbibresource{biblatex-examples.bib} \begin{document} ...


0

Just summarising my earlier comments, so we have an answer here. If the first paper were only by "Smith", you would get "Smith et al." for the second paper. It is just a convenient extra that biblatex lets you easily see that both papers were written by "Smith and Sparks" in your example. Indeed, it is possible (if not entirely correct if you're a stickler ...


7

In most cases this errors are due to underscores (e.g. because you added an url in a note or a howpublished field). You can add \errorcontextlines=200. Then the log file should show you the offending url. You can also add temporarly in your preamble \catcode`\_=13 \def_{XXXXXXXXXXXX} This will show you the underscores.


1

This MWE works on my computer running under Ubuntu (it doesn't on the other one with Windows, but I guess that the problem comes from the installation and not the MWE) : \documentclass[12pt,a4paper]{report} \usepackage[utf8]{inputenc} \usepackage[T1]{fontenc} \usepackage{lmodern} \usepackage[backend=biber, style=authoryear, ibidtracker=true, indexing=cite, ...


3

By default, biblatex does not add a "see note" message to shorthand citations, the shorthands are "introduced" at their first occurrence instead. It is, however, not at all hard to add the back-linking, we can just copy the portion of the footcite:note macro that deals with "see note" and append it to footcite:shorthand. The following code in the preamble ...


2

Eliminating footnote links requires setting two options: the hyperref=false option for biblatex, and the hyperfootnotes=false option for hyperref. This example should make clear that the citation at the beginning has no link, but the equation at the end does. \documentclass{article} \usepackage{filecontents} \begin{filecontents}{mwe.bib} @book{salam, ...


2

You can also workaround this problem with biber, specifying biber --output_safechars --output_safecharsset=full <main[.bcf]> I have tested this with version 1.8 and biblatex 2.8a. (There might be some more options in biber 1.9 and the future) Biber encodes the original source for two reasons. First, to keep consistency with the authors, i.e. ...


4

For several reasons, when the utf8 option to inputenc is given, Biber will see it and it will translate accented letters in the .bib file to their Unicode counterparts; for instance, \'e will become é and \=u will become ū. However, the utf8 option doesn't define all characters in Unicode; some of them still need a definition. ...


1

Biblatex now uses Biber as default backend. It used to use BibTeX before. Here are the steps to make bibliography display for your LaTeX document: Install Biber On Ubuntu: sudo apt-get install biber Then compile with the following commands (assuming your LaTeX file name is test1.tex): pdflatex test1 biber test1 pdflatex test1 The above case is when ...


3

If you just wish to reverse the numbering - not the order - then you can use the following approach: \documentclass{moderncv} \usepackage{biblatex,refcount} \makeatletter % http://tex.stackexchange.com/q/66829/5764 \newcounter{numbibentries} \renewbibmacro*{finentry}{\stepcounter{numbibentries}\finentry} % http://tex.stackexchange.com/q/123805/5764 ...


2

Using tcolorbox instead of mdframed or fullwidth finally solved the issue. Using grow to right by = \marginparwidth+\marginparsep on an odd page, and the opposite on an even page, I get (nearly) what I want, without any bugs. I think the length is not exactly right, but it's close enough for now. (Until someone smarter comes along at least) ...



Top 50 recent answers are included