Tag Info

Hot answers tagged

7

In order for a compound name to be considered a single token as far as abbrv.bst is concerned, it's sufficient to hide the hyphen: @phdthesis{phd/MW2014, author = {Klopotsko M{\"u}ller{-}Wachtendonk}, title = {Das Bild h{\"a}ngt schief}, year = {2014} } Note that the entry is missing the school field (not required, but important for ...


6

If one does some digging in chicago-notes.cbx, in the definition for the cite bibmacro one finds \ifboolexpr{ test {\iffieldundef{shorthand}}% or ( togl {blx@skipbiblist}% and togl {cms@inheritshhand}% and not test {\iffieldundef{crossref}}% ) } And indeed that seems to be the boolean expression that causes etoolbox ...


5

Your URL string contains quite a few - (hyphen) characters, and it's quite long. By default, URL strings are not broken at hyphenation characters. To enable line breaking at the hyphens, load the url package with the option hyphens before loading hyperref. \documentclass[12pt,a4paper]{book} \usepackage[utf8]{inputenc} ...


5

You can use arbitrary keywords that are not yet defined. They will be ignored by bibtex. In JabRef, you can add those fields in Options/Set up general fields.


4

You can make a copy of aer.bst and modify it to bypass the comparison of author (and editor) names. The following patch should do the trick. In the patch, the modified bibliography style file is named aer2.bst. I have edited two lines in the function make.list.label. --- aer.bst 2014-01-12 01:23:55.000000000 +0200 +++ aer2.bst 2014-08-20 ...


4

Here are the definitions for (simplified) citation commands to print the (full) name of the first author and the full names of the authors. \DeclareNameFormat{onlyfirst}{% \usebibmacro{name:first-last}{#1}{#3}{#5}{#7}% } \DeclareCiteCommand{\citefirstauthor} {\usebibmacro{prenote}} {\printnames[onlyfirst][1-1]{labelname}} {\multicitedelim} ...


4

After much gnashing of teeth, trying \BiBTeX, \BIBTeX, \BibTeX, \bibTeX, ... in the hope that such a command would be defined somewhere and looking through SO, I looked through the Wikipedia page, found Oren Patashnik's original BibTeX documentation, located the corresponding .tex file and found that a \BibTeX command was defined in its preamble: ...


4

Assuming your copy of the style file ACM-Reference-Format-Journals.bst is more or less the same as the one I was able to obtain from this GitHub site, you can get rid of the bracketd citation labels by loading the natbib package (in the preamble): \usepackage{natbib} To get rid of the handing indentation, use the instruction \setlength\bibhang{0pt} You ...


4

Remove the ALT prefixes from author and editor fields, i.e., change ALTauthor to author and ALTeditor to editor. Do this only for fields whose values are not {•}, of course, or you'll get some bitter complaints from BibTeX... By the way, I think the title of the cetin entry should start with {``Sodium Hydroxide'' Ullmann's... rather than with {"Sodium ...


4

This is not a full aliasing system, because it acts just on \selectlanguage, but it should be sufficient for your purpose. A full system would need deep surgery in babel. \begin{filecontents*}{\jobname.bib} @inproceedings{Renyi1961, author = {R\'{e}nyi, Alfr\'{e}d}, booktitle = {Proceedings of the Fourth Berkeley Symposium on Mathematical Statistics and ...


3

The traditional \cite{<cite>} command tests for the existence of a macro \b@<cite> - yes, a citation is just a macro definition. The test is necessary because, like the \label-\ref system, it uses the .aux file for handling them and could be non-existent depending on your compilation. However, if the macro \b@<cite> exists, it sets it using ...


3

You have to use natbib. \usepackage[authoryear]{natbib} Code: \documentclass[12pt,letterpaper]{report} \usepackage[authoryear]{natbib} \usepackage{filecontents} \begin{filecontents*}{Bibliography.bib} @book{Wel03, author = "Stefan Wellek", year = 2003, title = "Testing Statistical Hypotheses of Equivalence", publisher = "{Chapman \& ...


3

After loading hyperref with the breaklinks option, add the hyphen to the list of allowed break points by doing \g@addto@macro\UrlBreaks{\do\-} You can also relax the spacing of the bibliography by adding \raggedright before it. This aligns the following text in the current group flush left. \documentclass{article} \usepackage[utf8]{inputenc} ...


3

I had the same issue lately, so maybe this help. But as usually, this is depending on your bibliography style 1 - Use double braces author = {{Harvest Choice}} to avoid the reformatting of things via bibtex 2 - I used the url = {} field and a latex url command within it: url = {\url{yadayada}} 3 - You could try other bibliography styles or edit the .bst ...


3

The organization HarvestChoice suggests the following citation of the publication in question: HarvestChoice, 2006. "[Tanzania] National Sample Census of Agriculture 2002/2003: Small Holder Agriculture, Volume II: Crop Sector - National Report." International Food Policy Research Institute, Washington, DC., and University of Minnesota, St. Paul, MN. ...


3

After loading natbib, but still in the preamble, provide the instruction \setcitestyle{authoryear,round} Alternatively, you could load the natbib package with the options authoryear and round: \usepackage[authoryear,round]{natbib}


3

A BibTeX database is a plain text file (.bib file): JabRef provides a convenient and powerful editing front-end but cannot store data in the file without it being in the source. As such, if you add custom fields to the database they will be in the .bib file and so JabRef will show them in the source tab (which is meant for low-level editing). It is of ...


3

You need to format your bibliography file correctly. Writing author = "{xxx yyy and aaa bbb}" will be interpreted as a one single author whose name is simply a surname. You should write author = {xxx yyy and aaa bbb} or better author = {yyy, xxx and bbb, aaa} with each name as Last, First: @TechReport{E:N:T:Z:2003, author = {Elnikety, ...


3

Your problem is \bibliographystyle{plain} (I'm guessing that's what is meant by \bibliography {plain} in the question). The standard BibTeX styles were not designed for use with natbib, which needs extra structured information to be passed. Thus the solution is to switch to plainnat: \RequirePackage{filecontents} \begin{filecontents*}{\jobname.bib} ...


3

As indicated in the name, ieeetr-fr is an adaptation of the IEEE style for use in French. As such, it hard-codes in an assumption that babel is loaded with the french option to define for example \fg. You will either need to load babel appropriately or use a different style (say the standard IEEE one).


3

To long for a comment. I have reduced your MWE to the following code, running without errors and returns the desired result. My system here is MiKTeX 2.9, updated yesterday. Styles plainor alpha do not change the publisher output. Which tex districution do you use? And are youre packages up to date? You can check this by adding a \listfiles before the ...


3

You are refering with a wrong bibtex key. It is \cite{Zhang05} not \cite{Zhnag05} \documentclass[conference]{IEEEtran} \usepackage{filecontents} \begin{filecontents*}{references.bib} @IEEEtranBSTCTL{IEEEexample:BSTcontrol, CTLdash_repeated_names = "no", } @article{Zhang05, author = "Author1 and Author2", title = "{The title}", booktitle = {ACM}, ...


3

you don't need to use XeLaTeX with biblatex, it works with pdflatex too. You sample compiles fine for me with pdflatex, utf8 option of fontenc, biblatex and biber for unicode bibliography support, and fontenc package with T1 and LGR options for font support (although it seems it works even without fontenc): \RequirePackage{filecontents} ...


2

FWIW, Oren Patashnik's original BibTeX documentation defines a \BibTeX command in the preamble of the corresponding .tex file: \def\BibTeX{{\rm B\kern-.05em{\sc i\kern-.025em b}\kern-.08em T\kern-.1667em\lower.7ex\hbox{E}\kern-.125emX}} The larger title version is hand-crafted like this: \title{B\kern-.05em{\large I}\kern-.025em{\large ...


2

BibTeX very deliberately does not enforce any particular field names: fields which are recognised are dependent on the style (.bst) file in use and all others are ignored. Several fields have been used for many years (starting with the 'core' styles) and so are 'standard', for example author, title, year. Some related to electronic publication (which ...


2

This is one reason why it is can be helpful to start with a minimal WORKING example, if you can find one :-) #+LaTeX_HEADER: \usepackage{mathptmx} #+LaTeX_HEADER: \usepackage{pifont} #+LaTeX_HEADER: \usepackage[margin=0.7in]{geometry} #+LaTeX_HEADER: \usepackage[backend=bibtex,sorting=none]{biblatex} #+LaTeX_HEADER: \addbibresource{gg.bib} %% point at your ...


2

To get the appearance of the entries in the references, keep using the plainnat bibliography style but do not load the natbib package. You'll get: \documentclass[a4paper]{article} % to keep output all on one page \usepackage[english]{babel} \usepackage[utf8]{inputenc} \usepackage{amsmath,amssymb,amsthm,graphicx} %\usepackage{natbib} %% deliberately ...


2

The solution I found is to modify the .bst file. Look for apsrev.bst on your system and make a copy of it in the directory containing the document you're working on, naming it apsrev-nourl.bst. Open this file with any text editor and look for format.url; then change FUNCTION {format.url} { url empty$ { "" } { "\urlprefix\url{" url * "}" * } if$ ...


1

To get the desired authoryear citation style with round parentheses, you need to change the instruction \usepackage[square,sort,comma,numbers]{natbib} to \usepackage[round,authoryear]{natbib} Be sure to run LaTeX, BibTeX, and LaTeX twice more to fully propagate all changes. You'll get the following look: \documentclass[12pt,letterpaper]{article} % ...


1

In the following solution I use a new counter for numeric labels. The internal command \@biblabel is redefined to increment and print the counter. It gets called at the beginning of each item. The space after the numeric labels can be adjusted with \biblabelsep. See the manual of apacite for some documentation on the customization facilities. ...



Only top voted, non community-wiki answers of a minimum length are eligible