Tag Info

New answers tagged

4

Try cb2Bib: The cb2Bib is a free, open source, and multiplatform application for rapidly extracting unformatted, or unstandardized bibliographic references from email alerts, journal Web pages, and PDF files. Or for other online bibliography parsers just google: http://www.google.com/search?q=bibliography+parser


1

To answer my own question, using BibDesk kind of removes the need of an aligned bib-file, given that I add all entries in BibDesk and basically edit all my references in BibDesk. Since I am LaTeX-ing on OSX, BibDesk may be the best option in that it removes the need to be in the tex editor at all.


2

You can use sublime text and the alignment plugin: With this plugin, you can select the bib text entry, press Ctrl + Alt + a and the plugin will align the text at =. I have written down some more information about sublime text in my blog. Sublime Text is available for free for unlimited testing for unlimited time for Windows, Mac and Linux. See ...


2

You can change the Citation Key in Mendeley to whatever you prefer. You may have to enable this view, by going to the menu->Tools->Options->Document Details, then choose the document type (for instance, Journal Article), then check the Citation Key box. Then, a field for Citation Key should be visible in the details pane on the right hand side of the window. ...


5

It appears you're using a bibliography style that applies "sentence style", i.e., only the first letter of the first word is capitalized, whereas all other letters are automatically set in lowercase. To override this behavior, encase the word or words in question in curly braces, i.e., write title = "{GNU} cflow {Documentation}", Observe that both the ...


0

This kind of custom bibliography style is exactly the type of thing that the new Bibulous project is probably the best tool for. Using a subset of the OP's suggested database file (main.bib), @article{Abrahams1986, title = {Scaling description of the dielectric function near the mobility edge}, author = {Abrahams, Elihu and Lee, P. A.}, journal = ...


4

Multiple citations at the same place can be achieved with \cite{ref1,ref2,...} Some bibliographic styles (ieee for example) turn multiple citations, i.e., [1,2] into [1], [2]. So, for the second part, it is a matter of the style used and customs.


1

Removing the erroneous commas between the names of the authors, the document compiles: \documentclass{article} \usepackage{apacite} \bibliographystyle{apacite} \begin{filecontents}{\jobname.bib} @report{Jeff2000, author = {Jeff Borland and Peter Dawkins and David Johnson and Ross Williams}, title = {Returns to Investment in Higher Education}, institution ...


1

You have a coding error in your macros. The second \StrSubstitute should not have your \x temporary macro at the end - a final argument to \StrSubstitute should be in square brackets [..] to assign the output to \x, but at this stage you no longer need to save its output. \documentclass{article} \usepackage{xcolor} \usepackage{xstring} ...


2

This is an example of how to use bibunits. It shows how to use different styles for different bibliographies but obviously you can use the same style instead. Note that these styles don't typeset the url so I've added authors to get things working: \documentclass{article} \usepackage{bibunits} \usepackage{filecontents} \begin{filecontents}{\jobname.bib} ...


2

tl;dr: A universal solution is very nearly impossible, biblatex offers the bookpagination (and pagination field) and a well-coded style will make use of those, so bookpagination = {none} seems a good way to go for biblatex. The Long Answer A solution that works for both natbib and biblatex is almost impossible (one might say all but impossible) for the ...


1

If you're using biblatex, take a look on the biblatex manual, section 3.9.1 Generic Commands and Hooks. \finalnamedelim is probably the bibliography string you want to change. You can do that easily with: \renewcommand*{\finalnamedelim}{\addcomma\addspace} You may also take a look at the \multinamedelim-string.


1

You have to use latexdiff directly on the bbl files. So just execute latexdiff old.bbl new.bbl > diff.bbl and then execute (pdf)latex diff.tex. This generally works well with (author,year) style of citations, but I have not tried it with numbered styles. For the bibnote command you probably have to use --append-textcmd option latexdiff ...


1

Your question title and your question are unclear and misleading. You assume everybody knows what AES means. My first thought was Advanced Encryption Standard. As you mentioned year and place I infered you mean the Audio Engineering Society. Are you searching the bib-style for a paper on this conference's proceedings? => author guidelines including a LaTeX ...


0

One easy way to generate custom styles is with the new Bibulous program, developed as a replacement for BibTeX. Using the OP's suggested style, one can use a Bibulous style template of the following form (the code below shows the entire style file): TEMPLATES: inproceedings = <au>, \enquote{<title>,} presented at <booktitle>, ...


2

I think that thesis type is right. The following shows two possibilities. Incidentally, your date format was wrong, but I've corrected it: you need to divide dates with hyphens not slashes. \documentclass{article} \usepackage{filecontents} \begin{filecontents}{\jobname.bib} @thesis{thesis, author = {John Dough and Jane Doe}, title = {An example of some ...


0

a MWE is: \documentclass[12pt]{article} \usepackage{cite} \usepackage{color} \usepackage{hyperref} \usepackage[square,colon,sort&compress,numbers,nonamebreak]{natbib} \hypersetup{colorlinks,citecolor=red,linkcolor=red} \begin{document} blablabla \citet{Ref1} blabla..... \newpage \bibliographystyle{unsrtnat} \bibliography{BibliographyFile} ...


2

You seem to be entering the bibliography "by hand" (unless you have done that simply to create your MWE, which of course (since you've tagged your question bibtex is possible). Anyway, much as I hate answering a question with "use some bibliography package you are not using", I'm going to stick my neck out and say that this makes a good case for using ...


1

Change your entries from this: @incollection{aikhenvald2003, ... editor={Aikhenvald, Alexandra Y and Dixon, R.M.W.} ... } @incollection{plungian2010b, ... booktitle = {{Linguistic realization of evidentiality in European languages}} ... } to this (i.e., add a comma at the end of these fields): @incollection{aikhenvald2003, ... ...


2

If you are not loading natbib, you can pacth \thebibliography so it uses \section* instead of \chapter*: \documentclass[10pt]{book} \usepackage{etoolbox} \patchcmd{\thebibliography} {\chapter*} {\section*} {} {} \renewcommand{\bibname}{References} % this is just for the example \usepackage{filecontents} \begin{filecontents*}{refs.bib} ...


0

With biblatex/biber you can use biber document-base-name.bcf --output_format=bibtex


6

Add \nocite{} commands in the table order at the start of the document. \documentclass{article} \usepackage{filecontents} \begin{filecontents}{\jobname.bib} @conference{Smaili:2011aa, Author = {Smaili, Hafid and Breeman, Jan and Lombaerts, Thomas and Stroosma, Olaf}, Booktitle = {4th European Conference for Aerospace Sciences}, Title = {{A} ...


4

To get rid of the semicolon, the type field must be (as required by the Vancouver style) type={database on the Internet} and not type={page on the Internet} In fact, with the following contents for your ex.bib @Webpage{arXiv-web, type={database on the Internet}, title={arXiv.org e-Print archive}, key={arXiv.org e-Print archive}, ...


0

Inserting a year field will help resolve the problem.


0

I'm also using TexPad. For your bibliography you need to change the typesetter (upper-left corner of the TexPad window" that is by default at "Auto-detect" to "Bibtex" or to be sure "Bibtex + Makeindex"


5

This is off-topic for our site since it is related to Google Scholar exclusively. So I proposed closing as such. But let's close it by providing at least the TeX connection. If you go to your Scholar account settings you'll see the following page; There you can select BibTeX, Endnote, RefMan and RefWorks. But based on my personal experience it doesn't ...


0

I suggest, you use bibtex. In this Intro to BibTeX.pdf you will find a very basic introduction on how to use bibtex and how to cite referencs throughout your LaTeX document. There some tools that allow you to more or less automatically generate the bibtex-source for a given reference. One is JabRef which allows you to export whole .bib-files. GoogleBooks ...


5

Your author field is not properly formatted for BibTeX/biblatex. According to Tame the BeaST, §11 The author field, p. 23: Names are separated by the keyword and: author = {Smith, Jane and Doe, John} Names must be given in one of three formats "First von Last": author = {Johann Wolfgang von Goethe}, "von Last, First": author = {von Goethe, Johann ...


2

Your example code shows you use the apacite package and associated apacite bibliography style, which implement referencing and citing according to the conventions of the APA (American Psychological Association). Starting with the 6th edition of the APA manual, the following guidelines must be followed when referencing and citing entries with multiple ...


1

I recommend you use the command \citealt, not \citealp, for the job at hand. (The instruction will insert a comma between the author and year substrings; I don't think that's what you're looking for.) \RequirePackage{filecontents} \documentclass{article} \begin{filecontents*}{test.bib} @article{Dittrich1996, author = {Dittrich, Winand H. and Troscianko, ...


1

I can't explain where your last line disappeared. To solve it to a desired output, I added one blank line at the end of your document on purpose. I run these lines: pdflatex mal-apa6.tex bibtex mal-apa6.aux pdflatex mal-apa6.tex %! pdflatex mal-apa6.tex %! bibtex mal-apa6.aux %! pdflatex mal-apa6.tex \documentclass[jou,apacite]{apa6} ...


2

A generic (reference manager independent) solution: Create a new bookmark in the bookmark panel of your browser. Name it ("Export -> BibLaTeX" or whatever). URL: (Insert Content from this file). Load the page you want to cite. Click on the new bookmark button. Copy the selected text to clipboard and press [ENTER]. Paste the BibLaTeX entry into your .bib ...


0

Okay so I tried just about every suggested answer I could find throughout the exchange and couldn't get anything to work. Turns out, there was a fault in my .bib file, but it was something I would have never known was not allowed until I created a new file and one by one entered in the bib entries. What I found is that TeXStudio does not allow book ...


1

I was getting the same error message, with TexLive when moving from Windows to Ubuntu, so in case anyone else runs into this... The file I had been using was called test.BIB, which wasn't being recognized by bibtex. Copy/pasted the contents to a new file called test1.bib and worked fine.


3

For shortening bibliographies I recommend to generate a new bib file, where you specify only the fields you really need. (Leaving out middle names, employ common conference and journal abbreviations, etc.) As you see in the answer from Daniel, it is not easy to filter them out afterwards, and you will probably miss one or two. Keep in mind, that some ...


8

Another biblatex solution. As basis we take biblatex's numeric with maxnames=2 \usepackage[style=numeric,maxnames=2]{biblatex} We define our short bibliography driver std that prints only the author/editor, title and date \DeclareBibliographyDriver{std}{% \usebibmacro{bibindex}% \usebibmacro{begentry}% ...


4

In the following, I use biblatex to: Restrict the number of author names to two by passing the maxnames=2, minnames=2 options to the biblatex package. Tailor the content of the bibliography via the \AtEveryitem hook. Inside this hook, I use \clearfield/name/list{<element>} to exclude certain fields from being printed. For many fields the latter is ...


1

You should put it somewhere in your local-texmf root (if you use TeX Live, you already have one; if you use MiKTeX, create one if not already done with MiKTeX Settings application). More precisely, you should put it in: local-texmf\bibtex\bst\ or even in local-texmf\bibtex\bst\ieeetran since it is an extension to the IEEEtran bibtex style, then ...


2

You can use the biber ability to manipulate the bib entries on the fly with \DeclareSourcemap \documentclass{article} \usepackage[uniquelist=false,maxcitenames=2,backend=biber,style=authoryear,natbib=true]{biblatex} \usepackage{filecontents} \begin{filecontents}{\jobname.bib} @online{testref, author = {Some Author}, title = {{Some Title}}, url = ...


1

The key is the bit that reads address empty$ { organization publisher new.sentence.checkb organization output publisher output format.date "year" output.check } { address output.nonnull format.date "year" output.check new.sentence organization output publisher output } if$ This is a conditional block testing if the address is present. To ...


1

The main BibTeX style files recognize a "catch-all" entry type called @misc. It would seem OK to use it for entries of type "movie". If you use the bibliography style apalike, you'll get this output: \RequirePackage{filecontents} \documentclass{article} \begin{filecontents*}{\jobname.bib} @misc{mulcahy86, author = "Mulcahy, R. {\relax (Director)}", % ...


0

Changing to Biblatex might be a smaller step than you think. At least it can be a smaller step than fixing this some other way. Here is an example, using biblatex-apa. I had to add lines stating that the director should be used as author in citations of movies. Otherwise this is out of the box. I added the natbib option to get the same commands like \citep ...


4

The features of bibtex that you mention are not under the control of any user documented language (neither TeX nor the bibtex style language used in bst files) Of course bibtex itself is, like TeX, open source, eg you can browse around from here: http://tug.org/svn/texlive/trunk/Build/source/texk/web2c/bibtex.web?view=log so in principle you can make a ...


4

With this style file: http://comedy.dante.de/~herbert/BibTeX/plain-short.bst and \documentclass{article} \begin{document} \nocite{*} \bibliographystyle{plain-short} \bibliography{ref-antibiotics} \end{document} you'll get:


5

The message about the .csf file is spurious. The documentation is scanty and the bugs are probably many. However, up to a certain extent it works. I found a couple of Russian books with the help of Google books, that allows to export BibTeX data for the book. \begin{filecontents*}{\jobname.bib} @book{a, title={О правѣ наказанія: Рѣчь, произнесенная в ...


0

You can use environment variable TEXMFOUTPUT to specify output directory for bibtex files. In your case, you can create makefile like: all: mkdir out -p pdflatex -output-directory out parent.tex TEXMFOUTPUT="out:" bibtex out/parent pdflatex -output-directory out parent.tex pdflatex -output-directory out parent.tex Consider more ...


3

A minimal example producing the wrong behavior is \documentclass[twocolumn,10pt]{asme2e} \usepackage[english]{babel} \begin{document} \cite{xyz,xxx} \end{document} with which the .aux file show \citation{0.0pt} The erroneous behavior is due to the fact that asme2e.cls defines \@citex in a way that pleases it, while babel redefines the macro in an ...


1

The above will not work properly with https links. The desired behaviour will occur if replace={} is used instead of replace=\regexp{$1}, like so: \documentclass{article} \usepackage{hyperref} \usepackage[style=authoryear,backend=biber]{biblatex} \DeclareSourcemap{ \maps[datatype=bibtex]{ \map{% JSTOR stable \step[fieldsource=url, ...


2

This is what you can do. Open alpha.bst and save a copy in your document directory as myalpha.bst. Locate the lines: FUNCTION {format.names} { 's := #1 'nameptr := s num.names$ 'numnames := numnames 'namesleft := { namesleft #0 > } { s nameptr "{ff~}{vv~}{ll}{, jj}" format.name$ 't := nameptr #1 > { namesleft #1 > ...



Top 50 recent answers are included