Tag Info

Hot answers tagged

22

"et al." corresponds to the localization key andothers. In most styles it is set by the generic bibliography macro name:andothers. You can redefine this macro to wrap \bibstring{andothers} in \emph. \documentclass{article} \usepackage[american]{babel} \usepackage{csquotes} \usepackage[style=chem-rsc]{biblatex} \renewbibmacro*{name:andothers}{% Based on ...


13

Can you please post a MWE? I can't reproduce your problem; the following simple code \documentclass{article} \usepackage{mhchem} \begin{document} \ce{2LiOH_{(s)} + CO_{2(g)} -> Li_{2}CO_{3(s)} + H_{2}O_{(g)}} \end{document} gives me: Perhaps you are using some outdated package(s)?


12

Pershaps, the chemfig package may help you though it relies on tikz? Here is the first reaction: \documentclass{minimal} \usepackage{chemfig} \begin{document} text before \schemestart \setlewis{4pt}{}{red}\Lewis{0:,\chemfig{@{a}\textcolor{red}{A}}}\hskip4pt\chemfig{@{b}\textcolor{black!40!green}{B}}% \arrow \Lewis{0.,A}% \+\Lewis{4.,B}% ...


11

To enable shell escape in TeXShop:


8

The package chemstyle loads varioref by default. This can be turned of with the option varioref=false. The relevant line in your example would therefore read: \usepackage[journal=angew,varioref=false]{chemstyle}


8

This is another case where egreg's xpatch package comes in handy. Instead of copy-pasting the whole content of the name:andothers bibmacro, one may selectively apply changes (as suggested by Marco Daniel): \documentclass{article} \usepackage[american]{babel} \usepackage{csquotes} \usepackage[style=chem-rsc]{biblatex} \usepackage{xpatch} ...


8

The biblatex manual entry for shortjournal says A short version or an acronym of the journaltitle. Not used by the standard bibliography styles. My reading of this is that it is is more something like an informal acronym ('JACS' for Journal of the American Chemical Society, for example) than a formal title. It certainly does not say that it's an ISO ...


8

You can do for example \textsc{d}-Glucose, which requests small caps. This only looks good if the font family you're using actually provides small caps.


7

From your earlier question, I infer that you are using the style chem-rsc which is part of biblatex-chem. I took a look into chem-rsc.bbx and indeed found the following code snippet: \newbibmacro*{institution+location+date}{% \printlist{institution}% \newunit \printlist{location}% \newunit \usebibmacro{date}% \newunit } Because the ...


7

Separator rule commands are built in to the latex format, but defined to do nothing by default, so if you define them to make a coloured rule, you get: \documentclass{scrreprt} \usepackage{color} \newcommand\topfigrule{{% \color{blue}\vspace{2pt}\hrule height 2pt\relax\vspace{-4pt}}} \newcommand\botfigrule{{% \color{blue}\vspace{-4pt}\hrule ...


6

The chemstyle package doesn't do the numbering but the chemcompounds package which is loaded by the former. If you don't want to let the compound numbers to start with the ones in the ToC you have two possibilites: Use \compound+{<label>} in section headings and captions - this command variant will not declare a label but look it up from an auxiliary ...


6

According to this answer, the code comes from TeXample.net. There are easier ways to do this, though.


5

Normally, an extra pair of braces solves this kind of problem: \documentclass{article} \usepackage{chemcompounds} \declarecompound[${[1]^{2+}}$]{label} \begin{document} \compound{label} \end{document} If this was not the case, while you provide a proper MWE with chemcompounds, I would suggest you to use the mhchem package instead: ...


4

Use the code example in section 9.3.1. of the memoir manual to create a "List of Schemes" -- this will override the actions of chemscheme.sty. (You may also want to add \clearpage before \listofschemes.) \documentclass[oneside,openany,11pt]{memoir} \usepackage[demo]{graphicx} \usepackage{chemstyle} % \newcommand{\listschemename}{Schemes}% already defined ...


4

As JMS said, for using with pdfLaTeX the solution was specifying the option [runs=2] for auto-pst-pdf to get two runs for correct numbering: \usepackage[runs=2]{auto-pst-pdf}


4

It would probably overkill to load the package just for this purpose but the chemmacros package provides a lot of IUPAC naming commands. Amongst these are \D and \L for the FISCHER stereo descriptors. With default settings they are only valid inside the \iupac{} command in order not to overwrite the usual definition of \L. \documentclass{article} ...


4

The warning is clear. Somewhere you make something like \newbibmacro*{institution+location+date} but this macro already exists. So you must change it to \renewbibmacro*{institution+location+date}


4

Try including \usepackage{graphicx} in the preamble.


4

Try adding the following to your document preamble, after loading chemstyle: \usepackage{letltxmacro}% http://ctan.org/pkg/letltxmacro \LetLtxMacro\oldschemeref\schemeref \DeclareRobustCommand{\schemeref}[2][]{% \CNlabelnoref{#2}% \oldschemeref[#1]{#2}% } It's difficult to test without actual PDF images.


4

The chemstyle package uses the psfrag package to replace labels in eps graphics. According to section 8.1 of the psfrag package documentation: When adding a piece of text (a tag) in a figure for PSfrag to replace, use a single word, containing only unaccented letters and numbers. This is the way that PSfrag is intended to be used; doing so will ...


4

The culprit of this behavior is the tocloft package. Adding the option titles when loading it: \usepackage[titles]{tocloft} causes the titles of the custom lists to be typeset using the default LaTeX methods, and so your problem is resolved. MWE (note that there's no need to load caption since it is loaded by chemstyle): \documentclass[oneside, 12pt, ...


3

Going straight and simple. Use minipages: \documentclass{book} \usepackage{graphicx} \usepackage[format=hang,labelfont={bf},margin=1em,labelsep=period,textformat=period]{caption} \usepackage{subcaption} \begin{document} \begin{figure}[!h] \centering \begin{subfigure}{0.5\textwidth} \centering \begin{minipage}{0.5\linewidth} ...


3

For versions prior to version 1.0 In the chemnum package the format is controlled by three options: cmpd-style and ref-style which control the standard form and the form placed with \cmpdref and cmpd-weight which sets the labels bold or normal for both. All of them can be set with \cmpdsetup: \documentclass[12pt]{article} \usepackage[T1]{fontenc} ...


3

Are you using the caption package as well? If yes, this bug was fixed in version 3.2 so updating your TeX distribution will help. For example this MWE will work fine when compiled using caption package v3.2, but gives "1" every time when compiled using caption package v3.1m: \documentclass{article} \usepackage[demo]{graphicx} \usepackage{caption,chemstyle} ...


3

You could use \rightarrow instead of ->, if that doesn't work. \ce{2LiOH_{(s)} + CO_{2(g)} {\rightarrow} Li_{2}CO_{3(s)}+ H_{2}O_{(g)}} Since you are writing chemistry, you might be interested in the command \chemarrow provided by the chemarrow package.


3

In the minimal example, the graphics package is implicitly loaded. But the command \includegraphics[width=4in]{anyfile.eps} requires graphicx because of the key=value syntax in the optional argument. That's why the compilation must fail. It's probably good to update to the most recent versions of chemstyle and siunitx. Ubuntu packages might be not ...


2

As Martin suggested in the comments, minimizing the code often helps (that's why it's called a minimal example :) You've added two \usepackage{graphix} to your preamble, this seems too much. And to reproduce your problem, all the chemical packages seem too much too. If I minimize your example, I don't see a problem with the code, as you can see in this ...


2

One workaround for how the chemstyle package takes control of the caption placement is to not use a figure environment for the list and figure, and generate the caption using \captionof{figure}{<caption>} instead of \caption{<caption>} With this method, the construct will no longer float, which may or may not be acceptable for you. Another ...


2

Use the chemstyle package with option floatrow (to make sure the floatrow package will be used by the chemstyle package) and put a \RawFloats as first command inside the figure: \documentclass[twoside,a4paper]{report} \usepackage[demo]{graphicx} % option "demo" added for compiling without images \usepackage[floatrow]{chemstyle} \usepackage{enumitem} ...


2

You probably forgot to use the chemstyle's package option tracking=bpchem. I can reproduce your problem using this MWE (which uses scheme-tmp.eps from the chemnum documentation): \documentclass{article} \usepackage[runs=2]{auto-pst-pdf} \usepackage{bpchem} \usepackage{chemstyle} \begin{document} \CNlabel{bla} some text \CNref{bla} \begin{scheme} ...



Only top voted, non community-wiki answers of a minimum length are eligible