Tag Info

New answers tagged

1

For standard classes there's the titling package. After the edit to the question, the class used here is beamer. In this case, the answer is really simple since beamer provides an easy way to change the color attributes for the title: \documentclass{beamer} \setbeamercolor{title}{fg=red,bg=blue} \title{The Title} \begin{document} \begin{frame} ...


1

Yes, Tikz 3.0.0 when used with Standalone and shadings will fail to work. I had asked a similar question to yours, see Shadings/fadings (apparent) bug in Tikz, then subsequently I decided to file a bug report and this is the response from Christian Feuersänger: Thanks for the report. The issue has been solved already and I confirmed that it works. ...


0

System Settings -> Application Appearance -> Color Note that this will change the appearance all KDE applications!


2

The package file diagrams.sty, found on the webpage, does not define \*Link commands, therefore I have used \*Line instead (\dLine and \rdLine). Analyzing the package is a very time consuming task, because the author obfuscated the internal macros. But it seems that the approach of package luacolor works here. It does not insert specials, but sets the ...


2

Update: You can use \newkomafont to set a default font style for the numbers for all section levels and for the single section levels. Later these defaults can be changed using \setkomafont and \addtokomafont. Of course the \...format commands must be redefined in a way that they use the related \usekomafont{...} commands. Then it is easy to change the ...


7

The command \othersectionlevelsformat, in latest versions of KOMA-Script, doesn't work as before any more (to say the truth I think it's there for backwards compatibility only). Now every sectioning command has its own formatting command. Here's a list: \partformat \chapterformat \sectionformat \subsectionformat \subsubsectionformat \paragraphformat ...


1

For those who do not want to use tikz-cd, psmatrix from the pst-node package works fine. An example : \documentclass{article} \usepackage{pst-node} \usepackage{wasysym} \begin{document} $$ \begin{psmatrix}[nodesep = 10pt, colsep=3cm, rowsep=3cm] % % % % \CIRCLE & \CIRCLE\\ \CIRCLE & \CIRCLE % % % % ...


4

I'd suggest you to switch to the powerful tikz-cd package which was built upon TikZ specifically for commutative diagrams. You can easily control the attributes for every element of yout diagrams: \documentclass{article} \usepackage{tikz-cd} \begin{document} \begin{tikzcd} \bullet\ar[d,dash]\ar[dr,red,dash] & \bullet \\ \bullet & \bullet ...


2

Here is a solution. I replaced \cline{3-5} with a \hhline commmand. I simplified the code with the makecell package, which allows line breaks in cells, and added some vertical padding of cells with thecellspace package. Finally I formatted and aligned the numbers with siunitx: \documentclass{article} \usepackage[utf8]{inputenc} \usepackage[letterpaper, ...


4

The table can be put into a box, whose width is used for a \parbox (or minipage), which limits the width of the caption: \documentclass[demo]{article} \usepackage[english]{babel} \usepackage{graphicx} \usepackage{xcolor,booktabs,caption} \captionsetup[table]{box=colorbox,boxcolor=orange!20} \newsavebox\measurebox \begin{document} \sbox\measurebox{% ...


0

Another solution with the makecell package, which allows for line breaks inside cells, and a common formatting. Also there are less rows. I removed loading color, since you load xcolor, and added the table option? Iformatted the numbers using the siunitx package. Finally, as I don't have pythontex installed I had to comment the line where it's used: ...


1

Tables are constructed from row to row. \multirow{2} puts the stuff in the current and the next row. But the next row is not yet drawn and will overprint the text that sticks into this row. The better way is to use \multirow{-2} in the row below to print in the current row and the row above, which is already set. \begin{tabular}{|c|c|c|c|c|} ...


0

You were doubling some vertical rules inside the \multicolumns and this was giving you thicker rules: \documentclass{article} \usepackage[table]{xcolor} \usepackage{multirow} \usepackage{longtable} \usepackage{array} \begin{document} \begin{longtable}{| >{\centering}p{4cm} | p{2cm} | p{7cm} |} \hline \multicolumn{3}{| >{\centering}p{14cm} ...


4

Colors can be set via package color. It is important to set the color to white in the preamble. Then package color uses this color as \normalcolor. LaTeX uses this color at various places. For example, it resets the color in header and footers to make them independent from the color that is active at the time the output routine is called. ...


3

Try this: \documentclass{article} \usepackage{color,lipsum} \pagecolor{black} \color{white} \begin{document} \lipsum[2-4] \end{document}


4

Obligatory solution with Tikz! Output Code \documentclass{article} \usepackage{tikz} \usetikzlibrary{shapes.multipart} \tikzset{ split/.style={rectangle split, rectangle split parts=2, draw} } \newcommand{\double}[2]{% \tikz[baseline=(a.center)]{ \tikz \node[split, anchor=west, yshift=-1mm, minimum width=1cm, inner sep=3pt, rectangle split ...


4

The macro \bibox{top}{bottom} is what creates the box. By default (\biboxmode = 0), the box width is set to the content width. By resetting \biboxmode to something other than 0, it will make all boxes of fixed width, using the parameter \biboxwd. \documentclass{article} \usepackage{stackengine,xcolor} \def\biboxmode{0} \def\biboxwd{18pt} ...


4

Something like this? \documentclass{article} \usepackage{booktabs,tabularx, colortbl} \begin{document} \begin{tabularx}{0.3\textwidth}{XXX} \arrayrulecolor{red} % choose color aaaa & bbbb & cccc\\ \midrule xxxx & yyyy & zzzz\\ \end{tabularx} \end{document}


0

I have some immediate suggestions: Don't use both \makebox[\textwidth]{...} and the font-size changing command to try to make the table fit inside the text block. Providing the instructions \tiny and \setlength\tabcolsep{4.5pt} should suffice to make the table fit. All of the \hhline{...} instructions can be replaced with \hline. I'd change the column ...


8

Here is a way using tcolorbox (which uses tikz in the backend) \documentclass{scrreprt} \usepackage{xcolor} \definecolor{editorLightGray}{cmyk}{0.05, 0.05, 0.05, 0.05} \definecolor{editorPurple}{cmyk}{0.5, 1, 0, 0} \usepackage[most]{tcolorbox} \usepackage{ragged2e} \usepackage[framemethod=tikz]{mdframed} \begin{document} ...


7

Please always post complete code so that people do not have to guess which packages and class are required to reproduce the problem or answer the question. The following gives one way of incrementing the depth of colouring according to \j: \documentclass[tikz,border=5pt]{standalone} \begin{document} \definecolor{myblue}{cmyk}{10,0,0,0} ...


1

Define a macro \secref to format the output to suit your needs: \documentclass{article} \usepackage{titlesec,xcolor} \definecolor{amaranth}{rgb}{0.9, 0.17, 0.31} \titleformat{\section} [runin] {\color{amaranth}\sffamily\filright} {\thesection} {0.5em} {} ...


2

My table would be pretty similar, only difference really is the spacing. Micos advice are very good, i cannot add anything to it. \documentclass{article} \usepackage{ragged2e} \usepackage[utf8]{inputenc} \usepackage[letterpaper, top=0.5in, bottom=0.5in, left=1.55in, right=1.55in]{geometry} \usepackage{caption} \captionsetup[table]{position=above} ...


5

I'm not sure what you mean by "ugly code", but you could certainly start by getting rid of all \multicolumn{1}{|c|}{} directives: they do absolutely nothing -- except create code clutter. Your table currently has a moderately gaudy look. Assuming that's not intentional, you may want to tone down the impression a bit, e.g., by using a simple, normal-looking ...


4

This is just a complement to Christians solution which can be made a bit simpler. \documentclass{memoir} \usepackage{xcolor} \newcommand{\epigraphrulecolor}{blue} \makeatletter \addtodef\@epirule{\color{\epigraphrulecolor}}{} \makeatother \begin{document} \epigraph{Some inspirational quote}{The Author (1900--2010)} \end{document} We simply prepend the ...


5

Looking into memoir.cls helps ;-) The command for drawing the rule is \@epirule, which is basically nothing different then a wrapper for a standard rule with some width etc. settings. However, there is no color, indeed. Using a grouped {\color{yourcolor}\rule...} (see code below) works. Grouping is necessary, otherwise the color setting would bleed into ...


1

Just use \only<2>{ ... } instead. This should do the trick. \documentclass[10pt, compress, aspectratio=1610]{beamer} \usepackage{color} \definecolor{light-gray}{gray}{0.8} \newcommand{\itemcolor}[1]{% Update list item colour \renewcommand{\makelabel}[1]{\color{#1}\hfil ##1}} \begin{document} \begin{frame} \begin{center} ...


0

Oh, never mind. I found the answer browsing though revtex4-1.cls: \makeatletter \def\pdfstartlink@attr{} \makeatother In the preamble, after selecting the documentclass, helps.


1

Here's a solution with clipping as in Draw ellipses with different coloring for their intersection in tikz? \documentclass[tikz,border=2mm]{standalone} \usepackage{xcolor} \begin{document} \begin{tikzpicture}[{every node/.style={black,font=\sffamily\Large}}] \def\firstcircle{(0,0) circle (3cm)} \def\secondcircle{(3,0) circle (3cm)} ...


2

Here is a suggestion using path picture as node option: \documentclass[margin=5pt]{standalone} \usepackage{tikz} \usetikzlibrary{positioning} \begin{document} \begin{tikzpicture}[ kreis/.style={circle,fill=#1,minimum size=4cm},kreis/.default=none ] \def\tshift{.2cm} \path (0,0) coordinate (A) (1,2) coordinate (B) (2,0) coordinate (C) ...


4

Here's a solution with pgfplots and intersections. There might be simpler solution (like with clipping), but this can be an alternative. Credits: the Batman sign has been borrowed from this reddit thread. Output Code \documentclass[margin=10pt]{standalone} \usepackage{tikz} \usepackage{pgfplots} \usetikzlibrary{intersections} ...


3

Use labelfont to control the font of the label. You can also use captionsetup to treat figures and tables (and all compaitble self-defined floats) differently. \documentclass{article} \usepackage[font={color=red,footnotesize},labelsep=quad,width=.75\textwidth,labelfont={color=blue}]{caption} ...


3

Here is a solution that defines a colouredeqs environment, which has the same syntax as the empheq environment (optional key-valued arguments, and AmS environment as a mandatory argument). The background colour can be changed in the preamble via \colourlet{bkgcolour}{…}. It relies on xcolor and empheq. Comment aside, it is pointless to load amsmath if ...


4

You are mixing different environments here. In your MWE, you are putting an align* inside of an align which is defined in your preamble. Moreover, you are giving a label but what should that label refer to? To which line, to which number (especially if you do not want numbers)? I changed the definitions to your needs. I hope I guessed right. % arara: ...


5

This doesn't solve the error in your code, but it answers the question you mentioned in the title. You can use Tcolorbox package that as its title suggests, creates color boxes. It is very well documented and it has many features. You can also use it in your Beamer presentation easily. \documentclass[a4paper,10pt]{article} \usepackage{tcolorbox} ...


5

I've just written a new package for spot colors. It's named colorspace and as its name suggests the goal is to provide tools related to PDF color spaces. Currently you can define spot colors (including tints with the ! notation) as well as mixed inks (up to 4, so shades, ie, a spot color with black, are now possible). For example: ...



Top 50 recent answers are included