New answers tagged

3

You need a font that has Cyrillic glyphs. One such free font is Dejavu. If you have it installed, then the following should work: \setupbodyfont[dejavu] \starttext \startsection[title={Testing ConTeXt}] This is my {\em first} русский ConTeXt document. \stopsection \stoptext


0

Rather then \normalfont which doesn't work correctly as @Ulrike said you can use \upshape to change font shape for page numbering \documentclass{article} \usepackage{polyglossia} \setdefaultlanguage{russian} \setmainfont{CMU Serif} \usepackage{amsthm} \newtheorem{theorem}{Theorem} \renewcommand{\thepage}{\upshape\arabic{page}} \begin{document} ...


0

Try \enabletrackers[fonts.missing] \starttext \startsection[title={Testing ConTeXt}] This is my {\em first} русский ConTeXt document. \stopsection \stoptext


1

Using babel with more than one language option as in your case you should be aware of the following (babel manual version3.9r from 2016/4/23) In multilingual documents, just use several option. So, in LATEX2e the preamble of the document: \documentclass{article} \usepackage[dutch,english]{babel} would tell LATEX that the document would be written in two ...


0

You said you tried polyglossia but have you switched to xelatex? I see you mention pdflatex only. Loading all the packages (except the obsolete ones which have been removed and the ones that I don't have which have been commented), and excluding that you don't have additional options in the preamble that might create conflict, this setup works. Of course, ...


4

pdflatex is not able to handle combining accents; you should directly use U+0439 rather than the combination U+0438 and U+0306. \documentclass[14pt,a4paper]{extarticle} \usepackage[T2A]{fontenc} \usepackage[utf8]{inputenc} \usepackage[ukrainian]{babel} \begin{document} В рівноважній статистичній механіці. \end{document}


1

With pdfx (v.1.5.8) your example works if you change the package-loading order to become: \documentclass {amsbook} \usepackage[a-1b]{pdfx}% ---- recommended to load it early \usepackage{amsmath} \usepackage{mathtext} \usepackage[T1,T2A]{fontenc} \DeclareSymbolFont{T2Aletters}{T2A}{cmr}{m}{it} \usepackage[utf8]{inputenc} \begin{document} $\CYRI^2$ ...


0

I had two similar problems: "Unicode char \u8: " "Unicode char \u8:." (with dot) The problems were related to the .bib file (references list). The first problem was solved based on the \DeclareUnicodeCharacter{00A0}{ } stated by @egreg. The second one was helped by the @Chris H 's answer. I opened the generated file .log and looked for errors. I found: ...


2

It seems indeed that the the cyrillic glyphs were removed from the last available for download on the GUST.org version 2.004. An older version is available for download on fontsquirrel. Original answer, not correct I have recently run into a similar problem. I was surprised to learn from the ArTourter answer that the Cyrillic glyphs were removed due to a ...


1

Apparently, the whole thing had something to do with TeXstudio, as I was able to compile my file with TeXshop. Moreover, now TeXstudio compiles this file without any problems. In case someone has this particular problem: make sure you have collection-fontsrecommended and collection-fontsextra packages installed try compiling your file with TeXshop



Top 50 recent answers are included