Tag Info

Hot answers tagged

4

Assuming you are on a UNIX system and you have installed auto-complete-auctex manually (say by copying the .el file in the .emacs.d folder and then loading it from your .emacs file), you can simply edit the .el file and change the unwanted completion. The relevant line to edit is line 49: (LaTeX-arg-usepackage . (["opt1,..."] "Package")) change it to ...


4

AUCTeX and RefTeX are two separated and independent packages, one can be used without the other. AUCTeX has some facilities about labels and citations management, RefTeX is much better in doing this. Not everyone uses RefTeX and there has been a change in AUCTeX 11.88 to let users choose which labels should be inserted. This selection is independent from ...


3

If you have GNU Emacs 24 or later, you should definitely read the AUCTeX manual 1.2 Installing AUCTeX The simplest way of installing AUCTeX is by using the Emacs package manager integrated in Emacs 24 and greater (ELPA). Simply do M-x package-list-packages RET, mark the auctex package for installation with i, and hit x to execute the installation ...


2

EDIT: I was wrong, you can do this with normal org mode commands. C-x C-e will invoke org-export-dispatch This brings up the Export Dispatcher buffer. You'll notice the option for Body Only at the top, which is toggled with C-b. Set it to Off, and then complete your export with l l (or whatever you like). I'll leave my original, though now unnecessary, ...


1

In recent versions of auctex, it looks like it'll be more reliable to set TeX-command-extra-options, which is designed for just this purpose, and doesn't make you override the various forms of TeX-command. So this is a nice, non-destructive way of adding options without interfering with changes down the line -- like switching between TeX flavors, enabling ...


1

Any suggestions on how to proceed would be welcome. I would prefer not to manually change any configuration files as I came across an admonishment not to do so in the pdfTeX manual. I never bothered to repair this kind of misbehaviour of Emacs, because if I encounter "TeX exited abnormally", I have a quick look at the output. You get it in a fraction of ...


1

After I type \usep and then press TAB, the string is autocompleted to ... Wrong approach. Don't type \usep, but type C-c C-m and then usep and tab. Because auctex has its own machinery for completion of packages.


1

I solved this problem by inserting '(reftex-use-external-file-finders t) into my emacs init file. It makes RefTeX use the appropriate command from reftex-external-file-finders to find the file. In my case that is kpsewhich -format=.bib %f. The default is looking in the folders specified in the environment variables BIBINPUT and TEXINPUT. I prefer this ...


1

You always get the log by typing C-c C-l after running LaTeX, pdfLaTeX, LuaLaTeX, XeTeX (forgot something?). Then have a look at the first (!) error message. And for the rest, please see this answer: http://tex.stackexchange.com/a/124259/4736 .



Only top voted, non community-wiki answers of a minimum length are eligible