Tag Info

New answers tagged

1

You can use Latin Modern Sans Serif: \documentclass{article} \usepackage{fontspec} \setsansfont{Latin Modern Sans} \begin{document} \textsf{A simple example} \end{document}


3

With utf8 the Unicode character € is mapped to \texteuro, which requires textcomp. The definition of \texteuro is \DeclareTextCommandDefault{\texteuro} {\CheckEncodingSubset\UseTextSymbol{TS1}\tc@fake@euro5\texteuro} If the TS1 font for the current family is known not to have the Euro symbol (that is, it belongs to class 5), the glyph is faked by means ...


7

LaTeX does not need to check anything, the T1 encoding doesn't include euro by definition. It is in the TS1 encoding (as used by textcomp) and of course in the EU1 and EU2 encodings used by lua and xe latex.


1

You shouldn't use applemac encoding for .tex files any more! All modern OS understand UTF8 and, with ascii, it is the only universal format. I have no idea why the default in TeXshop still is applemac, if I'm not mistaken. You also can use UTF8-encoded .bib files if you make your bibliography with biblatex/biber, and JabRef is able to save your .bib files ...


3

The line \usepackage[utf8]{fontenc} is incorrect: the good one is \usepackage[T2A,T1]{fontenc} for supporting both the Latin and the Cyrillic alphabet. However, you have to mark up where you want to use Cyrillic: \documentclass[a4paper,12pt]{article} \usepackage[T2A,T1]{fontenc} \usepackage[utf8]{inputenc} \usepackage[russian,english]{babel} ...


3

Font and input encodings are different things (see fontenc vs inputenc). As such, utf8 makes sense as an option for the inputenc package (it is an input encoding), but is nonsense for fontenc (it's not a font encoding). You presumably want something like \usepackage[T1]{fontenc} (or perhaps T2A,T1, as you seem to have some Russian text based on your ...


1

This seems to be a bug in the new version of the base compiler. I had the same error using pdflatex and resolved it replacing \usepackage[utf8]{inputenc} by \usepackage[utf8]{input} Then the compiler will say it didn't find input.sty and ask for a file. Just type 'inputenc.sty'. It should be able to complete. I'm on my way to a better fix, waiting ...


3

You have improper encoding: UTF-16 instead of expected UTF-8. It may be still visible in your graphic editor, but makes a false input to the pdflatex (e.g.) program.


1

It is been a while but I'd like to contribute to offer a solution for LyX. Type: \usepackage{cmap} \usepackage[T2A]{fontenc} in the preamble (Document-> Preferences). Then activate under languages (Document->Preferences->Language) for the encoding: "Different -> Unicode(utf8). Close and save.


4

The column is narrower that \tymin which is 10pt by default. Set \tymin to a smaller value to avoid the warning: \documentclass[a4paper]{article} \usepackage[T1]{fontenc} \usepackage{tabulary} \begin{document} \setlength{\tymin}{5pt} \begin{tabulary}{\textwidth}{C}aa\end{tabulary} \end{document}


4

The problem seems to be in the fact that the European Modern font have a slightly thinner em than Computer Modern. If I load tabulary with the debugshow option, I get Table Target Width: 345.0pt \tabcolsep: 6.0pt \arrayrulewidth: 0.4pt \doublerulesep: 2.0pt \tymin: 10.0pt \tymax: 690.0pt Col 1: Initial=22.00003pt -12.0pt Final=10.00003pt > ...



Top 50 recent answers are included