Tag Info

New answers tagged

1

I've found out a solution. Here's a MWE: \documentclass{article} \usepackage[english]{babel} \usepackage[T1]{fontenc} \usepackage{MinionPro} % https://github.com/sebschub/fontpro \usepackage{libertine} \usepackage{titlesec} % garamondx emph % install it with https://www.tug.org/fonts/getnonfreefonts \let\emph\relax ...


3

If you are using the default settings and want serif font for just a symbol, you can define a command for it using \mathrm \documentclass{beamer} \newcommand\SPi{\mathrm{\Pi}} \begin{document} \begin{frame} $\SPi\quad\Pi$ \end{frame} \end{document} On the other hand, if you are using the serif math fonts, you can use \mathsf to define your sans-serif ...


3

Open Sans Condensed comes in Light, Light Italic, and Bold, with no Bold Italic. You can use it like this: \documentclass[20pt]{beamer} \usepackage{fontspec} \usefonttheme{professionalfonts} \setsansfont{Open Sans Condensed Light}[ Numbers=OldStyle, ItalicFont={* Italic}, BoldFont={Open Sans Condensed Bold}] \begin{document} \begin{frame} ...


0

I wondered whether, given that PDF readers might replace Helvetica with Arial if the Helvetica is not embedded, this might be a work-around for getting my document into Arial. If a font is not embedded, then the behaviour depends on the PDF viewer, user settings, OS, available fonts, and system and user font configuration. That is, if the font is ...


2

When you install fonts into a TEXMF tree, TeX needs various things in order to use them: The various files must end up in the directories TeX expects. In your case, this is already all in order. TeX must be able to find the various files when it looks. Since you installed into your personal tree, TEXMFHOME, this is straightforward: TeX will find them so ...


1

I had the same problem with FontAwesome and struggled a lot with my new Windows 10 Installation, MiKTeX 2.9 and TexStudio. I also tried other things like running initexmf --mkmaps and initexmf --update-fndb or reinstalling MiKTeX or reinstalling the packages using MPM which didn't help me. Here is what worked: miktex-makepk: PK font ...


1

The following example with up-to-date TeXLive works well: \documentclass{amsart} \usepackage{colonequals} \usepackage[math-style=ISO]{unicode-math} \setmainfont[Numbers=OldStyle]{Minion Pro} \setmathfont{MinionMath-Regular} \setmathfont[range={\mathfrak,\mathcal}]{XITS Math} \begin{document} foo \textit{bar} \textbf{baz} \begin{equation*} f(x) ...


10

Option professionalfont helps to reduce the font declarations by beamer (older versions): \documentclass[professionalfont]{beamer} \usepackage{siunitx} \usepackage{newtxtext,newtxmath} \usepackage{bm} \begin{document} \end{document} Newer beamer versions want a font theme instead of the option: \documentclass{beamer} \usefonttheme{professionalfonts} ...


4

A variant of Heiko's method; I also use bm, that features a better implementation of \boldsymbol (that can also be called \bm). With \ifcoef you can disable \boldsymbol more easily also in other situations, by simply setting \coeftrue (in a group). \documentclass[12pt,a4paper]{article} \usepackage{amsmath,amssymb,bm} \newif\ifcoef \newcommand{\bvec}[1]{% ...


5

\boldsymbol is still inside \mathnormal, thus the setting of \mathnormal is overwritten by \boldsymbol. A way to solve this is to redefine \boldsymbol inside \coef: \documentclass[12pt,a4paper]{letter} \usepackage[latin1]{inputenc} \usepackage{amsmath,amsfonts,amssymb} \newcommand{\x}{\boldsymbol{x}} \newcommand{\coef}[2]{% \begingroup ...


1

Here's how to do it (with the help of answers 1 and 2): Obtain Adobe's AFDKO font tools and install them. Put the font file into an empty directory. Run tx -pdf -1 YOUR_FONT.otf > YOUR_FONT.pdf to map the glyphs of font. Open YOUR_FONT.pdf, search for the wanted glyph and its glyph tag (the upper left number, we will name it GLYPH_TAG). Create a dummy ...


5

There is no general answer to this question, nor could there be. It’s not just that some designers misuse calt and other features, or disagree in their interpretation of the specification. Even if they all used features as they were meant to be used, fonts would still exhibit different behaviors. Imagine that everyone agreed to use ss01 for Q, and ss02 for ...


0

To change your font, just change \setmainfont to a different font: \documentclass{book} \usepackage{fontspec} \setmainfont{FreeSerif} \begin{document} This is in another font than ``Handwriting -- Dakota''. \end{document} Note that your "error" messages are not errors, just warnings. They tell you your font lacks certain properties (I can't run your ...


0

‘Handwriting - Dakota’ is a typeface included in OS X in an Apple-proprietary format called a font suitcase, which dates back to the classic Mac OS. LuaTeX and XeTeX have their own code for accessing font files, separate from the operating system, and cannot use these typefaces or any like it (like Hoefler Text) unless you buy them again from their original ...


2

They are the same fonts. That is, the Font Catalogue also lists alternatives and extensions etc., but the basic fonts it lists are the ones you already get. What PSNFSS actually provides are clones of the fonts listed unless you have installed alternatives and configured your installation to use them. More specifically, the packages support either clones ...


3

In order to get small caps from a font through the standard commands such as \textsc, the font you have loaded needs to have small caps. The font you've chosen, DejaVu Serif Condensed, doesn't. When you compile your MWE, you will as a result get a font warning from LaTeX that no small caps exist for this font, and that it will use the normal font instead: ...


0

Code: Well I searched a lot for a script to recognize uppercase letters and lowercase letters, with no success (How to check if the selected letter is uppercase or lowercase in a macro?). But then I found a more elegant way to make the fake small caps (and fake mid caps) in Faking small caps in XeLaTeX: \documentclass[a4paper,12pt,twoside]{memoir} ...


0

Based on the comments received, I've been able to answer my question. See page 27 of the current manual for microtype. ! pdfTeX error (font expansion): auto expansion is only possible with scalable fonts. Automatic font expansion has been improved in pdfTeX 1.40, in that it now not only works with Type 1 fonts but also with TrueType, OpenType ...


3

One solution is to create fake small caps. The MWE below defines a command \fakesc that uppercases and shrinks text to resemble small caps. \documentclass[a4paper,12pt,twoside]{memoir} \usepackage{DejaVuSerifCondensed} \usepackage[T1]{fontenc} \newcommand\fakesc[1]{\uppercase{{\scriptsize #1}}} \begin{document} The sign on the door said \fakesc{keep out}, ...


1

The bookmark text for \faWrench contains a font command \Segoe (BTW, the command is a font switch command, not a macro with an argument). Font switch commands are NOT allowed inside bookmarks. Or does a PDF viewer exists, which can make use of a LaTeX font switch command? Instead of \newfontfamily\Segoe{segoeui.ttf} ...


1

You can use the fontspec facilities for this: \documentclass[12pt, oneside, a4paper]{article} \usepackage{geometry} \usepackage{amsmath} \usepackage{amssymb} \usepackage{amsfonts} \usepackage{fontspec} \usepackage{xgreek} \setmainfont[ ItalicFont={GFS Didot Italic}, BoldFont={GFS Didot Bold}, BoldItalicFont={GFS Didot Bold Italic}, ]{GFS Elpis} ...


0

As a workaround, you can use the package unicode-math. You can see here the differences between unicode-math and mathspec. In short, mathspec is intended for replace some fonts in math mode with system fonts (which you are looking for), while unicode-math main purpose is use complete math OpenType fonts. Using unicode-math, you can set a complete math ...


3

Which version of ConTeXt are you using? I am using 2015.08.13 on Mac and the following example: \definefontfamily[myfamily][serif][Baskerville] \definefontfamily[myfamily][sans][Optima] \setupbodyfont[myfamily] \starttext Hello \sans{World} \stoptext works correctly. pdffonts test.pdf name type encoding ...


3

Just add this to your preamble: \def\UrlFont{\normalfont} or whatever font you want (may I suggest Old German?)


3

You can just follow the instructions provided by The LaTeX Font Catalogue if one of the fonts they illustrate is suitable. Just click on the font you like and copy the code lines into your preamble. For example if you want to use Kurier: \documentclass{article} \usepackage[math]{kurier} \usepackage[T1]{fontenc} \begin{document} \[ \Pr(P) = ...


4

Another solution based on titletoc, from the titlesecbundle; \documentclass[fleqn, a4paper, 11pt, oneside]{book} \pagestyle{plain} \renewcommand{\rmdefault}{ptm} \usepackage{newtxtext} \usepackage{titletoc} \contentsmargin[1cm]{0cm} \titlecontents{chapter}[0em]{\vskip12pt\bfseries\sffamily} {\thecontentslabel\enspace} {\hspace{1.05em}} { ...


3

\url comes from package url (loaded by hyperref). \urlstyle configures the font. The same font: \urlstyle{same} This means, no special font is set and the current font is used for the URL. Other pre-defined styles: \urlstyle{rm}: The font \rmfamily is used. \urlstyle{sf}: The font \sffamily is used. \urlstyle{tt}: This is the default: \ttfamily. See ...


3

When using tocloft, you have to set the fonts for each sectional component separately. There is no over-arching font setting, since each component is placed inside a box or group with their own font-specification. It allows the ultimate specificity, even though it might not suit your generic needs: \documentclass{book} \usepackage{mathptmx} ...


1

The font table shows all of the glyphs present in the font. For LaTeX to typeset a character in a certain font, it must either be supported directly by the font e.g. the character is @ and the font contains an @ symbol. Or, it must be possible to construct the character from characters the font does supply e.g. the character is ŵ and there's no ŵ in the ...


2

Add T1 to the font encodings else cm-super won't be used i.e. \usepackage[T1,T2A]{fontenc} - otherwise you'll get OT1 as the default text encoding and the default Computer Modern, I think, which isn't scalable. Since mathabx is causing the problem, you need to ensure that you have scalable versions of mathabx installed correctly. Obviously, you should ...


8

If you compile with pdflatex you can do this: \documentclass{article} \usepackage{Alegreya} \input glyphtounicode \pdfgentounicode=1 \pdfglyphtounicode{fj}{0066 006A}% f j \begin{document} fb ffb ff fh ffh fi ffi fj ffj fk ffk fl ffl ft fft \end{document}


0

For the record, here is what I ended up doing, using the idea from the older version of Gustavo's answer. \newcommand*\GrabFontIdentifier[2]{% % #1 <- a control sequence, e.g. "\next" % #2 <- a NFSS font name, e.g. "operators" \sbox\z@{$% \expandafter\global\expandafter\let\expandafter#1% \the\textfont\csname sym#2\endcsname $}% } ...


2

I don't remember where this method was found, but I share it here, since this is one of the many questions asking for a fatter computer modern. I hope this is what you look for, it was what I looked for. In your modes.mf you add: mode_def myblacker = mode_param (pixels_per_inch, 1200); mode_param (blacker, 3.5); mode_param (fillin, 0); mode_param ...


3

I have no problem with lualatex from up-to-date TL 2015 (I used "..." for some Japanese characters which the editor of SX doesn't allow.) \documentclass[a4paper]{article} \usepackage{fontspec} \setmonofont[ BoldFont = Source Han Code JP B, Scale=0.9 ]{Source Han Code JP L} \setmainfont{Source Han Sans Regular} \begin{document} This is Source Han ...


10

Let's follow what cmr10.mf says; at the end of it there is generate roman where generate is (usually) equivalent to input. Now roman.mf has input romanu; % upper case (majuscules) input romanl; % lower case (minuscules) input greeku; % upper case Greek letters input romand; % numerals input romanp; % ampersand, question marks, currency sign input ...


2

You need to expand \TextA before feeding it to \textit: \expandafter\textit\expandafter{\TextA} If you like you can redefine \textit in such a way that it expands its argument one time first: \ExplSyntaxOn \cs_generate_variant:Nn \embrac_textit:nn {no} \RenewDocumentCommand \textit {sm} { \IfBooleanTF {#1} { \embrac_textit:no {*} {#2} }% ...


4

Euler is not really compatible with Computer Modern, it's better with Palatino, in my opinion. As a rule, the operator names such as sine, cosine and logarithm are typeset with the normal (upright) text font, in order not to be confused with products of quantities: “sin” does not mean the product “s by i by n”. \documentclass[border=2]{standalone} ...


1

It's possible, by using \mathchoice and making digits “math active”: \documentclass{article} \usepackage{times} \usepackage[lite]{mtpro2} \begingroup \makeatletter \newcommand{\adjustdigit}[1]{% \begingroup\lccode`~=`#1 \lowercase{\endgroup \expandafter\xdef\csname digit\romannumeral#1code\endcsname{\the\mathcode`#1\relax} \gdef~{\csname ...


7

\documentclass{article} \usepackage{fontspec} \setmainfont{Minion Pro} \newfontface\Swash{MinionPro-It}[Contextuals=Swash] \newcommand\textsw[1]{{\Swash#1}} \begin{document} \textsw{Qu’est que c’est?} \emph{Qu’est que c’est?} \textsw{Zygoma} \emph{Zygoma} \end{document}


1

Assuming that the truetype and opentype versions of the Crimson font are similar, the following should work: \documentclass{article} \usepackage{fontspec} \setmainfont{Crimson Roman}[Ligatures=TeX] \begin{document} Some text. \end{document} It should work if you have the truetype but, since I've got the opentype version, that's the one I actually ...


1

If you've installed the font in a proper texmf directory, run texhash or the equivalent for your system. XeTeX will then find the font without having to specify the location. Secondly, including Path in \defaultfontfeatures is almost certainly wrong in almost all cases. This is what is causing your error — after specifying a Path, fontspec assumes that the ...


2

Warning: This answer has been completely rewritten. Althought the general idea remains the same as in its first version, the new code differs in many aspects. I am going to add some explanation, too. The code The following code defines two commands: \GrabFontIdentifier lets the control sequence passed in its last mandatory argument equal to the font ...


0

You may try: \setmainfont[Ligatures={TeX,Common}, BoldFont={AGaramondPro-Semibold}, ]{Adobe Garamond Pro} But, AFAIK, you'd have to make sure that the font is named exactly as 'AGaramondPro-Semibold' in your system. To make sure you spelled the <fontname> correctly, you can run fc-list :fontformat=TrueType command to see the ...


1

You need to install more fonts. This should be possible with something like tlmgr install psnfss (if necessary; I doubt it) and more importantly tlmgr install helvetic. Sometimes figuring out font package naming can be difficult…


1

From the start menu launch MiKTeX Package Manager, select mathabx-type1, right-click on the selection and select install. base. To install cm-super, do the same from MPM. Finally run from the command-line: updmap --verbose to update the type 1 fonts database. Added: I forgot this (important) detail: for the mathabx fonts to be displayed with their ...


8

With the advent of MacTeX2014 and continuing in MacTeX2015 -- and likely to persist into the indefinite future :-( -- Lua(La)TeX can no longer directly access certain font features, such as ligatures, if the font is a system font whose ligature-related properties are AAT-encoded and not OpenType-encoded. Hoefler Text, Didot, and Baskerville are three such ...


2

It is rather unclear what you actually want. But here two suggestions: You could still use SourceSerifPro as main font and fake a slanted font: \documentclass[]{scrartcl} \usepackage{fontspec} \defaultfontfeatures{Ligatures=TeX} \setmainfont{SourceSerifPro}[ ItalicFont = SourceSerifPro, ItalicFeatures={FakeSlant=0.2}] \begin{document} This is a ...


3

If you declare a heavy math version you need to define some fonts for it, here I just make them the same as the bold ones (which just means that you are more or less bound to run out of 16 math fam, but you get bold brackets) \documentclass{article} \DeclareMathVersion{heavy} \renewcommand\rmdefault{mdugm} \newcommand\heavymath{\mathversion{heavy}} ...


3

The set up for fonts is split into a configuration for text and a configuration for maths. Settings for one do not affect settings for the other. So, every time you switch to maths mode, you activate a different set of fonts. Of course, if you use \text{} or something, you switch temporarily back to text. But, while in maths mode, you are using the maths ...


0

This answers a question addressed to me in comments. You have done everything you need to do. You don't need to do anything special to use the fonts beyond adding the lines you mention to your preamble. Here's a complete example: \documentclass{article} \usepackage[T1]{fontenc} \usepackage{lxfonts} \usepackage{kantlipsum} \begin{document} \kant[1-20] ...



Top 50 recent answers are included