Tag Info

Hot answers tagged

10

You seem to have a misunderstanding of font lookup of xetex. The different lookup mechanisms are described in detail in the XeTeX manual, but I will try to boil things down a little for an answer. If you provide a font name, e.g. Times New Roman, as in your first example, where you call \setmainfont{Times New Roman} then XeTeX will use your system's ...


7

As can be seen in the answers to your other post, you have to define your symbols after the start of your document. % arara: lualatex \documentclass[a4paper]{article} \usepackage{unicode-math} \AtBeginDocument{% \let\phi\varphi \let\epsilon\varepsilon } \begin{document} \noindent varphi: $\varphi$ works!\\ phi: $\phi$ should look the ...


7

It looks like it was a bug in luatex. This seems to have been fixed in the latest version of luatex, version 0.80.0, as provided in texlive 2015-pretest. Using these versions, the output is as expected:


5

You can prepare the following example: \input ucode \input lmfonts \hsize=12cm —Hola, esto es un texto absurdo —para ejemplificar lo que ocurreconestedocumento— con algunas palabras más. \end and you can try to process it by 1) xetex test and 2) xetex -fmt pdfcsplain test. You will see different results: 1) the long word isn't hyphenated, 2) the long ...


5

Loading a non existent language is useless. Just add a font family for Ethiopic characters (I used Kefa, use whatever you like). \documentclass[a4paper]{scrartcl} \usepackage{fontspec} \usepackage{polyglossia} \usepackage[Latin,Ethiopic]{ucharclasses} \setmainlanguage{english} \newfontfamily{\tigrinyafont}[Script=Ethiopic, Scale=1]{Kefa} ...


5

unicode-math makes only sense if you also have a sensible "unicode math" font that you want to use as base math font. There is no "cm bright math" (sans serif math fonts are sparse ...). So it is better to use for the math setup the non-unicode way: \documentclass[a4paper,12pt]{article} \usepackage{cmbright} \usepackage{amsmath,amssymb} ...


5

Just convince siunitx to use your newly created font family by: \sisetup{text-rm=\oldstyle} full example: \documentclass{standalone} \usepackage{fontspec} \setmainfont{TeX Gyre Pagella} \newfontfamily\oldstyle[Numbers={Monospaced,OldStyle}]{TeX Gyre Pagella} \usepackage[detect-all]{siunitx} \AtBeginDocument{ \sisetup{text-rm=\oldstyle} } ...


4

An up-to-date TeX distribution has the XCharter OpenType font, so you can use it instead of \renewcommand{\rmdefault}{bch} which will not give you anything except for ASCII characters. Moreover \la as you defined it is just a switch that tells XeLaTeX to use Brill from that point on. A correct document would be \documentclass{article} ...


4

Version 2 After reading a recommendation/comment by Khaled Hosny I've changed the core of the snippet, so it's switching font only when needed. There is no font change on purpose if a character is a space. In the previous version, it wrapped every single character (not recommended in general as it breaks up ligatures, kerning pairs and probably other ...


4

This is for XeLaTeX only, as the behavior of LuaLaTeX when inputting — (U+2014) seems satisfactory. We want to allow hyphenation in the word preceding the em-dash, so we can add a zero kern before it, which will make the word end, but doesn't create a line break point. However, we want also to remove the behavior of the em-dash that, for compatibility with ...


4

CW from the comments: luaotfload normalizes all names supplied by the font. Apart from lowercasing you can also leave out spaces if you wish. So, for XeLaTeX, spacing and casing are significant, while for LuaLaTeX, they are not. This is not engine-dependent, just how luaotfload (and, incidentally, ConTeXt) treat things. The rationale is simple: ...


4

When you are using XeTeX then your task is exactly solved by XeTeX primitives \XeTeXcharclass and \XeTeXinterchartoks. Read the manual of XeTeX. For letters 'a', 'e', 'i', 'o', 'u' the setting looks like: \newXeTeXintercharclass \mycharclassbf \XeTeXcharclass `\a =\mycharclassbf \XeTeXcharclass `\e =\mycharclassbf \XeTeXcharclass `\i =\mycharclassbf ...


3

This is because different fonts are used when compiling using PDFLaTeX or XeLaTeX. Quoting from the style definition file: \ifxetex %% If the document is compiled with XeLaTeX, we load the TU Delft house %% style fonts: Bookman Old Style (serif) for titles and Tahoma (sans-serif) %% for text. Even if the nativefonts option was specified, we ...


3

in \la{N} the {} are not doing anything, \la does not take an argument, it switches font for the remainder of the current group. In this case that is the \end{enumerate} So at that point the font (and any other local declarations) revert to the values they had at \begin{enumerate}. It isn't clear if you intended \la just to change the font of N or if you ...


2

OK, so egreg's comment pointed me in the right direction. I tried using mathspec to change the math fonts, with not luck. After taking a closer look at the macros in hepparticles, I fount that they use \mathup and similar macros for rendering the particle names. I couldn't find out how to change those with mathspec, so I switched to unicode-math and found a ...


2

I found a solution that works for me. I started playing around with version=bold, as David suggested, but that kept turning all my math mode text bold. In the end I switched from file names to system font names. (I wanted to avoid that initially, since I am working on the same document from several different machines.) With system font names, \boldmath ...


2

Probably hidden use of math mode is forcing some direction nodes to intervene. You can protect the code inside \mbox \documentclass{article} \usepackage{fontspec} \usepackage{tikz} \usepackage{polyglossia} \setmainlanguage{french} \setotherlanguage{arabic} % comment that line, the problem disappears. \setmainfont[Ligatures=TeX, ...


2

Let me present a small snippet in LuaTeX. We pass an argument and selected letters to the Lua core, where the snippet decomposes it at a character level and wraps the preselected letters only by the \malbf command. Words to be marked are tagged, I didn't expect a TeX command, I presumed plain text. I enclose a small example with English (requested letters ...


2

Your installation was correct. If you try other fonts, you would encounter no problems. You just were unlucky enough to try the Garamond font first. The KPSE* family and the updmap are not the issue here. Apparently, the problem lies with the documentation at the LaTeX font catalog which claims that Garamond is part of TeXLive. Garamond is only partially ...


2

You can define a \tabfig command that chooses oldstyle digits in tabular format: \documentclass{article} \usepackage[ oldstyle, proportional ]{libertine} \usepackage{array} \newlength{\period} \newcommand{\tabfig}{\fontfamily{LinuxLibertineT-TOsF}\selectfont} \AtBeginDocument{\settowidth{\period}{\tabfig 0000--0000}} \begin{document} ...


2

Concentrating on the direct use of emdash as control of --- is a bit harder. The following produces the following in pdflatex, lualatex and xelatex. I think that's the desired outcome. \documentclass{scrartcl} \usepackage[hmargin = 4cm]{geometry} \ifx\Umathchar\undefined %pdftex \usepackage[utf8]{inputenc} \let\oldtextemdash\textemdash ...


1

In a current miktex and texlive 2014 one can get the search path for font feature files with kpsewhich --show-path="font feature files" and this gives pathes of the type <texmf-tree>/fonts/fea. I tested it with both systems and it worked fine after I updated the fndb/ls-R.


1

As pointed out by Robert in the comments, the problem has nothing to do with Microtype. But by activating Microtype or any other font feature by \setmainfont[Microtype]{Latin Modern Roman} the default font settings get overwritten. Fonts which have a special subfont for smallcaps may not work afterwards. By reinitializing the smallcaps subfont it will ...


1

If this is what you expect to see in your LaTeX / XeTeX output … then you may just have to change the name of the font, which may be outdated in the example you got. I modified your example like this (with comments removed): \documentclass{article} \usepackage{fontspec} \setmainfont[Script=Devanagari]{Lohit-Devanagari} % Hindi -> Devanagari ...


1

Using the package amsbsy and \pmb seems to get the boldmath. \documentclass{minimal} \usepackage{fontspec} \usepackage{unicode-math} \usepackage{amsbsy} \setmainfont[% Ligatures=TeX, BoldFont=LinLibertine_RB.otf, ItalicFont=LinLibertine_RI.otf, BoldItalicFont=LinLibertine_RBI.otf] {LinLibertine_R.otf} \setmathfont{texgyrepagella-math.otf} ...



Only top voted, non community-wiki answers of a minimum length are eligible