Tag Info

Hot answers tagged

22

I think you might also be interested in the package footmisc. When you use \usepackage[bottom]{footmisc}, it always puts the footnote as much to the bottom as possible.That means that if your page breaks for whatever reasons (preventing widows or orphans), e.g., 3 lines before it would be full, the footnote is typeset to the bottom as if the page was really ...


13

The TeX FAQ has some information on this. The easiest (and most brutal) thing they suggest is setting \interfootnotelinepenalty=10000, which will prevent the footnote from breaking across pages. Alternatively, they suggest adjusting the space on the page (using \enlargethispage{<length>}), to force the line with the footnote onto the next page. ...


11

In a comment to the question I quoted footmisc's manual: The hyperref package has ambitions to make hyperlinks from footnote marks to the corresponding footnote body; naturally this causes grief to footmisc, and unfortunately no remedy is currently known. If you use footmisc, suppress hyperref's hyperfootnotes, by loading it as: ...


10

Probably the easiest solution is to add the option splitrule when loading the footmisc package: \usepackage[norule,splitrule]{footmisc}


10

You're telling TeX that breaking a page in the middle of paragraphs is infinitely bad. As a result, it's starting a new page after the first paragraph which results in a really underfull page. If you want the page to break after the first paragraph, you should write \newpage after it. I think \interlinepenalty=10000 is absurd. If you want to control ...


10

I see that I come some months to late but I want to present my approach to maybe solve the problem or at least to provide a workaround. The problem at my side is, the approach is so simple so that I can't imagine that there is no other people who had the same idea before. So my question is: Where is the catch in this approach? To explain the code: I ...


9

Change the order in which you load the packages: \usepackage[para]{footmisc} \usepackage{lscape} If you are using pdflatex, you could use pdflscape instead of lscape.


9

I can't reproduce your problem. Here's a minimal example which patches the footnote text code to remove the space (rather than adding a negative space in each footnote.) \documentclass[twocolumn]{article} \usepackage[perpage,para]{footmisc} \usepackage{etoolbox} \makeatletter \patchcmd{\@makefntext}{.5em}{0em}{}{} \makeatother \begin{document} This is ...


9

The following document prints correctly the nested footnote, with commas in the proper places: \documentclass{article} \usepackage[multiple]{footmisc} \begin{document} This text has multiple sequential footnotes, with commas at the proper places\footnote{Here is a footnote}% \footnote{Here is another footnote.\footnotemark{}}% \footnotetext{This is the ...


9

Since you're already using the footmisc package, you may want to load it with the option splitrule. Doing so will place a full-linelength line ("rule" in typographic jargon) above the split-off part of a footnote that's split across two pages. This is a frequently-used solution in the publishing industry to indicate to readers that the footnote material at ...


9

To make it work with para automatically you need a modified version of \url as noted in the comments, you the first version added parfillskip glue after each url which padded to the end of the line, This version removes that. \documentclass{article} \usepackage[para]{footmisc} \usepackage{hyperref} \def\myurl#1{\setbox0\vbox{\hsize.5\maxdimen ...


9

footmisc performs a patch on \@makecol. However, before doing so, it checks to make sure that its definition conforms to what it looked like at the time of writing footmisc. The package implementation (section 5.1 The output routine, p 12) mentions: First, we ensure that \@makecol is as expected from the time at which these macros were written: since ...


8

At least for the standard document classes (and also with the footmisc package loaded), footnote marks are typeset as superscripts which adjust to (and should be appropriate for) the font size in effect. If you nevertheless want somewhat smaller marks in chapter titles, you could add a \scalebox (from the graphicx package) to the definition of the kernel ...


8

The footmisc manual describes its interactions with various other packages, including setspace. This quote is from section 2: The setspace package modifies the way line spacing is calculated in footnotes. Footmisc knows about this, and preserves the change. However, you must load setspace before footmisc. If you load setspace last, then footmisc ...


8

The manual of footmisc states that the default symbol list is defined as: \DefineFNsymbols*{lamport}[math]{*\dagger\ddagger\S\P\|{**}{\dagger\dagger}{\ddagger\ddagger}} and then set using: \setfnsymbol{lamport} So, if you only want to remove the * (and maybe **) you can use: ...


7

No automated solution, but perhaps \enlargethispage can help. It should quite easy to measure the gap between text and footnotes on the last chapter page and issue an \enlargethispage{-??\baselineskip}, where ?? stands for the number of lines to cut from the page. Let's hope that the among the requirements there's a page number at the bottom. Of course ...


6

You can customize the appearance of the footnotes with the footmisc package. Here's an example: \documentclass{book} \usepackage[hang]{footmisc} % do this \AtBeginDocument so that all font settings will be already made \AtBeginDocument{ % set the \footnotemargin to 1.5em at \footnotesize \footnotesize\setlength{\footnotemargin}{1.5em}\normalsize % set ...


6

Since you are already loading the geometry package, adjust the values for bmargin (the bottom margin) and footnotesep (the separation between the bottom of text body and the top of footnote text); for example: \usepackage[scale=0.75,bmargin=1cm,footnotesep=1cm]{geometry}


6

footmisc has no effect with the french option to babel enabled as the main language, unless one issues \frenchbsetup{FrenchFootnotes=false} because, otherwise, the code for “French footnotes” is used, which is not influenced by footmisc. It's also better to use the \url command that makes delimiters <...> useless. \documentclass{article} ...


5

minipages have their own footnote counter, which is called mpfootnote. When you use the option symbol* loading the package footmisc, it affects only the normal footnote counter. So, if you want the same behavior for minipages, you have to add the line \renewcommand\thempfootnote{\fnsymbol{mpfootnote}} in your preamble. MWE: \documentclass{book} ...


5

With scrextend, a package that is part of the KOMA-Script bundle, one can use KOMA's command \deffootnote[<mark width>]{<indent>}{<parindent>}{<definition>} with the standard classes for formatting footnotes. The following figure (taken from the KOMA-Script documentation) illustrates the different values: Inside the ...


4

This seems to work, at least if the footnote to the author is short. \documentclass[11pt]{article} \usepackage[bottom,flushmargin,hang,multiple]{footmisc} \usepackage{etoolbox} \makeatletter \patchcmd\maketitle{\hb@xt@1.8em}{\hbox}{}{} \makeatother \begin{document} \title{Title} \author{Joe Blow\footnote{Address}} \maketitle Hello.\footnote{This is a ...


4

A redefinition of \@makefntext will do the job (the modification is signaled %NEW in the example code below). The new length \margintomarker lets you control the distance from the margin to the footnote marker; the distance between the marker and the footnote text will be set using \footnotemargin: \documentclass{article} \usepackage[hang]{footmisc} ...


4

You can use the scrextend package: \documentclass{article} \usepackage{scrextend} \deffootnote[.5in]{.5in}{.195in}{\makebox[.5in][r]{\thefootnotemark.\hspace{.2in}}} \begin{document} Something.\footnote{Here is a footnote.} Something else.\footnote{Lorem ipsum dolor sitamet, consectetur adipiscing elit. Morbi risus lacus, suscipit vehicula ullamcorper a, ...


4

If a package option can be reverted/unset and how that may be done is a per-case question. It depends on what exactly the package in question does if the specific option in question is set. Package options generally don't have anything in common except that they're given as package options. An option may simply set a boolean flag... % somewhere in ...


4

One possibility is to redefine \@makefntext: \documentclass{article} \makeatletter \long\def\@makefntext#1{\parindent 1em\noindent \hb@xt@1.8em{% \hss\@textsuperscript{\huge\@thefnmark}}#1}% \makeatother \begin{document} Test\footnote{test} Test\footnote{test} \end{document}


4

The problem comes from this: \begin{minipage}[t]{\footwidth}\raggedright #1\end{minipage} Comment out the minipage environment, leaving only \raggedright #1 and you'll see the standard behaviour: in the page where the \footnote command is invoked, the footnoterule is drawn, and, if the whole footnote text doesn't fit in the page, the text is properly ...


4

Run-in (paragraph) typesetting of footnotes in (La)TeX is tricky. An introduction to the problems faced is section 9 of the documentation of the manyfoot package. With regard to the algorithm of footmisc, its para option needs to "mess about with the output routine" (footmisc documentation, p. 12). Page 13 of the footmisc manual states: We make a box out ...


4

You can't use both packages together. beamer has its own \footnote definition and you are destroying it if you load footmisc. I would probably simply fake the para look. E.g. \setcounter{footnote}{1} \footnotetext{osborne-rubinstein, \textsuperscript{2}test}


3

Are you trying to get rid of all space between the two levels of footnotes? LaTeX fights pretty hard to keep some space there. I think this is pretty wise, in fact. In your case, there are two things you could do to get rid of some excess vertical space: \setlength{\footskip}{0pt} \setlength{\footnotesep}{0pt} Also, given that you defined a footnote ...



Only top voted, non community-wiki answers of a minimum length are eligible