Tag Info

New answers tagged

5

This won't work. \uppercase is a primitive which will works ok for simple text, but not with arbitrary content, and not with complicated commands like \cite. In your case I also see no need to use it. The footnotes starts with an uppercase already in most cases. There is the \Cite command, and for the az-Zayn you can use \autocap: ...


3

Just use the endnotes package: \documentclass[man, a4paper, 12pt]{apa6} \usepackage{endnotes} \usepackage{kantlipsum} % for mock text \let\footnote\endnote \title{Title} \author{Author} \begin{document} \maketitle Main body.\footnote{footnote} X\footnote{Abc} \kant[1] X\footnote{Abc} \kant[2] X\footnote{Abc} \kant[3] \clearpage \theendnotes ...


1

If the footnotes should still resembles the traditional footnotes, but just on a separate page at the end of the document, you can capture each \footnote and replace it with a combination \footnotemark and delayed \footnotetext. \documentclass[man]{apa6} \usepackage[nopar]{lipsum}% Just for this example \let\oldfootnote\footnote ...


3

Here package polyglossia change the definition of \arabic to get Indian form of numbers ٣ ٢ ١ ... You can modify the format of footnote numbering by redefining the command \thefootnote \documentclass{memoir} \usepackage{polyglossia} \setmainlanguage{arabic} \setotherlanguage{english} ...


2

EDIT: It should work now. Proceed with caution. \documentclass{article} \let\oldfootnote\footnote \newcommand{\newfootnote}[1]{% \renewcommand{\footnote}[1]{ ##1}% \oldfootnote{#1}% \let\footnote\newfootnote } \let\footnote\newfootnote \begin{document} Lorem\footnote{Dolor\footnote{Sit\footnote{Amet}}} ...


2

This is a bad idea, sorry. TeXnically it may be possible to ignore the footnote command inside a footnote and nontheless print the text of the nested footnote. "Let's say² you have this sentence." The text of the footnote were: "²Just for the sake of the argument." Later you decide to move it into a footnote, you'd get this: "³Let's say Just for the ...


1

Note that this resets the footnote index to zero after printing. If you want non-repeating numbers or to use the footnote counter, that can also be done. \documentclass{article} \newcount\mycount \makeatletter \newcommand{\myFootnote}[1]% #1 = text {\global\advance\mycount by 1 \@textsuperscript{\@fnsymbol\mycount} \global\expandafter\def\csname ...


0

There is a particular use-case that I find occurring the most often to me: author and their affiliations cross-reference each other as it was mentioned above. For this particular case I use authblk package that works exactly as expected with most of the standard classes of documents: \documentclass{article} \usepackage{authblk} \begin{document} ...


0

I created a short command to do as @egreg suggests, avoiding this problem with the TOC and keeping a normal font size: \newcommand{\headingwithfootnote}[2]{ #1[#2]{#2{\textsuperscript{\normalsize\footnotemark}}}} ... \headingwithfootnote{\section}{Chapter Title} \footnotetext{The footnote text.}


2

You can use the verbatim package to define a new environment that defines a character to enclose the footnote text. \documentclass{article} \usepackage{verbatim} \textheight=3cm % just not to waste space \newcommand{\vfchar}[1]{% % the usual trick for using a "variable" active character \begingroup\lccode`~=`#1 \lowercase{\endgroup\def~##1~}{% % ...


4

Here is a version without the use of packages (i.e., works in plain verbatim environment). I make ? (or any char of your choosing) active and employ ! (or any char of your choosing) as a delimiter. With this syntax, ?!My footnote! is the equivalent of \footnote{My footnote}. \documentclass{article} \textheight=1.5in\relax% FOR THIS MWE ONLY ...


5

A minimal example reproducing the error is: \documentclass{article} \usepackage{hyperref} \begin{document} \footnote{\href{http://whatever}} \end{document} The solution: hyperref's \href has two arguments: \href{URL}{text}. Either use both or use \url{URL}: \documentclass{article} \usepackage{hyperref} \begin{document} ...


11

listings provides the possibility to escape to LaTeX inside a listing, see section 5.12 Escaping to LaTeX of the manual for details. The basic idea is to set an escapechar which switches to LateX and back: \documentclass{article} \usepackage{listings} \begin{document} \begin{lstlisting}[basicstyle=\ttfamily,columns=fullflexible,gobble=2,escapechar=ß] ...


3

The problem is caused by the fact that internally the footnote is using \glslabel to reference the entry but the definition of this command has changed by the time the footnote is processed. The simplest thing to do is to modify the style to ensure the label is expanded first, as in the modified example below: \documentclass{scrreprt} \usepackage{ragged2e} ...


0

Here are two alternatives: The first uses a different symbol to indicate the footnote. The second re-words the sentences to eliminate a use of footnote. \documentclass[12pt]{article} \usepackage[symbol*]{footmisc} \DefineFNsymbols*{lamport}{\dagger\ddagger\S\P\|% {**}{\dagger\dagger}{\ddagger\ddagger} } \begin{document} ... To fulfil this requirement, ...


2

Avoid footnotes to math material (and avoid footnotes in general). In this case you should at least have the footnote marker after the comma, but it's just less confusing. I'd reword the paragraph, taking also into account the fact that εmach is an important ingredient in the formula; footnotes should only contain material that can be skipped. ...


0

I suggest the following rewrite that does not need a footnote: ... multiplied by $1+\epsilon_\textnormal{mach}$ where $\epsilon_\textnormal{mach}$ is the smallest number such that $\epsilon_\textnormal{mach} + 1 > 1$. I fully agree with daleif that footnote markers (whether they are numerical or letters or symbolics) are just confusing when applied to ...


1

I found a solution by using the para* option of manyfoot to get rid of the initial indentation and then redefining \footnoteB. \documentclass{memoir} \setlength{\footmarkwidth}{\leftmargin} \setlength{\footmarksep}{0em} \footmarkstyle{#1\hfill} \usepackage[perpage,ruled,para*]{manyfoot} \DeclareNewFootnote{A}[alph] \DeclareNewFootnote[para]{B} ...


0

If the mainlanguage of the your document is set to arabic you can get what you meant with some customizations for \footnoteruleB and \footnoteB. \documentclass[11pt,a4paper]{memoir} \usepackage{polyglossia} \usepackage[series={A,B}]{eledmac} \setmainlanguage[numerals=maghrib]{arabic} \setotherlanguage{english} %%% FONTS %%% ...


1

Revert the setting to the original one. In the code below you may want to set \skipfootins to 6ex instead of 4ex. Experiment on your own. \documentclass{book} \usepackage[paperwidth=21cm,paperheight=12cm]{geometry} \usepackage{lipsum} \usepackage{etoolbox} % this is necessary \makeatletter % keep the original \footnoterule for minipage ...


1

Why don't you just do \renewcommand{\fixedfootnotetext{}} when you don't need anymore, or redefine it as something else?


2

Here a partial solution for your case (awaiting the final solution, which can be used in all situations), we modify the definition of \footnoteruleA and \Afootnoterule with : \makeatletter \let\footnoteruleA=\right@footnoterule \let\Afootnoterule=\right@footnoterule \makeatother The command \right@footnoterule from bidi draw an RTL footenoterule, and ...


1

This is how scrartcl does by default: The default configuration of the KOMA-Script classes is: \deffootnote[1em]{1.5em}{1em} {\textsuperscript{\thefootnotemark}} (section 3.14 of the manual) Here's a minimal example: \documentclass[ final, numbers=noenddot, a4paper, 12pt, oneside ]{scrartcl} ...


1

Following my solution to Biblatex: First citation as full reference and following citations ibid or - when interrupted - short citation we can redefine the cite:short macro of verbose-ibid.cbx \renewbibmacro*{cite:short}{% \printnames{labelname}% \setunit*{\nameyeardelim}% \iffieldundef{labelyear} {} {\printtext[bibhyperlink]{% ...


5

Redefine \footnoterule: \documentclass{article} \usepackage[paperwidth=21cm,paperheight=8cm]{geometry} \usepackage{lipsum} \usepackage{etoolbox} % this is necessary \makeatletter % keep the original \footnoterule for minipage \let\latex@footnoterule\footnoterule \patchcmd{\endminipage}{\footnoterule}{\latex@footnoterule}{}{} % redefine \footnoterule ...


0

I did this before you qualified that you only wanted this on pages with footnotes. Note that \FootnoteEnd is executed on the second page, but doesn't take effect until the third page. \documentclass[10pt,a4paper]{article} \usepackage{afterpage} \usepackage{lipsum} \newcommand{\repeatfootnote}{\empty} \newcommand{\againfootnote}% ...


5

a footnote is a "moving argument" -- it is saved up to be used elsewhere. when this happens, the contents of the footnote expand, and alphabetical control sequences end up with a space after their text. (in other words, "\infty" ends up as "\infty ".) ordinarily, this doesn't matter. but when a term is written out for sorting into an index, the space does ...


2

You can redefine your \footnote command so the marker is printed first in the text in one style via \footnotemarker, and the footnote is printed afterwards in the default style via \footnotetext. Using etoolbox you can use \AtBeginEnvironment to make such a change apply to specific environments. Here is an example changing the behaviour in quotations, with ...


2

Adding to OlivierBlanvillain's answer, the sepfootnotes package also provides the \sepfootnotecontent and \sepfootnote commands out of the box: \documentclass{article} \usepackage{sepfootnotes} \begin{document} \sepfootnotecontent{a}{So complex that I would prefer to pull out the footnote text.} This is a very long complex\sepfootnote{a} sentence. ...



Top 50 recent answers are included