Tag Info

New answers tagged

3

\documentclass{article} \usepackage{amsmath} \usepackage{unicode-math} \setmathfont{XITS Math} \setmathfont[math-style=literal,range={"00F0-"03D6}]{XITS Math} \begin{document} This will work: $\upmu\upalpha x$ $\mitAlpha$ But this will work: $\mathrm{\mu}$ $\mathit{\Alpha}$ \end{document}


6

How greek letter are typeset depends on the option math-style. With e.g. french both \upmu and \mu will be upright, with ISO both are italic. (I do find this confusing too, that \upXXX ends up italic ...). If you want to force upright mode for a single instance use a markup command like \mathup. \documentclass{article} \usepackage{amsmath} ...


2

Two versions, one without hyperref, one with it. No hyperref \documentclass{article} \begin{document} \section{\protect\boldmath Bold $\pi$} \end{document} With hyperref \documentclass{article} \usepackage[unicode]{hyperref} \begin{document} \section{\protect\boldmath Bold \texorpdfstring{$\pi$}{\textpi}} \end{document}


1

Unless using a special font, the macro\boldsymbol from amsbsy package should do. (Beware, that math typesetting will make the bookmarks weird if used unless \texorpdfstring with appropiate workaround is applied) \documentclass{article} \usepackage{amsbsy} \usepackage[unicode]{hyperref} \begin{document} \section{Not bold $\pi$} \section{Bold ...


1

Again there seems to be something being redefined. A simple solution is to define your own command, in this case \myomega. \documentclass{article} \usepackage[utf8]{inputenc} \usepackage[LFE,LAE,OT1]{fontenc} \usepackage[farsi,english,arabic]{babel} \mathchardef\myomega="0121 \begin{document} \selectlanguage{farsi} $\myomega$ \end{document}


3

The problem is due to how amsart uppercases the title. You solve it by adding \usepackage{textcase} that will use the safer \MakeTextUppercase command. \documentclass[a4paper]{amsart} \usepackage[utf8]{inputenc} \usepackage[english,greek]{babel} \usepackage{textcase} \begin{document} \title{τυχαιος τιτλος} \maketitle \end{document} It won't work with ...


5

I believe that if your system is set in a Latin locale, then fontspec automatically sets Script = Latin. \documentclass{article} \usepackage{fontspec} \setmainfont[Script = Latin]{CMU Serif} \begin{document} βγλθωχ \end{document} The font CMU Serif is designed so that it automatically substitutes certain Greek glyphs with more "Latin looking" glyphs if ...


14

You could load any font which supports these letters with help of the package fontspec (which requires Lua- or XeLaTeX): % arara: lualatex \documentclass{article} \usepackage{fontspec} \begin{document} \setmainfont{EB Garamond} ἁμαρτία \setmainfont{Linux Libertine O} ἁμαρτία \end{document} If you do not want to type the letters ...


12

Load babel for polytonic Greek. Depending on your preferences, you can use the transliteration or direct input. \documentclass{article} \usepackage[utf8]{inputenc} \usepackage[greek.polutoniko,english]{babel} \begin{document} \textgreek{<amart'ia} \textgreek{ἁμαρτία} \end{document}



Top 50 recent answers are included