Tag Info

New answers tagged

0

Actually, I do not understand the question. Your MWE doesn't work because of \usepackage{pgfplots}%<-- surplus \usepackage{amsmath}% not important for MWE \usepackage{amssymb}% not important for MWE \usepackage{xkeyval,tikz}%<--- surplus \usepackage{pgfplots}%<-- surplus \usepackage{pgfplotstable,filecontents} If I omit surpluses package your MWE ...


2

Indeed your legend to name is defined multiple times. Whatever you put in the \begin{groupplot}[#1] as #1 will be put on all axis plots. Doing: \begin{groupplot}[/tikz/font=\small,...] \nextgroupplot ... \nextgroupplot ... \end{groupplot} is thus equivalent to: \begin{axis}[/tikz/font=\small,...] ... \end{axis} ...


3

You don't need to use set layers to get what you want. Just axis on top is sufficient and axis on top itself sets layers. I have made the grid black just for illustration. If you insist on using set layers put it after \begin{tikzpicture} like \begin{tikzpicture} \pgfplotsset{set layers} But for this particular case, it is not doing much. You have ...


2

You are plotting the marks too and since those marks are too close to each other, the line looks thick. For this either remove + from \addplot or pass the option no marks to \addplot. Then the effect of changing colour can be seen. \documentclass{article} \usepackage{pgfplots} \pgfplotsset{compat=1.12} \usepgfplotslibrary{groupplots} \begin{document} ...


4

You can load subcaption and caption packages and use \captionof inside a node like \node[text width=6cm,align=center,anchor=north] at ([yshift=-5mm]my plots c1r1.south) {\captionof{subfigure}{Pressure relative (P/P)\label{subplot:one}}}; The node option textwidthis needed for\captionof` to work inside the node. ...


2

You can add the option ybar legend explained in page 211 of the v1.12 manual to the axis options. You can also use the area legend option in the axis options, explained on the same page of the manual. Note that I had to load the groupplots library and set the compatibility compat=1.12 in your MWE. \documentclass{article} \usepackage{pgfplots} ...


0

Another alternative: add \hspace*{-4cm} (adjust how many centimeters you want to achieve a nice centering). For example: \documentclass[]{article} \usepackage{pgfplots, alphalph} \usepgfplotslibrary{groupplots} \begin{document} \begin{figure} \hspace*{-4cm} \begin{tikzpicture}[font=\footnotesize\sffamily] \begin{groupplot}[ ...


1

You can use xtick={1,...,5}, xticklabels={A,B,C,D,E} in the options of \nextgroupplot. Change xtick={1...,5}, as you wish. Further don't use \it{...} as \it is tex command and it doesn't take an argument. Use \itshape as I did. \documentclass[]{article} \usepackage{pgfplots, alphalph} \usepgfplotslibrary{groupplots} ...



Top 50 recent answers are included