Tag Info

Hot answers tagged

3

i'm not familiar with pdfx, but it presumably takes the place of hyperref. it is, with very few exceptions, necessary for hyperref to be called last. you have pdfx first.


3

You don't need it. Only the dvips driver has problems to break links and needs breakurl. xdvipdfmx (used by xetex) works without it: \documentclass{article} \usepackage{hyperref} \textwidth=2cm \begin{document} \url{http://tex.stackexchange.com/questions/218196/breakurl-doesnt-work-with-xelatex} \end{document}


3

Set charsize option to 0pt to get auto size for text fields: \TextField[bordercolor=1 0 0,width=10em,charsize=0pt,name=box]{Thisisabox}


3

You need to set an anchor in the appropriate spot. This is done automatically when \refstepcounter is issued, but you have to do it manually when \@currentlabel is set without the help of a counter. An anchor can be set with \phantomsection (it's a bad name, though). \makeatletter \newenvironment{algorithm}[2]% {\medbreak \edef\@currentlabel{#1}% % ...


2

You could use the package's \hyperlink and \hypertarget macros. They don't require any counters, \refstepcounter actions, or redefinitions of \@currentlabel. Insert \hypertarget{<anchor name>}{<some text>} in the location to which the reader should jump. Insert \hyperlink{<anchor name>}{<other text>} in one or more locations from ...


2

Not introducing a spurious space before the url in the first argument to \href seems to solve the problem. I say 'seems' because I do not have access to that version of Reader or to Windows. Hence, I tested this with an older version on GNU/Linux. However, I reproduced the problem and tested the solution, so I'm guessing it is the same. (If not, let me know ...


1

The problem was that I used pstopdf, not ps2pdf. It seems like that TL2014 distribution does not have ps2pdf, so I had to install ps2pdf with ghostscript from brew for Mac OS X. brew install ghostscript


1

The relevant option should be backref=page, as this inserts the correct links to the page. In addition, the hyperref package should be loaded after the subcaption package, which is not needed in this minimal example at all. \documentclass{report} \usepackage{subcaption} \usepackage[backref=page]{hyperref} \begin{document} \chapter{Loranium} Lorem ...



Only top voted, non community-wiki answers of a minimum length are eligible