Tag Info

Hot answers tagged

5

Since you are using a KOMA class, the way to go is to use the tocstyle package: The code: \documentclass{scrreprt} \usepackage[ngerman]{babel} \usepackage[tocflat]{tocstyle} \newtocstyle{raggedstyle}{% \settocstylefeature[0]{entryhook}{\bfseries} \settocstylefeature[0]{leaders}{\hfill} \settocfeature{raggedhook}{\raggedright} ...


5

The only way I could get that many hyphens in that text is to force tex to prefer them, this shows various alternative settings \documentclass{article} \usepackage{ragged2e} \begin{document} \def\t{I want to hyphenate this sentence, but the presence of quadruple lines successively hyphenated} \noindent\mbox{\vrule\ \begin{minipage}[t]{3.1cm} ...


5

You can use the testhyphens package. \documentclass{article} \usepackage[british,welsh]{babel} \usepackage{testhyphens} \begin{document} \begin{checkhyphens}{} un casgliad credadwy traddodiadau athroniaeth mathemateg canolfan hapusrwydd blwyddyn deuddeg llongyfarchiadau cyfeiriadau \end{checkhyphens} \selectlanguage{british} \begin{checkhyphens}{} un ...


4

here's an adaptation of your file that will generate the hyphenations you seek: \documentclass[welsh]{article} \usepackage{babel} \begin{document} \showhyphens{un casgliad credadwy traddodiadau athroniaeth} \showhyphens{mathemateg canolfan hapusrwydd blwyddyn} \showhyphens{deuddeg llongyfarchiadau cyfeiriadau} \end{document} just process this with ...


4

Just load microtype and see, if it helps: % xelatex \documentclass{article} \usepackage{polyglossia} \setdefaultlanguage{english} \setlength{\textwidth}{6.3em} \setlength{\parindent}{0em} %\usepackage{microtype} \begin{document} I want to hyphenate this sentence, but the presence of quadruple lines successively hyphenated \end{document} Without: ...


3

If I add \usepackage[icelandic]{babel}, I get the following hyphenation points for those three words: Eyja-fjalla-jök-ull Hall-orms-stað-ar-skóg-ur norð-ur-ljós If you feel that the additional hyphenation points for those words are bad, you can add exceptions to the dictionary: \documentclass[a4paper,12pt]{report} \usepackage[T1]{fontenc} ...


3

If using LuaLaTeX is an option for you, you could use the showhyphens package (which requires LuaLaTeX) to show -- with a thin vertical red line -- every single hyphenation point that LaTeX thinks is valid. You won't need to go through all 100+ pages of your document; in general, checking the hyphenation points on just the first few pages will suffice. % ...


3

Assuming you are using a plain-like format with the babel hyphenation patterns available (so say pdftex or xetex) you can switch to the correct hyphenation using the fact that \lang@<name> is the language number. Thus \language\csname lang@welsh\endcsname \showhyphens{un casgliad credadwy traddodiadau athroniaeth mathemateg canolfan hapusrwydd ...


3

If your language is not Polish, then don't load the language. Just activate nohyphenation and you're done. In the example, \parbox{0pt} forces TeX to hyphenate as much as possible. \documentclass[a4paper, 12pt]{article} \usepackage{fontspec} \usepackage{polyglossia} \begin{document} \hyphenrules{nohyphenation} \hyphenation{al-a ko-ta mie-ć mu-si} ...


2

Hyphenation seems to work fine with babel (but I don't understand greek): \documentclass[paper=a6]{scrartcl} \usepackage{showhyphens} \usepackage{fontspec} \newfontfamily\greekfont{GFS Porson} \usepackage[greek]{babel} \languageattribute{greek}{ancient} \begin{document} \greekfont ΣΩ.\quad Οὑτωσὶ τοίνυν, ὦ παῖ καλέ, ἐννόησον, ὡς ὁ μὲν πρότερος ἦν ...


2

I think I'd be inclined to use Gonzalo Medina's answer given you are using scrreprt (and skip loading tocloft), but a tocloft solution isn't too tricky (and also useful for memoir users): \documentclass{scrreprt} \usepackage[ngerman]{babel} \usepackage{tocloft} \cftsetindents{section}{0mm}{12mm} \cftsetindents{chapter}{0mm}{12mm} \makeatletter % ...


1

In case anyone with the same question stumbles on this post: From latex@mdpi.com: Yes, this is intended that hyphenation is turned off in the mdpi.cls file.


1

With \AtEveryCitekey{\hyphenrules{nohyphenation}} in the preamble, hyphenation can be disabled for all BibLaTeX keys (the langugage nohyphenation must be defined in babel).


1

(Too long for a comment, but not really a solution.) Based solely on the code you've posted or given specific hints about, the following output is obtained with pdfLaTeX. Three normal en-dashes are generated, but no "funny characters". Do you get the same output if you load the package-which-you-are-not-at-liberty-to-share? \documentclass{article} ...


1

As pointed out by @egreg in the comments, \usepackage[icelandic]{babel} should give the correct hyphenation patterns. You can check this with the testhyphens package. \documentclass[a4paper,12pt]{report} \usepackage[icelandic]{babel} \usepackage[T1]{fontenc} \usepackage[utf8]{inputenc} \usepackage{testhyphens} \begin{document} \begin{checkhyphens} ...


1

A solution with the titletoc package: \documentclass{scrreprt} \usepackage[showframe]{geometry} %\usepackage[ngerman]{babel} \usepackage{ragged2e} \usepackage{fmtcount} \usepackage{titletoc} \titlecontents{chapter}[12mm] {\contentsmargin{10mm}\bigskip\sffamily\bfseries\Large} {\contentslabel[\MakeUppercase{\romannumeral\thecontentslabel}]{12mm}} {} ...



Only top voted, non community-wiki answers of a minimum length are eligible