Tag Info

New answers tagged

0

I have duplicated your set up and files and they work fine if you use the expected compile sequence. You need to run pdflatex first to generate the idx file. Then you need to run makeindex to create the needed aux file. And finally you need to run pdflatex again to get the pdf file. Note it will located in the build directory. The shortcuts which work ...


2

I suggest delim_1 "; " item_1 ", " in a separate longlines.ist since this make es clear distinction between index number and page number. The linebreak is from item_1 setting if not set as above. Add the options=-s longlines.ist to the \makeindex options list. \documentclass{article} \usepackage{lipsum} \usepackage{imakeidx} ...


6

What you have to do is to create a file named mystyle.ist with the following contents: item_1 ", " Then add the option options=-s mystyle when you are generating the index \makeindex[name=wdes,title=Initia Heirmorum,columns=1,options=-s mystyle] and you're done. MWE \documentclass{article} \usepackage{lipsum} \usepackage{imakeidx} ...


3

The \@idxitem and \subitem, \subsubitem commands control the indentation of the index entries relative to the left margin. The \subitem and \subsubitem commands use \@idxitem to indent further on. The correct value depends on the OP's preferences. \documentclass{article} \usepackage{blindtext} \usepackage{forloop} \usepackage{imakeidx} ...



Top 50 recent answers are included