Tag Info

New answers tagged

1

You may get this error also if you use different language for bibtex. In that case project.bbl may contain characters in different encoding (e.g latin2). What you need to do is swap encoding when rendering bibliography to latin2 and switch back to utf8 after. \inputencoding{latin2} \bibliography{mybib} \inputencoding{utf8} Hope this helps.


4

Since the file name encoding seems to be UTF-8, the file name needs to be reencoded from Latin-1 to UTF-8. This is also supported by package grffile: \documentclass{article} \usepackage[latin1]{inputenc} \usepackage{graphicx} \usepackage[encoding,filenameencoding=utf8]{grffile} \begin{document} \includegraphics{Bäckerstraße} \end{document} Alternatively ...


4

If you can use XeLaTeX or LuaLaTeX, I would like to welcome you to current century: \documentclass{article} \usepackage{polyglossia} % also loads package fontspec \setmainfont{Minion Pro} % or whatever OTF you have on your system \setmainlanguage{latvian} % loads language hyphenation rules and such \usepackage{unicode-math} % if you also need maths ...


4

\# \$ \% \& \~ \_ \^ \{ \} are very different types of commands, \% makes a percent but \^ does not make ^ it is a command that takes an argument \^{a} constructing accented letters. You can use \detokenize{@Model.ReportTitle} then you basically only need to quote \( \} and \% to ensure that the construct has balanced braces. and add ...


10

The letter š is supported by the T1 encoding and you should load \usepackage[T1]{fontenc} anyway. The “n with cedilla” is not supported by the fonts, so it must be composed. With newunicodechar it's pretty easy: \documentclass{article} \usepackage[T1]{fontenc} \usepackage[utf8]{inputenc} \usepackage{newunicodechar} \newunicodechar{Ņ}{\c{N}} ...


2

It's the older version: utf8x, but this works with pdflatex \documentclass{article} \usepackage[T1]{fontenc}% \usepackage[utf8x]{inputenc} \begin{document} diņš \end{document}


6

UTF-8 input is fine, you just need to tell tex what to do with that character: \documentclass{article} \usepackage[T1]{fontenc} \usepackage[utf8]{inputenc} \DeclareUnicodeCharacter{0146}{\c{n}} \begin{document} diņš \end{document}


2

As I explained in the comment, gb4e changes the category codes of character ^ and _, which makes CJK fail to decode Japanese characters. As is suggested in the gb4e doc, you can use \noautomath where you want to disable the special effects of _ and ^. Here is the solution. %!TeX encoding = UTF-8 %!TeX program = pdflatex \documentclass{article} ...


1

This is not a direct answer to your question, more a means of tracking down the problem. I have also had problems with undefined Unicode characters, so I add the following to my preambles: \usepackage{newunicodechar} \DeclareUnicodeCharacter{FFFD}{?????} The character FFFD is the Unicode replacement character. It enables a document to compile to ...


0

Use {\' e} and such, it's the safest route. =========== But in the interest of investigating the issue, I've tested putting latin1 instead of latin9 in the inputenc package, and same errors popped up I've tested utf8, and lo and behold, more information popped up: package inputenc error: Unicode char \u8:Â not set up for use with latex And this tells ...



Top 50 recent answers are included