Tag Info

New answers tagged

0

I ended up downloading and manually installing the mathtools package, this was easier I think than switching to an earlier version of miktex. I think emher is right and that this is a bug in miktex 5105 where those two packages just don't appear in the list. For anyone else with the same problem you can download the package here. To install the package I ...


0

It seems like there is a bug in the MikTeX 5105 basic installer. Using it ("basic-miktex-2.9.5105"), i encountered the issue stated here; the "mathtools" and "breqn" packages do not appear and the "mh" package installation fails with the error mentioned earlier. To circumvent this problem until a fix is released, download the net installer instead ...


1

As I use Ubuntu I have installed TeX Live and of course I use apt-get to install packages. I found that I was missing some files needed to compile my document. Using apt-cache as recommended in Method 1 above I found that texlive-latex-extra was the package I needed. However the download size was huge (327 MB). The essential package only, was easily ...


0

Texlive comes within the Ubuntu package management system. Start aptitude, synaptic, whatever, and search for texlive. I'd uninstall the manual setup you have and use the supplied packages. It'll save a lot of headaches.


4

The mh package has recently been split into mathtools and breqn, with different maintainers, and they certainly appear in MiKTeX Package Manager: Which version of mpm do you have?


1

The gui installer is called via ./install-tl --gui Note the double minus. Actually, you can use only one, I just find it more readable


2

Using LaTeX (realistically) requires a minimum set of packages in addition to the kernel itself. The team distribute them as required and tools, but there is further sub-division. For example, keyval is part of graphics which is part of required. The easiest way to get the minimum set is to install the collection defined to cover exactly this case tlmgr ...


0

R, rstudio and latex all are in there latest version. I think the problem is in OS X yesomite beta. I downgrade the system. It is working fine now. Thank you for your responses.


1

Old question, but this is a common problem. If you installed via MacTeX, TeX Live will end up in /usr/local/texlive, but I believe MacPorts installs under /opt by default (it did last time I checked, but it's been a few years). Hence, you do indeed have two conflicting TeX distributions, and you're running kpsewhich from the MacPorts install. If you enter ...


1

If you installed your fonts in TEXMFHOME, check the box for "Automatically enable fonts in my home directory" in TeX Live Utility's preferences, and it will run updmap for you after an update/install.


1

This is an old question, so note that I've tried to answer it in some detail at Reconfiguring Tex Live Utility for 2014. In short, the OP's solution of "I tried dragging the /usr/local/texlive/.../bin" should have worked, assuming the … was an actual path…but I'd need more details to know what happened. Since it started working after installing MacTeX and ...


0

Just install texlive-base with apt-get. Example: $ sudo apt-get install texlive-base [sudo] password for user: password Do you want to continue? [Y/n] Return Done! Also, this question should be asked on Ask Ubuntu instead.


5

suppose you have installed the TeXLive version from http://tug.org/texlive/ and now you want to install the editor Texmaker with apt-get install texmaker. Then Ubuntu's package manager tells you that you also have to install the TeXLive. This doesn't happen when faking the package manager of Ubuntu. If your Ubuntu uses the latest TeXLive version from Debian ...


8

Having the path to the TeX Live binaries in your path is indeed sufficient for other programs to find TeX Live. It is more of a question of installing the same thing twice (or rather a newer version and an older version). apt is the package manager of Ubuntu and it has no idea that you installed TeX Live unless you used apt to install it. Thus, if you don't ...


0

What happened to me was: in Ubuntu 11.10 I defined the environment variable TEXMFCN to point at my home directory $TEXMFCNF=$HOME/texmf/web2c export TEXMFCNF For some reason, after the upgrade to 14.04, the bash gave a different interpretation to my setting: to search the latex packages only in my home directory. So, commenting that line in ...


1

TikZ is not a "program", but a package for LaTeX (and other versions of TeX). If you just want to create graphics and don't know anything about (La)TeX you should make yourself familiar with that (e.g. by reading the article about LaTeX on wikipedia). If you are using LaTeX, you can use TikZ with \usepackage{tikz} if it is included in your TeX ...


0

You can install a much more minimalistic texlive using profiles. Have a look at this install script I use in my github repo. I have this install just the packages I need to build the PDFs using travis-ci: https://github.com/BPA-CSIRO-Workshops/handout-template/blob/master/developers/texlive_install.sh The profile file is in the same directory.


2

There is a problem with the autorun.inf file in TeXLive 2014. The instruction OPEN=install-tl.bat should be OPEN=install-windows-tl.bat. If you extract its content, you only have to double-click install-windows-tl.bat.


0

First make sure it isn't already installed — I thought it was part of the ‘basic’ installation. If you cannot have administrator privileges to install with the Package Manager, you can download from a repositoy babel-english.tar.lzma. Unzip it (twice) to get a texmf folder. You just have to copy the contents of this folder at the root of the MiKTeX ...


2

I could not install packages using tlmgr (I guess because, as jon pointed out, TL2013 is not maintained anymore). So I ended up using tlmgr uninstall to remove the TexLive "vanilla" installation, remove its path from $PATH, and reinstall the Ubuntu version from scratch. It is good enough for me for the meantime, although it's true that I ended up installing ...


0

This is just to have more space for a comment to Norbert. BTW: Shouldn't tex-common be added to that equivs build file provided on the TUG web page (In my case we mount TL via NFS for easier maintenance, so I'd like to not have any of these packages installed in the system). Just to be clear I do not have problems with maxima, my problem was with texmaker ...


1

A quick fix is to just put the .cls file next to the .tex file you're compiling (ie. in the same directory). Perhaps this is not a permanent enough solution for you (eg. if you're going to use this class file in many documents), but this is how I use IEEE's & OSA's journal class files (where once every few years at most I need to use a particular class ...



Top 50 recent answers are included