Tag Info

Hot answers tagged

13

The input conventions of BibTeX are rather strict; multiple authors must be separated by the and keyword: author={Alpher, Ralph and Bethe, Hans and Gamow, George} or, if you want to keep only initials, author={Alpher, R. and Bethe, H. and Gamow, G.} If you want only the first author and automatically add et al. in the bibliography, use the others ...


9

If you have the BibTeX-Code available and copy that to your clipboard (either by opening the export.bib or by copying it from the homepage) and you click on the JabRef window (so that it has the focus) you can just paste (Ctrl+V) it as a new entry. I knew that from BibDesk (Mac OS) which I am using and found the same for JabRef here ...


8

The format of JabRef is BibTeX! So of course you can export a subset of a database in that format. Open a database and select the entries you want Select "Save Selected as…" from the "File" menu Give a name to the extracted file Use the resulting .bib file % This file was created with JabRef 2.5. % Encoding: UTF8 @INCOLLECTION{Degani:2009, ...


7

It seems that you want chapterwise bibliographies. This can be done with bibunits which works together with natbib. Just put \putbib where you want the chapter bibliography and add the following to the preamble. \let\stdthebibliography\thebibliography \renewcommand{\thebibliography}{% \let\section\subsection \stdthebibliography} ...


7

Thank you everyone! I have experimented a bit further, and some nice folk at LaTex community helped me figure out what's wrong. In my 'Configure Texmaker', i actually had the wrong setting (as you can see form the screen cap) I changed it back to "bibtex %.aux" and now it works! And I also set the quickBuild to latex bibtex latex pdfLatex ...


6

You have run into this 7 year old bug that will be fixed for LyX 2.1 (beta to be released soon). bibtex is probably trying to tell you what's wrong but LyX is not passing that information on. To see the bibtex log, export to LaTeX (pdflatex) and compile manually with pdflatex and bibtex. If you don't understand the error, post it here. And yes, similar to ...


6

In menu Options -> Preferences -> File -> Select the radio button "Resolve strings for all fields except:" instead of "Resolve strings for standard BibTeX fields only".


6

The proper TDS-compliant setup is as shown below. Make a directory, say c:\mytexmf and put your bibtex files in c:\mytexmf\bibtex\bib\mypackages\... Add your local texmf directory to the latex search path by declaring it in MiKTeX: Start -> All programs -> MikTeX -> maintenance -> Setup Under the tab Roots add the path, say c:\mytexmf and ...


6

You can use arbitrary keywords that are not yet defined. They will be ignored by bibtex. In JabRef, you can add those fields in Options/Set up general fields.


6

You can change them in winedt through Options → Preferences and then backup tab as in the following picture: You can even create a sub folder by adding %p\Bakfolder\%n%t.bak so that all .bak files are created inside Bakfolder Similarly in jabref, you can go to Options → Preferences and then in File as in the picture ↓


5

A solution to your problem would be to add a script to your git workflow, that reformats your .bib-file. One such tool is biber in toolmode. Calling: $ biber --tool example.bib results in a nicely formated file called example_bibertool.bib: @ARTICLE{bib:farzaneh, AUTHOR = {Seyed Amir Farzaneh and Mehran Sohrabi}, BDSK-FILE-1 = ...


5

It is enough to carry only the .bib file. .bak files are the backup files created by JabRef and they are the copies of .bib files useful in case you damage the original file. Since you are modifying the bib file on different computers, it would be better to use some version control like Git or Dropbox etc so that synchronisation becomes easy, otherwise you ...


5

Perhaps the reason is that you compile with bibtex, not biber. Bibtex doesn't understand utf8 — not even 8-bit encoding. Probably you should use biblatex — in which case the syntax for loading the database and a bibliography style should be (for the alphabetic style, for instance): \usepackage[backend=biber,style=alphabetic]{biblatex} ...


5

You could use the cite package. By default, it will put a small amount of whitespace after each comma. If you want an ordinary interword space after the commas, include the space option; i.e., in your document's preamble, you should invoke the package as follows: \usepackage[space]{cite}


5

You can set up Jabref to automatically import a reference from Firefox into the current database, but it's somewhat arcane. Here is my solution under Linux: 1) Select Options -> Preferences -> Advanced -- and check "Listen for remote operation ..." I don't think it matters which port. 2) Create a small bash script (text file) named "jabref-import" that ...


5

I've noticed two things: The encoding of your document is latin9 (View > View Source > Complete Source), but The entries in your .bib file are written in UTF-8 fashion, which BibTeX doesn't support. So, try writing accented characters in your .bib the usual way, e.g. González > Gonz{\'{a}}lez etc. Also, check LyX wiki for useful tips regarding usage ...


5

In JabRef, go to Tools --> New Subdatabase based on AUX file, choose the .bib and .aux file belonging to your project. This will read the citation keys from the aux file, and extract the corresponding entries from the bib-file.


4

As Joseph Wright suggested in his comments as far as I am aware you cannot modify the behavior from options>>preferences. I also do not know of any plug in that would provide this support. I have never written a plug in for JabRef, but you might be able to pretty easily or you could make a feature request to JabREf: ...


4

In addition to the biblatex package you mention, you may also want to check out the biblatex-jura style.


4

JabRef is a program for managing BibTeX database (.bib) files but does not directly affect what happens in LaTeX. Adding a database to a .tex file does not add in the citations. You need either \cite or \nocite: the latter adds references to the bibliography without a citation in the text \begin{filecontents}{\jobname.bib} @article{demo1, author = {Other, ...


4

In order to successfully use BibTeX, you need to execute the following sequence of commands: run latex on the .tex file run bibtex run latex again run latex again The first pass of latex detects a citation command in your .tex file, as well as the \bibliographystyle{...} and \bibliography{...} commands. Then, running bibtex formats the citation based on ...


4

Note that JabRef is only a BiBTeX database manager. On my machine, with an open project, clicking the "Save All" (Ctrl+Shift+S) in TeXnicCenter does a refresh of the project structure, including that of a Literature database update if the project has been processed under BiBTeX. In TeXstudio to refresh the drop-down list of references after updating your ...


4

This is a minimal example showing two references of the IEEEexample bibliographic database that you probably have also. (Sorry because the Lyx is in Spanish, but I hope that you can identify without problems the corresponding windows in English): Note that the windows showing the bibliographic database show by default the style plain, that produce this ...


4

Adjusting the import settings: Options > Preferences > BibTeX key generator. Now deselect the option "Generate keys for imported entries":


3

A BibTeX database is a plain text file (.bib file): JabRef provides a convenient and powerful editing front-end but cannot store data in the file without it being in the source. As such, if you add custom fields to the database they will be in the .bib file and so JabRef will show them in the source tab (which is meant for low-level editing). It is of ...


3

When you edit the source bibtex files (i.e. the *.bib) then you must rerun the complete bibtex sequence. This must be done because pdflatex does not read the *.bib file directly, but the supporting input file *.bbl is constructed by bibtex, etal. However, in a more general sense, if you are using bibtex or biber you should always run the full sequence ...


3

To change the columns, go to Options⇒Preferences⇒Entry table columns. In the table, simply enter both field names separated by a slash, so e.g. journaltitle/booktitle. You can even combine more than two fields this way. The first non-empty field will be displayed in the entry table. This feature was implemented following feature request #438 author/editor ...


3

The comma in author names for BibTeX are reserved to write names as Lastname, Firstname. Different authors are separated with "and". While you can write Firstname Lastname (no comma), it is sometimes necessary to use the other form: when the last name contains several tokens as in Per Brinch Hansen. BibTex would think that Brinch is a first name, therefore ...


3

I don't know of anything that will work without bother. For Word 2007, Reference Manager will export Word's bibliography to Bibtex. The next release is intended to handle Word 2010 bibliographies. I have the impression that you can import the 2010 format sources.xml files into Word 2007, with Word 2007 dropping what it doesn't understand, but I can't ...


3

JabRef should remember the search method between uses: unless there is an issue with your installation, setting 'global search' on one use should result in this being the search method the next time you start JabRef. The 'Global search' option deliberately opens a second window with the results. It sounds like you are looking for a 'Filter' search, which ...



Only top voted, non community-wiki answers of a minimum length are eligible