Tag Info

Hot answers tagged

10

The line Babel <3.9l> and hyphenation patterns for 79 languages loaded. doesn't actually refer to the LaTeX babel package being loaded as a whole. Rather, it refers to the subset of functionality from babel which provides a mechanism for switching between hyphenation patterns. For pdfTeX and XeTeX this information has to be built into the format so ...


6

The space between chapterprefix and chapter is set by \chapterheadmidvskip. If there should be no additional space between this two lines you could use either \renewcommand*\chapterheadmidvskip{\par} or the new interface \RedeclareSectionCommand[innerskip=0pt]{chapter} \addchap changes secnumdepth locally, so \ifnumbered{chapter}. So your ...


5

The default font size in scrartcl is 11pt, in scrlttr2 12pt, and this matters for nodes as somewhere em or ex is used. So make sure that you are loading scrlttr2 with the same fontsize option: \documentclass[DIN, parskip=half,fontsize=11pt]{scrlttr2} or scrartcl with larger fontsize: \documentclass[parskip=half,fontsize=12pt]{scrartcl} Output of ...


5

I was late. The following supports Ulrike Fischer's answer. In pgfmoduleshapes.code.tex, it declares the default \pgfset{ inner xsep/.initial =.3333em, inner ysep/.initial =.3333em, This em depends on the default font/font size. In fact, the following test \newdimen\testdimen \testdimen.3333em \the\testdimen results in 3.9162pt and ...


5

Another way to do this (maybe this option wasn't present before) is by setting the refline=dateleft option, either as a documentclass option, or in the preamble like this: \KOMAoptions{refline=dateleft} This aligns both the city and the date to the left.


4

This translates your page layout into KOMA's terms. It may not make the requested changes because I don't know what they are meant to be. Your example does not include any chapters, let alone chapter titles, and it is impossible to guess which distance you are talking about or what is meant to align with what. Note that, as originally configured, your ...


4

Note that the unstarred version of \ihead sets only the content of the main page style while the starred version sets both. There is no need to use both if their argument ist the same. On the first page of a chapter the plain style of the current pairofpagestyles is used. So you could define \newpairofpagestyles[scrheadings]{specialchapter}{\ofoot*{}} ...


3

If I compile with TeX Live 2014, adding \showthe\linewidth, I get 418.25555pt With TeX Live 2015, instead, I get 8191.99998pt This is apparently due to a change in KOMA-Script classes. On the other hand, it doesn't make much sense to set the length to 0.75\linewidth in the preamble, because \linewidth is a length that varies in the document. You ...


3

Somebody has asked Markus Kohm a similar question. So there is now a suggestion for the headings on the KOMA-Script website (German): \documentclass[chapterprefix]{scrreprt} \renewcommand*{\chapterformat}{\thechapter\autodot} \RedeclareSectionCommand[innerskip=0pt]{chapter} \makeatletter ...


3

Use \documentclass[a4paper,pagesize]{scrreprt} \usepackage{typearea} %\usepackage{tikz} \begin{document} \KOMAScriptVersion \end{document} to ensure that A4 is used even if your KOMA Script version is older than 3.17 Explanation: All KOMA-Script classes load package typearea to set the page layout. With KOMA-Script versions older than 3.17 the ...


3

If the line above the chapter heading should only be inserted if the chapterprefix is written you could insert this line in \chapterformat. This works also for \chapter* and \addchap*. \documentclass[chapterprefix=true]{scrbook} \RedeclareSectionCommand[ beforeskip=0pt, afterskip=1\baselineskip ]{chapter} \usepackage{etoolbox} ...


3

I think the question is not clear enough. You are having a problem which you don't completely understand and you are asking for a particular solution that might not be what you really want. So here are a few shots in case one is exactly what you are looking for. The problem is that there's no sans serif bold italic in that particular font that comes by ...


3

I will only answer the first two questions. If you do not want the back address on top of the "Client" use the class option backaddress=false To set the to set the todays stamp automatically in spanish remove \usepackage{datetime} and remove \setkomavar{date}[Date]{06 July 2015}. Code: \begin{filecontents*}{template.lco} \ProvidesFile{template.lco}[] ...


2

There were some changes in KOMA-Script. \topskip is no longer automatically inserted before chapters. So you could use \chapterheadstartvskip{}. But I would suggest to use the new way for changing the space before and after section titles: \RedeclareSectionCommand[beforeskip=0pt,afterskip=.1cm]{chapter} Note that you will get a warning with version 3.17a ...


2

If you want to use both \leftmark and \rightmark in a one-sided document with package scrlayer-scrpage you have to set the option autooneside=false \documentclass[twoside=false]{scrbook} \usepackage{blindtext} \usepackage[ automark, autooneside=false % <- ]{scrlayer-scrpage} \clearpairofpagestyles \ihead{\leftmark} \ohead{\rightmark} ...


2

If you want to color only the lines you can load package ulem and define new commands for colored lines as suggested in its manual: \newcommand\sectionuline{% \bgroup\markoverwith{\textcolor{red}{\rule[-0.5ex]{2pt}{0.4pt}}}% \ULon% } \newcommand\subsectionuline{% \bgroup\markoverwith{\textcolor{blue}{\rule[-0.5ex]{2pt}{0.4pt}}}% \ULon% } Then you ...


2

Despite their name the usual way with KOMA-Script is to redefine \chapterheadstartvskip and \chapterheadendvskip: \documentclass[chapterprefix=true]{scrbook} \renewcommand*\chapterheadstartvskip{\noindent\rule{\linewidth}{4pt}\par} \renewcommand*\chapterheadendvskip{\noindent\rule{\linewidth}{2pt}\par\vspace{\baselineskip}} \usepackage{blindtext} ...


1

From main menu: Document>Settings...>Page Layout Then click on checkbox for "Two-sided document". Regards


1

This was in fact not a TeX problem, but merely a printing problem. I have found the appropriate printing settings so that the page does not get scaled down (by a factor approx. being 0,97) to fit into the printable area of the printer, but the printable area gets cut out from the PDF. Thanks!


1

Here is another suggestion using \newkomafont to define a font style for this element. This also works if there is a table of contents. \documentclass{scrartcl} \newkomafont{frequentlyusedmacro}{\bfseries\itshape} \newcommand*\FrequentlyUsedMacro{{\protect\usekomafont{frequentlyusedmacro}Macro}} ...


1

Here is another suggestion without etoolbox and without \makeatletter ... \makeatother: Each of the KOMA-Script classes scrartcl, scrreprt und scrbook define the command \partmark. Hence I can redefine this command to set a new defined mark. \automark[section]{chapter} \newmarks\currentpart \renewcommand\partmark[1]{% ...


1

EDIT: I changed the code to a MWE. With the two commands you can print the taxes only or the sum of both values. You can place them wherever you want them to appear. \documentclass{standalone} \usepackage{pgf,pgfmath} \pgfkeys{/pgf/number format/.cd, fixed, fixed zerofill, precision=2, set thousands separator={.}, set decimal ...


1

Note that the following suggestions are limited to chapter headings with only one line. One possibility is appending the gray rule to \chapterheadstartvskip: \documentclass{scrreprt} \usepackage[utf8]{inputenc} \usepackage{blindtext} \usepackage[T1]{fontenc} \usepackage{xcolor} \usepackage{calc} \usepackage{etoolbox} \appto\chapterheadstartvskip{% ...



Only top voted, non community-wiki answers of a minimum length are eligible