Tag Info

New answers tagged

4

Labels are also nodes. So TiKZ is setting each label in a circle. Since larger labels need larger circles, those labels are set further away from the labelled node. You can avoid this by explicitly specifying the usual rectangular shape for labels: \documentclass[tikz]{standalone} \begin{document} \begin{tikzpicture} [ every node/.append ...


2

You probably mean that the \label commands should be processed only the first time the file is input. Start the file to input with \ifcsname thisfilehasbeeninput\endcsname \global\expandafter\let\csname thisfilehasbeeninput\endcsname\relax \else \makeatletter \let\latexlabel\label \def\label#1{\@bsphack\@esphack} \makeatother \fi and end ...


3

You can add a macro to all the labels in the inputted file and either reset it manually or use \thechapter (for example). \documentclass{report} \usepackage{mathtools} \begin{document} Equation \eqref{first.1} and equation \eqref{first.2} are copies. \chapter{Main} \begin{equation}\label{first.\thechapter} a=b \end{equation} This references the local ...


0

As @Steven B. Segletes, you have to add empty lines by hand. I want to draw your attention to the fact that it's much simpler to use the enumitem package, which already has a multiline style for description labels. It could go like this: \documentclass{article} \pagestyle{empty} % produces empty heads and feet -- no page numbers \usepackage{enumitem} ...


2

You can use a second \addplot+ command to add a second meta entry. Use color=black istead only draw=black to get black stars and error bars. Use ymax=1.05 to enlarge the y axis a little bit. \documentclass[margin=10pt]{standalone} \usepackage{pgfplots} \pgfplotsset{compat=1.11} \usepackage{filecontents} \begin{filecontents}{data1.dat} X Y Y_error Label ...


0

I'm not sure if it will help but I had similar problem. I had solved it with putting this into document preamble: \pgfplotsset{compat=newest} Source


4

Amsmath sets \let\label=\@gobble in align*. \documentclass{article} \usepackage[utf8]{inputenc} \usepackage{amsmath} \begin{document} \let\goodlabel=\label \begin{align*} J &= J_0 + 2 m r^2 & \refstepcounter{equation}\goodlabel{eq:asdf}(\theequation) && \tilde{J} &= J_0 + 2 m \tilde{r}^2 ...


3

I have just recently set up Asymptote and Ghostscript on a new machine and run into exactly the problem you describe with 3D figures that used to work (affecting not just labels but other things, and causing an error when attempting to add axes3 with labels and other labels later on). After a bit of hunting around for a couple of days and not seeing anything ...


1

Here is a suggestion using the package scrlayer-scrpage \documentclass{scrbook} \usepackage{lipsum} \usepackage[manualmark]{scrlayer-scrpage} \clearpairofpagestyles %%% alternatively: %\usepackage[manualmark]{scrpage2} %\clearscrheadfoot %\pagestyle{scrheadings} \chead{\pagemark} \lehead[\rightmark]{\rightmark}\rohead[\leftmark]{\leftmark} ...


1

As far as I can see, the cause of the original error message was the auto option, which seems to be incompatible with the way currents are typeset in circuitikz. I ran into the same problem and had to debug for quite some time before I found out that the culprit was a \tikzset{auto} that I had in the file header, that I needed for a number of other tikz ...


4

You can use \dtlexpandnewvalue to expand the \ref in \sortitem. However, this can only be done once \ref has been defined and which is only after the .aux file has been created. Hence, the following is the output after the second run: During the first run this will be displayed as: Notes: To allow for use with hyperref I now check to see if ...


2

I suggest you insert the instruction \phantomsection between \newpage and \begin{minted}. The purpose of this instruction is to provide an "anchor" of sorts for hyperref, so that a cross-reference to an object that doesn't have an automatic counter associated with it will still take you to the intended location within the document.



Top 50 recent answers are included