Tag Info

Hot answers tagged

21

The Vim-LaTex / LaTeX-Suite for Vim adds these markers automatically and by intension. You can jump to the next such marker using CTRL+J, which removes this marker. The idea is to speed things up by allowing you to jump to the end of the group or environment which was just added. This is also useful for templates where you can add <+name+> markers ...


7

The following works on my end: Create a file called latexmk.vimrc in the current directory with the following content set nocompatible filetype plugin on set grepprg=grep\ -nH\ $* filetype indent on let g:tex_flavor='latex' let g:Tex_DefaultTargetFormat = 'pdf' let g:Tex_CompileRule_pdf = 'latexmk -pdf -f $*' set iskeyword+=: Call vim -u latexmk.vimrc ...


7

There are no real standards, but here are some tips I’ve found handy: Don’t indent parts of a paragraph, but do break lines between sentences and after significant phrases within a sentence. As I posted at http://tex.stackexchange.com/a/64538/2966, this makes it easier for small edits to have small diffs. (You are using a VCS, aren’t you?) To exaggerate my ...


6

Something that is pretty much as useful is to type nameofenvironment then F5 which gives \begin{nameofenvironment} \end{nameofenvironment}<++> and puts the cursor in the body of the environment. You can leave the environment easily by pressing CTRL J


6

If you are using Adobe Reader or certain other PDF readers it locks the file. I don't know what OS you are on, but based on discussion in the chatroom Reader only locks the file on Windows. If you are indeed on Windows switch to Sumatra PDF, which does not lock the file. I don't know what linux or Mac PDF readers lock the file, but you should try switching ...


6

I stumbled upon this one today, as also already posted above. http://michaelgoerz.net/refcards


6

A first approximation would be to indent every line starting with a lower case letter by 4 spaces so a regex replace s/^\s*([a-z])/ \1/ in sed or perl or emacs or vim (I assume:-) LaTeX doesn't even see any white space at start of line except in verbatim environments so it doesn't matter what indentation you use as far as LaTeX is concerned.


4

Normally, you should have {}<++>, where <++> is a placeholder where you can jump using Ctrl+J. It seems like the delimiters for placeholders have been replaced by {}. From the documentation of latexsuite, maybe you should verify the value of the variables Imap_PlaceHolderStart and Imap_PlaceHolderEnd to check whether these have respectively been ...


4

Checkout your vim setting of backspace via :set backspace?. If it doesn't contain start you should add this :set backspace+=start (help :h 'backspace') to get the expected behavior of vim-latex. Honestly, I think this should be noted somewhere in the vim-latex documentation or even set automatically by the plugin since it relies on it.


4

A few initial comments: I’m assuming you’re using the multirow package to try to print the multiple columns (you didn’t say, but it seems like the natural choice). I’d suggest using the siunitx package to align the decimal points in your table. The booktabs package has some good advice for nice-looking tables in LaTeX in the documentation. I’ve used it ...


4

It allows you to jump outside of the grouping operators by pressing CTRL J When you press CTRL J, the cursor takes you to the position, deletes the <++>, and leaves you in insert mode, ready to type. Once you get used to it, it is a very useful device and huge time saver. You'll also find the <++> device if you type enumerate and then press F5 ...


4

Not a "solution" to your problem, but I found the folding feature to be mostly in the way. The line let g:Tex_AutoFolding = 0 in my ~/.vimrc "solved" that problem for me. ;-)


4

If you press F5 when the cursor is located outside \begin{document}...\end{document}, latex-suite lets you add packages, i.e. it inserts \usepackage statements. Moving the cursor inside the document section should lead to the desired behavior.


3

If your list of lines is surrounded by blank lines, the following mapping will work: :map <f6> {jV}:s/^../\\item/<cr>{jV}k<f5>itemize<cr> Place the cursor anywhere in your numbered list and press F6 Update A more general approach is to search backwards until the first line which does not start with a digit, and select from that ...


3

let g:Tex_GotoError=0 in your ~/.vimrc should do pretty much what you want.


3

You can edit the highlight for texItalStyle and texBoldStyle. I prefer to simply clear them by doing: hi clear texItalStyle hi clear texBoldStyle You can find the highlight group of the text under the cursor by running the mapping provided here.


3

I think this is the expected behaviour in vim-latexsuite and it may just be a bug in the quickstart tutorial. If you want to change to get this \begin{eqnarray} \label{}<++> \end{eqnarray}<++> with the cursor in between the label brackets, you can define the following variable and then type eqnarray followed by F5. let g:Tex_Env_eqnarray ...


2

I just tested this out and it appears the problem you are having is that after compilation the cursor is left in the document and not in the error list. Moving between windows can be done simply with CTRL-W CTRL-W (this moves to the 'next' window - there are more window switching keystrokes - look them up with :help CTRL-W). Once in the error window hitting ...


2

You can use \lq and \rq for the left and right quote, respectively. It may be quicker than deleting one of keyboard quote signs, indeed. Probably a quicker solution is a definition for both quotes, e.q. \def\bsq#1{%both single quotes \lq{#1}\rq}


2

There are several tools which can can help you. arara The cool tool arara provides several rules to specify all compilation steps from inside the document. For example you want to compile with pdflatex+bibtex+pdflatex you need the following lines in the preamble of the main document: % arara: pdflatex % arara: bibtex % arara: pdflatex After this ...


2

LaTeX Suite's help provides quite a bit of information of such mappings. Quoting from the help file Changing commands *ls_3_2_3* *ls_a_br* *changing-commands* *ls-vmap-f7* *ls_a_dY* In both insert ...


1

There two plugins which support latexmk within vim: LatexBox and AutomaticTexPlugin The last one has also built-in method to compile documents in the background (live updates) and shows a progress bar. It also has a very good completion, see the feature list.


1

I put let g:Imap_FreezeImap=1 in my .vimrc. It should disable all of this annoying “magic”.


1

Side note for anyone who ends up here looking for the same thing I am: To disable specific IMAPs, add trivial IMAP commands to the file ~/.vim/after/ftplugin/tex.vim (you may have to create it if it does not exist). For instance, " Undo stupid latex-suite macros call IMAP('()', '()', 'tex') call IMAP('{}', '{}', 'tex') call IMAP('[]', '[]', 'tex') call ...


1

You may use this command : :!pdflatex articles.tex && mv articles.pdf proj_name.pdf but you have to change manually the command for each case.


1

I have encountered the same problem as the OP, and I found that it is caused by the neosnippet configuration, which contains the folloing lines: " For snippet_complete marker. if has('conceal') set conceallevel=2 concealcursor=i endif The neosnippet plugin probably uses the 'conceal' feature of vim for some of its autocompletion functions. The solution ...


1

The vim-latex installation instructions say to put the files into ~/vimfiles if you are running on Windows. Neither of the paths you mentioned above seem like they would be ~/vimfiles. My interpretation of those directions would be to put the files into a vimfiles directory in your windows home directory - same place that your _vimrc file would be.


1

I'm using a powershell script under windows to this end, I found it years ago here: http://uweziegenhagen.de/?p=2095 The first sentences on this page in German simply says something like »... after I found out how to make powershell work on a certain path, we can easily write a script which deletes all temporary files in a certain folder«. So take this ...


1

you could use :!del *.aux *.log *.out *.bbl *.blg ... in vim and map this to a key you like (F11 for instance) in your vimrc file.



Only top voted, non community-wiki answers of a minimum length are eligible