Tag Info

New answers tagged

8

With kind help from @cfr, you've established that: The font does contain ligature glyphs. fontspec can't make use of AAT ligature information even if it's available. The font omits OpenType feature data necessary for automatic ligature support. So what can you do? You can either add the missing mapping data to the font, or create an external OpenType ...


1

Not really an answer, but to be able to show some pictures ... I get with this example the following outputs on windows. So it could be that there is bug in the miktex xelatex. But I don't know if you are using it. \documentclass{article} \usepackage{fontspec} \usepackage{polyglossia} \setmainfont[Script=Devanagari]{Nakula} ...


4

After a few false starts, it became clear that || is the result of a ConTeXt convention, and for reasons more interesting than mere caprice. From ConTeXt's lang-mis.mkiv file: One of TEX's strong points in building paragraphs is the way hyphenations are handled. Although for real good hyphenation of non-english languages some extensions to the ...


5

Using || for producing a double em-dash is abusing the system. The fact that | produces an em-dash, when the output font encoding is OT1, is purely incidental and should never be relied upon. The “right” way in TeX/LaTeX for obtaining an em-dash is by typing --- and this works also with fontspec, provided the Ligatures=TeX option, that's activated by ...


12

You have to add the german shorthands, which knows several "-shorthands: \documentclass{article} \usepackage[ngerman,american]{babel}% american still active at \begin{document} \useshorthands{"} \addto\extrasamerican{\languageshorthands{ngerman}} \begin{document} shelfful shelf"|ful {shelf}ful shelf{}ful shelf\/ful \end{document} The german shorthands ...


0

In the end I decided that typing unicode characters directly as David Carlisle suggested was the way to go for my problem. It avoids hacking the Latex parser and the formulas in my text file are much more readable. The biggest hurdle was figuring out how to input unicode characters on linux without having to change the text editor I was using. In the end, I ...



Top 50 recent answers are included