Tag Info

New answers tagged

2

tabularx affects the setting of multiline cells, and the only column for which you had more than one line you were not using X. Also I removed some packages to make your example more minimal (they generate missing font errors as posted for me) This just used X and removes pbox: %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%% %% (UTF-8/XeLaTex) ...


3

Don't use \pbox. \documentclass[12pt,a4paper,oneside,openany]{book} \usepackage{fontspec,tabularx,amsmath} % For multiletter symbols \DeclareMathOperator\Real{Re} % cf plain TeX's \Re and Reynolds number \DeclareMathOperator\imag{Im} % cf plain TeX's \Im \newcommand{\constant}[1]{\mathit{#1}} \newcommand\Rey{\constant{Re}} % Reynolds number ...


1

REVISED SOLUTION to eliminate use of \pbox. Here, I replaced your use of the \pbox with a \stackanchor, with extra vertical separation provided by way of \addstackgap. I wrapped it all up in a newly defined macro \mystack{}{}. In that definition, the [3pt] and [6pt] vertical gap specifiers may be changed to suit. \documentclass[12pt,a4paper]{book} ...


2

Just wanted to add to the answer of @Tahtisilma that you can also use \hyphenation{wo-rd, w-ord} to manually set hyphenation patterns for specific words in you document. Also, \phantom{word} will act as if "word" was printed, except that it isn't. Great little trick for last-ditch fine-tuning of spacing where \hspace{} doesn't work (note: not in this ...


9

It is better to use an enumerate list to do what you're doing. If you want to reproduce exactly the same output, load enumitem and use the following settings leftmargin=0pt,align=left,labelsep=10pt,itemindent=*,label={\bfseries\alph*.} MWE: \documentclass[a4 paper,11pt]{article} \usepackage{amsmath, amsfonts, amssymb, parskip, dsfont, amsthm, wasysym, ...


5

LaTeX is hyphenating. The problem is that you provide LaTeX with space at the start of enumerate, that can stretch (the default space). Delete the spaces at the beginning and the problem goes away. By the way if LaTeX does not know the word or you want different breaks you can use \- e.g., ans\-wer. \documentclass[a4 paper,11pt]{article} ...


5

Just using the enumitem package seems to solve the issues: Without using an enumerate type of environment, you can use an \mbox to ensure that you get consistent spacing -- although I would not recommend this: Code: \enumitem \documentclass[a4 paper,11pt]{article} \usepackage{amsmath, amsfonts, amssymb, parskip, dsfont, amsthm, wasysym, mathrsfs} ...


5

The left frame is drawn by pieces of rules as high as a strut, but with \baselinestretch set to 0.8 some characters are higher than a strut. You could solve by changing the way the rules are computed, for instance with \documentclass{article} \usepackage{listings} \usepackage{setspace} \lstset{basicstyle=\footnotesize\ttfamily\selectfont, ...


3

sectsty only updates only the sectional unit font-related setting but still use the traditional \@startsection construction: \renewcommand\section{\@startsection {section}{1}{\z@}% {-3.5ex \@plus -1ex \@minus -.2ex}% {2.3ex \@plus.2ex}% % {\normalfont\Large\bfseries}} {\normalfont\Large\bfseries\SS@sectfont}} ...


0

I finally solved this using the package setspace, and wrapping my TOC in a spacing environment as follows: \usepackage{setspace} \begin{spacing}{1.8} \tableofcontents \end{spacing} For line spacing of, for example, 1.8.


2

Issue a manual \par within the tiny block to force the paragraph to be set using the \tiny specification. However, you can avoid this by using a \parbox directly: \documentclass{beamer} \usepackage{blindtext} \begin{document} \blindtext \parbox{\linewidth}{\tiny \blindtext} \end{document}


5

If you want to do this inside all of your figure environments, use etoolbox and its \AtBeginEnvironment macro Put the following in your preamble: \usepackage{etoolbox} \AtBeginEnvironment{figure}{\renewcommand\arraystretch{1.3}}{}{} Full code: \documentclass{article} \usepackage{lipsum} \usepackage{setspace} \usepackage{etoolbox} ...


2

Here, I create myfigure environment to do what you ask. \documentclass{article} \usepackage{lipsum} \usepackage{setspace} \newenvironment{myfigure}[1][htbp]{\figure[#1]\renewcommand\arraystretch{1.3}} {\endfigure} \begin{document} \setstretch{1.3} \lipsum[1] \bigskip \begin{tabular}{ r | r | r } 7168 & 1623040 & 28.30 \\ ...


5

The line spacing of a paragraph is done, when TeX breaks the paragraph into lines. This happens at the end of the paragraph. In the case of the question, environment explain uses \setstretch{0.1} and \footnotesize. At the end of the environment, the paragraph has not yet ended, but the environment does. Therefore the local settings of the environment are ...



Top 50 recent answers are included